Introduction

ProEngineer Wildfire2 is a computer aided design (CAD) program that is used to create models on a computer in three-dimensions. Since three dimensions are used the models mimic real parts in the way that they are constructed. The models are sometimes referred to as virtual parts since at the design stage they only exist within the computer. Most of the models made in ProEngineer Wildfire2 are termed solid models which implies that the computer has a full understanding of the solidity of the part i.e. the computer 'knows' where there is material and where there is empty space. Solid modellers use commands to construct models that reflect manufacturing techniques, such as extrude and cut, combining these to make complex shapes.

ProEngineer Wildfire2 is a fully parametric CAD program. This means that when a part is designed and modeled dimensions are assigned which define the part. If, at a later time, these dimensions are found to be unsuitable they can be easily changed and the modification will filter through the system wherever the part appears. This is particularly helpful when dealing with collection of parts (known as an assembly) since if a modification is made to a single part, the modification is carried throughout the assembly. A designer can also define relationships between parts. For example, in an engine, if the diameter of the piston is increased or decreased, the corresponding engine block can be defined such that it is automatically modified to match the specifications of the modified piston.

Using any CAD system complex models need to be built by combining simpler shapes. In ProEngineer Wildfire2 these simpler shapes are called features. Several features are combined to form a part. Using Figure 1 as an example the part shown diagrammatically is made up of four features as follows:-

1. A rectangular block of material is created.
2. Removing material from the block creates a slot.
3. Finally material is removed to form a large hole.
4. Material is again removed to make four small holes.

Later tutorials will explain how several parts can be combined to form assemblies as shown in Figure 1.

Creating a Part

In this tutorial we will introduce you to some basic modeling concepts including creating parts, creating basic features, sketching and saving information. Before starting to work through this tutorial you need to be sitting in front of a computer which has access to ProEngineer Wildfire2 and be logged on. You tutor should have advised you of how to log in already.

Start ProEngineer Wildfire2 by double clicking on the icon on your desktop or from the START menu. The main application window should appear shortly.
Introduction To Modeling

After choosing the new command a dialog box will appear as shown in Figure 3. Notice that the Part option is already checked and type in calculator as the name of this part (Note: ProEngineer does not allow spaces and other special characters in names).

A second dialog will appear offering different options for parts – in particular different units of measurement. Choose mmns_part_solid which means the units of length will be millimetres and units of mass will be Newtons and click on the OK button.

Well done – you have made your first part! The part contains some features already. The browser on the left of Figure 5 shows 3 datum planes and a coordinate system. So what are datum planes? As the word plane implies these are flat areas that can be used as references for defining parts of your model. In some case you can define models without any datum planes, in other cases they are essential. Many people choose to always have a basic set of default datum planes (like the ones in your model) defined as a starting point for their model. Datum planes are displayed as rectangles that are just big enough to enclose the model. They are given names by the system such as RIGHT, TOP and FRONT. You will see datum planes drawn in either brown or black. This is to distinguish between the two sides of the datum. If you looking exactly onto the edge of a datum plane you will see two parallel lines drawn representing the two sides of the plane.

Figure 2: ProEngineer Main Window
You will see the normal Windows features – menus, toolbars, a main graphics area and on the left side a browser window.

The next step is to create your first part. To do this use the menu FILE > NEW. As you click on this menu notice the small picture to the left of the word New… This is the icon for the NEW command. You could choose this icon from the toolbar below the menu if you prefer. Generally in this tutorial the menu command is given but you will often find the icon more convenient so look out for them.

Figure 3: The New Part Dialog Box
After choosing the new command a dialog box will appear as shown in Figure 3. Notice that the Part option is already checked and type in calculator as the name of this part (Note: ProEngineer does not allow spaces and other special characters in names).

A second dialog will appear offering different options for parts – in particular different units of measurement. Choose mmns_part_solid which means the units of length will be millimetres and units of mass will be Newtons and click on the OK button.
Now let’s start modelling. Figure 6 shows the finished model we are going to make – it is a child’s calculator. As with any model you make there are lots of options as to how to approach the modelling process. We will describe one approach here – but there are others. The model is made from a series of building blocks called features. In general try and use as few features as possible but also keep each feature as simple as possible.

**Extrusions**

Choose INSERT > EXTRUDE from the menu. Note the icon for this command which also appears to the right of the screen – it is a very commonly used command. You should see a new toolbar appear like the one in Figure 7. This is called the dashboard and contains all of the options for the type of feature you are creating.

The starting point for our calculator will be a simple rectangular block of material made by a technique called extrusion.

To start creating this feature click on the PLACEMENT menu in the dashboard – highlighted in red – then press the DEFINE button. The Sketch dialog appears. Notice that this dialog has many fields but the sketch plane option is highlighted in pale yellow awaiting your input. The sketch plane is a flat surface onto which you will draw your shape. Choose the datum plane TOP by clicking on it in the graphics window or in the browser. The other fields in the Shape dialog are filled in automatically so you don’t need to worry about them at the moment – just click on the SKETCH button.

The graphics screen will change to a black background looking directly on to the sketch plane, and the icons described in Figure 9 will appear. You should also see a References dialog. References are used by ProEngineer to locate dimensions. ProEngineer guesses at suitable references and in this case will have chosen the Right and Front datum’s as shown in the main graphics window by the dotted lines. This is a good choice in this case so you can CLOSE this dialog.

You are now ready to use sketcher. Choose the rectangle tool and draw the rectangle with two clicks as shown in Figure 8.

---

**Figure 5 : Start of the Part**

**Figure 6 : The Toy Calculator**

**Figure 7 : The Dashboard**

**Figure 8 : Outline Sketch**
that you drew the original rectangle. You will also notice that constraints have been created. These are indicated by the small symbols next to each line. V stands for vertical and H stands for horizontal.

Now to set the size of the rectangle to the correct value, choose the selection tool and double click on each dimension and type in the required value from Figure 8.

The dimensions will now be in yellow indicating that they have changed and the shape will change to the sizes entered. To end sketching press the icon. To complete this first feature type 12 into the numeric field of the dashboard (See Figure 7) and click the green tick to finish.

To see this block in all its glory choose the command VIEW > ORIENTATION > STANDARD ORIENTATION and try the different display option icons. You can also look around your design – press the middle mouse button and move the mouse to spin the model around. Middle mouse button and SHIFT key moves the model around the screen. Middle mouse button and CTRL key zooms into the model – you can use the mouse wheel for this too.

Figure 9 : Sketcher Commands

Your window should now look like Figure 8 but the numbers in the dimensions will be different. If the dimensions aren't positioned exactly as in Figure 8 don't worry, just choose the select tool and click and drag the dimension text to a new position. You will notice that the dimensions are drawn in grey. This indicates that they are so called 'weak' dimensions. Weak dimensions will be automatically replaced if they become unnecessary.

The drawing you have made defines the SHAPE of the feature. To fully define the feature ProEngineer has automatically added dimensions that define the SIZE. The values of the dimensions are determined by the size
Introduction To Modeling

Let's make another extrusion on top of the first. Choose the command VIEW > ORIENTATION > STANDARD ORIENTATION to make sure you are viewing the model correctly then choose INSERT > EXTRUDE from the menu. Start to draw a new sketch as before by clicking PLACEMENT then DEFINE. The sketch plane option in the Shape dialog option is highlighted in pale yellow awaiting your input. The sketch plane for this feature is the large flat surface of the first extrusion (see Figure 11a) so click on this surface in the graphics window. Now click on the SKETCH button.

We need to define some extra references in the sketcher. References are used to locate dimensions but they also allow you to 'lock' your drawings onto existing edges. Whilst the references dialog is open click on the four edges of the original extrusion – you may just see some dotted lines appear on them (see Figure 11b). Now close the references dialog and draw the rectangle shown in Figure 11c – you should notice the cursor locking onto the edges. Change the dimension to 55 and exit sketcher by clicking on √.

Figure 11: Second Sketch

To end sketching choose √ and click OK in the Section dialog. To complete this first feature type 3 into the depth field of the dashboard (See Figure 7) and click the green tick to finish.

Figure 12: Second Feature

You should be getting the hang of extrusions by now but we will come back to them later – there is more to learn.

Rounds

The calculator looks like a brick – let's improve its appearance by smoothing off some of the edges. To do this we will use the INSERT > ROUND command. The dashboard for the round command will appear as shown in Figure 13.

Figure 13: The Round Dashboard

The round command has some great functionality. In its simplest form you just need to click on the edges you want rounded. Click on the edge highlighted in red in Figure 14a and change the value to 5 and click the green tick to finish the round.
Repeat the round command a second time to make the round in Figure 14b.

You can add a round to more than one edge a time. Choose INSERT > ROUND a third time and click on the four vertical edges holding down the CTRL key for multiple selection. The size of this round will be 10.

The calculator is starting to look more interesting. Now lets return to the extrude command to remove material representing the screen. You should by now know the command for extrusions and how to enter sketch mode. The sketching plane is highlighted in red in Figure 16.

We don’t need any extra references in this feature so you can close the reference dialog. The edges of the screen will follow the outside edges of the calculator – this is called offsetting. Choose the command SKETCH > EDGE > OFFSET and in the Type dialog choose LOOP. Now pick on the surface you want to offset the edges of – in this case it happens to be the one highlighted in red in Figure 16. Type an offset distance of -5 – the negative value is needed to go the opposite way to the direction arrow. A series of lines is created offset from the edge of the surface. Exit skether with the tick icon.

If we wanted to add material we would be able to finish this feature now but we want to remove material. To change to remove material mode in the dashboard press and also press the first icon to change the direction of the protrusion. Type a depth of 2.

How about some more rounds! Add a 3 round all around the top and bottom edges of the calculator. Note that you only need to pick one edge on the top and one edge on the bottom and ProEngineer automatically
goes round the whole model because all the edges are tangential (smoothly joined).

Also add a 2 round all around the top edge of the screen. Again you will need two picks because of the sharp corner.

Figure 17 : More Rounds

Patterns

That’s the main part of the calculator completed. Now it is time to add some details. We will start by creating the buttons. You may be thinking that these are just circular extrusions and you would be right – but rather than drawing each one individually will make use of some of the repetition features in CAD. The golden rule of CAD is don’t draw anything twice if you can avoid it!

We will start by drawing just one of the buttons. It is an extrusion of a circle. The sketching plane is shown in red in Figure 18a and the dimensions are shown in Figure 18b. The height of the extrusion is 1.5.

Figure 18 : Button Extrusion

Now for the clever bit! We will make multiple copies of this first button using the PATTERN command. You need to select what you are going to pattern first so click on the button in the graphics window – it should turn red. Now choose EDIT > PATTERN. The dashboard for the pattern command will be displayed.

Figure 19 : Pattern Dashboard

There are several types of pattern. The one we need is dimension based. You should have noticed that the dimensions of the button feature are displayed for you. This is because the group of buttons will be made be made by copying the first button and after each copy is made one of the dimensions used to make the feature will be incremented by a specified amount to move the copy into its new position. The questions are which dimensions, how much is the increment and how many copies. This is what you need to define now.

First let’s make 4 copies of the button along the phone. Click on the 20 dimension. An edit box appears into which you should type the increment for the dimension after each copy is made. Type in 8 – in other words there will be 8 between each button along the phone. You must press the Enter button on the keyboard for your entry to be properly recognised. We said we wanted 4 buttons in this direction so type 4 into the second input box from the left in the dashboard – again you must press Enter.

If you ended pattern definition now you would get four buttons copied along the phone. We want buttons along AND across the phone. If you look at the dashboard you will see the 4th and 5th input boxes are identical to the 2nd and 3rd which you have already filled in. The 4th and 5th input boxes are for the second direction of copies.

To start to define the second direction click in the 5th (last) input box which currently says Click here to add item. Now click on the 15 dimension and type in -10 as the increment and press Enter. A negative value is required because the 15 dimension needs to decrease each time a copy is made. Type 4 into the 4th input box and press Enter to make 4 copies. You have now completed the input and can end by clicking on the green tick. If you have got it right you should see a rectangular array of 16 buttons.
Let’s have a go at a second pattern. Let’s say this is a Speak-&-Tell calculator so we need a microphone and speaker. The speaker will be a series of small cuts below the screen. As with the buttons we will make one cut then make a pattern of copies.

The first cut can be seen in Figure 23. It is a circular cut which is off centre. There are no planes or surfaces which can be used as a sketching plane – so we will have to make a new datum plane before we start the extrusion.

Choose INSERT > MODEL DATUM > PLANE. This command allows you to create a datum. A dialog is displayed. This is an intelligent dialog as the command changes dependant on what geometry you select. Click on the RIGHT datum in the main graphics window and the command assumes you want to create a datum plane parallel to RIGHT but a distance away – type in a distance of 10 and click OK. A new datum DTM1 is created.

Enter the INSERT > EXTRUSION command. The familiar dashboard is displayed.

Enter PLACEMENT and DEFINE and pick the new datum DTM1 as the sketching plane. With the references dialog open create a reference by clicking on the top edge of the calculator and draw a 10 circle in line with this reference as shown in Figure 22.

Figure 20 : Completed Pattern

Figure 21 : Extrude Dashboard

Now to make a pattern of this feature. This is a simpler pattern because it only copies in one direction. In the browser window right click on the last extrusion and choose PATTERN to pattern the slot. You should see the pattern dashboard. The left-most option will be set to DIMENSION. This option creates a pattern based on dimensions. We used it for the keypad. If you tried to use this option for this pattern you would find there was not a...
suitable dimension to use. So this time change the left-most option to DIRECTION. This option simply copies the feature a number of times in a given direction. To define the direction click on the datum DTM1. The copies will be made in the direction perpendicular to this datum. (Note : you don’t have to use datums to define direction you can also use surfaces, edges or axes etc.). Now click in the third option pane and type 5 (to make 5 copies) and in the fourth option pane and type 2 to set the distance between the copies as shown in Figure 24. (Note : The icon can be used if the copies go in the wrong direction).

Figure 24 : The Direction Pattern Dashboard

No second direction input is required so just press the green tick to make the pattern.

EXTRUSION command then PLACEMENT and DEFINE and choose the sketching plane shown in red in Figure 18a. Now draw three concentric circles as seen in Figure 26a then draw three horizontal lines that cross right over the circles as shown in Figure 26b (Note the top line passes through the centre of the circles).

If the dimensions aren’t exactly in Figure 26 new dimensions can be added. Use the dimension tool then click with the left mouse button on the geometry you want to dimension and then click with the middle button to add and position the dimension. Any ‘weak’ (grey) dimensions made redundant by this new dimension will be automatically removed. If ProEngineer is unable to delete dimensions because they are ‘strong’ it will warn you and ask you which dimension or constraint you want to remove.

Figure 25 : Speaker Pattern

Complex Sketcher Tools

Finally we will add an extrusion to represent the microphone for the Speak-&-Tell calculator. This is a simple extrusion again but we can use it as a means of introducing some new sketcher tools. Start the INSERT ->

Figure 26 : Initial Microphone Sketch

The lines are needed to define the shape of the microphone but there are too many long lines – they need trimming back – and ProEngineer has just the tool for the job. Locate the trim icon on the toolbar. When this tool is selected and you move the cursor over a line part of the line (until it crosses another line) highlights. Clicking on it deletes that PART of the line. Go round now deleting parts of lines until you are left with the sketch shown in Figure 27. Exit sketcher – if you get an error message you have not trimmed back all of the lines correctly – and extrude a cut 1mm deep into the model.

This trimming technique is one useful way of drawing more complex shapes. There are related tool icons in the panel next to the trim icon including one which extends two lines/arcs to their intersection.
Introduction To Modeling

Figure 27: The Finished Microphone Sketch

Conclusion
That is our model completed. This is a simple representation model as it doesn’t have all of the parts defined correctly – there are no internals and the keys are ‘stuck on’ rather than being a separate keypad sticking through from the inside. In later tutorials you will see how you could model this more accurately.

To make the calculator more interesting you could have a go at modelling some numbers/symbols on each key. Choose the top of the key as a sketching plane for an extrusion and use the icon in sketcher to ‘draw’ each number. Extrude them 0.5 above the keys so you can just see them.

Review
So what should you have learnt?
- How to create a new part
- How to create extrusions to add and remove material.
- How to sketch basic shapes.
- How to create edge rounds.
- How to create simple patterns.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.

Next have a go at modelling the shapes below then move on to Tutorial 2 where you will attempt another model which uses different feature types.

Figure 28: Some Sample Models – Estimate the Dimensions
Intermediate Modeling

Not all shapes are made from extrusions so this second tutorial introduces some new types of features. These include revolved features where a curve is spun around a central axis (like working on a lathe or potters wheel) and simple sweeps where a cross-section curve is swept along a centre line (ideal for making pipes). We will also return to the subject of patterns and rounds showing some more options for these commands.

The subject of this modeling exercise is a pair of headphones. Once again this will be a representation model made as a single part. In reality headphones are made from many pieces assembled together and this is the way you should use ProEngineer if you were going to manufacture the headphones. As a designer looking at the overall finished product it is often easier to model the complete design until a final decision to manufacture is made then return to break the design down into individual detailed parts later.

![Figure 1: The Finished Headphones](image)

**Revolved Features**

Now you understand the basic principles of using ProEngineer such as using the dashboard, defining sketch planes and sketching we will not cover these in detail unless something new is needed.

Start ProEngineer, Create a new part called headphones using the mmns_part_solid option. Choose the command **INSERT > REVOLVE** and notice the revolve feature dashboard appears.

![Figure 2: The Revolve Dashboard](image)

Just like extrusions revolved features use sketches that are created in the same manner. Enter sketcher (PLACEMENT > DEFINE) choosing FRONT as the sketching plane. Draw the two lines and the arc shown in Figure 3a. If you try to exit sketcher now you will get an error message – No axis of revolution. All revolved features must have an axis of revolution – a centre line around which the curve is revolved. This is drawn using the Centreline tool found by clicking the small arrow next to the normal line tool. Select this tool now and draw a centreline on top of the horizontal line you have already drawn – it should lock onto the reference line.

![Figure 3: Revolve Sketch and Feature](image)

Exit sketcher. The default option for revolve is to revolve the sketch for a full 360 degrees (see dashboard) which is exactly what we want so just click on the green tick to finish.

The next step is a simple extrusion for which you should not need much help but it gives a chance for us to discuss the options for length of extrusion.
Intermediate Modeling

**Figure 4 : Thru Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLIND</td>
<td>You type in a value as the depth of the extrusion.</td>
</tr>
<tr>
<td>SYMMETRIC</td>
<td>The extrusion goes both sides of the sketch plane.</td>
</tr>
<tr>
<td>THRU NEXT</td>
<td>The extrusion stops at the next surface.</td>
</tr>
<tr>
<td>THRU ALL</td>
<td>The extrusion goes through all geometry in the part.</td>
</tr>
<tr>
<td>THRU UNTIL</td>
<td>The extrusion goes to selected surface or plane.</td>
</tr>
<tr>
<td>THRU SELECTED</td>
<td>The extrusion goes to a plane thru selected point, curve, surface or plane.</td>
</tr>
</tbody>
</table>

Sketch on to the FRONT datum plane and extrude both sides by a distance of 50.

**Figure 5 : Double Sided Extrusion**

We need a new datum plane to draw this trajectory curve on. Choose INSERT > MODEL DATUM > PLANE then click on the RIGHT datum plane then whilst holding the CTRL key click on the axis through the centre of the last extrusion. The Datum plane dialog should now contain two references and next to the RIGHT datum reference it will say Offset - click on this and choose parallel.

**Figure 6 : A New Datum Plane**

Now we can draw the trajectory curve for the sweep feature. Choose INSERT > MODEL DATUM > SKETCH and choose DTM1 (the datum plane just created) as the sketch plane. Draw the sketch shown in Figure 8. Notice the two extra vertical references created on the ends of the extrusion. The easiest way of drawing this sketch is to first draw 5 straight lines then add fillets at each corner.

Sketcher has some intelligence built into it in the form of geometric rules or constraints. You may have noticed this intelligence in operation – for example lines drawn near vertical or horizontal have the letters V or H next to them and lines drawn with similar length are given a reference like L1. These constraints are either automatically assigned by sketcher as you draw or you can manually tell ProEngineer to add constraints by using the skether constraint icon. See Figure 7 for an explanation of all of the constraints available to you.

**Sweep Features**

Now we need to make a wire to attach the phones to the head strap. There is an easy feature for this called a sweep. This requires two curves the centreline of the ‘wire’ known as the trajectory and the second is the cross section of the wire which in this case will be a simple circle – though it can be any shape you want.
Now to create the 3D geometry. Choose INSERT > VARIABLE SECTION SWEEP. The SWEEP dashboard should appear.

**Figure 9 : Sweep Dashboard**

Notice that the default for sweep is to create a surface so click on the first icon to ensure a solid is created. Now click on the datum curve you have just drawn to select it as the trajectory curve. The sketch icon will now be active so click on it and you will be taken directly into sketcher – the sketch plane is defined automatically on the start of the trajectory curve. This sketch defining the cross section of the sweep so just draw a 2 circle centred on the horizontal and vertical references automatically created on the end of the trajectory curve. Leave sketcher and click the green tick to finish.

**Figure 10 : The Sweep**

Let’s make a second sweep to show you that you don’t need to draw curves first. You can use the edges of the existing models if you want. We add an earmuff around the phone (you could have created this as part of the original revolve feature in this case). Choose INSERT > VARIABLE SECTION SWEEP then click on the first icon to make a solid. Now, in the main graphics window click on the circular edge of the phone – half of the circle is selected in red. Now hold the SHIFT key down and click on the other half to select it as part of the same curve. Enter sketch mode.
and draw a 10 circle centered on the automatic references. Exit sketcher and end the feature definition.

**Figure 11 : The Ear Muff**

A final chance to practice sweeps - for this tutorial at least. We will make the head strap to show you don’t have to use circular cross sections. We will need to draw the curve for this sweep so choose INSERT > MODEL DATUM > SKETCH and choose FRONT as the sketch plane. Draw the sketch shown in Figure 12. Remember that additional constraints can be added using the icons. Add a vertical constraint between the top end of the arc and the centre of the arc using the icon. Now this is quite tricky till you get the hang of it! - the left hand end of the arc is aligned with centre of the wire by using the icon and repeatedly RIGHT clicking near the centre of the wire until the END:CURVE symbol highlights. Exit sketcher.

**Figure 12 : Head Strap Trajectory Curve**

Now to add the 3D geometry. Choose INSERT > VARIABLE SECTION SWEEP then click on the first icon to make a solid. Now, in the main graphics window click on the curve you have just drawn. Enter sketch mode and draw the oval in Figure 13 centered on the automatic references. Exit sketcher and end the feature definition.

**Figure 13 : Head Strap**

To tidy up the strap add a double sided extrusion of a diameter 6 circle that is 35 long around the join of the strap to the wire.

**Figure 14 : Extrusion**

**More Patterns**

In the introductory modelling tutorial you were introduced to patterns – multiple copies of features. Those simple patterns were rectangular or linear patterns. Here we will introduce polar patterns (based on angles) and rather clever Fill patterns unique to ProEngineer.
Fill Patterns

Fill patterns are very easy and impressive! Like all patterns you first have to create something to pattern. So let’s make a cut into the earpiece for the sound to get out. Make a 1 diameter extruded cut 0.5 deep at the centre of the flat face of the earpiece.

![Figure 15: Initial Cut for the Pattern](image)

Now to make multiple copies of this cut. Right click on the cut you have just made in the model tree then choose EDIT > PATTERN. The default type of pattern is to define by Dimensions as shown by the first list box. Change this first list box to the Fill option and the appearance of the dashboard should change to that shown in Figure 16.

![Figure 16: The Fill Pattern Dashboard](image)

This type of pattern fits as many copies of the feature inside a boundary as it can. So the first step is to draw the boundary. Click on the REFERENCES > DEFINE and select the flat face of the earpiece as the sketch plane. Draw a 35 circle. This circle will form the outer limit of the copies – all copies will fit inside this circle.

Exit sketcher and you will all ready see the black dots representing the copies which will be made. They are in the shape of a square as shown by the 3rd list box. Change this to Diamond and see the difference and change the 4th list box – the spacing – to 5. Note that with this type of pattern you can also click on any of the black dots (they turn white) to leave that copy out of the pattern. Close the Dashboard with the green tick.

![Figure 17: Fill Boundary and Diamond Pattern](image)

Polar Patterns

The fill pattern is very versatile and can be used in many situations but you should be aware of other ways of making patterns. So here are some examples of patterns based on angles – polar patterns.

First we will make a cut into the back of the phone. Choose INSERT > EXTRUDE and enter sketch mode choosing DTM1 as the sketch plane. The sketch you need to draw is shown in Figure 18.

![Figure 18: Polar Pattern Sketch](image)

Exit sketcher. Make sure the option for removing material through the back of the phone is set before closing the dashboard. Now add a round feature around the edge of this cut to make the appearance better.
NOTE: If you have used an earlier version of ProEngineer you may be surprised that this sketch does not have an angle dimension. A new pattern option makes this type of pattern extremely easy so you don’t need this complication.

Ready for the pattern? Right click on the cut (not the round) feature you have just made in the model tree then choose EDIT > PATTERN. The default type of pattern is to define by Dimensions as shown by the first list box but we want an AXIS pattern so change the first list box now and see the dashboard change to the one shown in Figure 20.

The first step in this pattern is to choose an axis around which the pattern will be made (the centre of rotation). Make sure axes are displayed then pick on the axis at the centre of the earpiece. This may be a little tricky as there are lots of axes for the other holes here – the one you want will have a low number probably A2. Now click on the third list box and change the 4 to 8 as the number of copies. Click on the fourth list box and type in an increment of 45. There is no second copy direction in this case so close the dashboard with the green tick. You should see 8 cuts around the phone. Right click on the round feature then choose EDIT > PATTERN. The fillet is automatically propagated around each of the cuts because the original cut to which this round ‘belonged’ was itself patterned!

There is one more polar cut to add – a series of holes through the head strap. These are created in the same way as the last AXIS pattern. Before you make the feature and pattern lets prepare by making an axis around which the copies will take place. Choose INSERT > MODEL DATUM > AXIS. Pick the inside cylindrical surface of the head strap – make sure you pick the surface and not an edge. An Axis will be created through the centre of the strap. Close the axis dialog.

As always we need to draw the cut which will later be patterned. Choose INSERT > EXTRUDE. Enter Sketcher choosing the TOP datum as the sketching plane. Now choose the end of the headphone as a reference and draw the simple sketch shown in Figure 22. Exit sketcher. Make sure the options for removing material entirely through the head strap is set before closing the dashboard.
To complete simply RIGHT click on the cut in the browser on the left and choose PATTERN. Choose the AXIS option and pick the axis you created earlier, choose 5 cuts and type an increment of 22.5 (use to make sure the pattern goes the right way). Close the Dashboard.

**Elliptical Rounds**

Use your previous experience to add a round to each edge of the first of the holes you have just created. Remember to hold the CTRL key to select the two edges (top and bottom of the hole). Before exiting the round dashboard click on the Sets menu and you will see the dialog in Figure 23.

![Figure 23 : Round Sets](image)

This dialog allows you to vary the type of round. Change the word Circular to the option D1 x D2 Conic and you will get two radius values in the dashboard to define a conic round. Change these values to 2 and 1 respectively – look on the model to check you get them the right way round so that the large radius is on the outside of the strap.

Right click on the latest round feature then choose EDIT > PATTERN. The fillet is automatically propagated around each of the cuts because the original cut to which this round ‘belonged’ was itself patterned!

**Mirroring**

Finally to create the other half of the headphones click on the name HEADPHONES.PRT at the top of the browser window then choose EDIT > MIRROR pick the flat end of the head strap as the mirror plane. The headphones should be complete!

**Review**

So what should you have learnt?

- How to create revolutions to add and remove material.
- How to use more complex sketch functions.
- How to create fill patterns.
- How to create polar patterns.
- How to create elliptical rounds.
- How to mirror the whole model.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
When modeling any part you are likely to be working to certain parameters which can be used to create construction geometry in your model. In the case of this remote control unit let’s assume that the design specification states the part should be no longer than 150. Now let’s use that information to define two datum planes. Choose INSERT > MODEL DATUM > PLANE and click on the RIGHT datum in the graphics window. The Offset option is set automatically in the dialog box so type in a value of 150. In the Properties tab type a name of ENDLINE and click OK. Repeat this making a similar datum called MIDLINE at a distance of 75. That has set up the reference geometry for us to use.

We are now going to design the outside shape of the remote. As you can see from the picture this is a complex shape and the simple EXTRUDE and REVOLVE commands would be totally inadequate. We are going to use a command we have already introduced VARIABLE SECTION SWEEP but use it to its full capabilities.

**Sketching with Splines**

You may remember this command relies on existing curves so we need to draw some curves now. Like many complex shapes, lines and arcs aren’t suitable for the shapes we want – we will use a free form curve known as a spline.

Choose INSERT > MODEL DATUM > SKETCH and choose FRONT as the sketch plane. On entering sketch mode click on the ENDLINE datum as an additional datum. The is used to create splines. Choose it now and have a practice – it takes a little getting used to. Each click of the mouse defines a point on the curve and ProEngineer smoothly interpolates between these points. Click the mouse button to finish drawing a spline.

You can then use the selection tool to edit the curve by dragging any of the control points.

Once you have got the hang of drawing with splines draw the curve shown in Figure 1. Note it has 5 control points and the first and last points lie on the references and are horizontally inline. Exit sketcher.

Repeat the previous command and draw a second, separate curve. This one is just a simple horizontal line aligned to all references as shown in Figure 2.

These first two curves define the shape of the remote when viewed from the front. Now we will draw two curves to control the shape when viewed from above. Draw another datum curve using the TOP datum as the sketch plane aligning the ends of the curve as shown in Figure 3.

The fourth and final curve is identical to the last one so simply click on the last curve in the browser window then choose EDIT > MIRROR and pick the FRONT datum as the mirror plane. You should now have 4 curves and are ready to create the solid.
Sweeping
To make the solid choose INSERT > VARIABLE SECTION SWEEP and click on the straight line curve FIRST (it will be called origin) then whilst holding the CTRL key the other three curves. Choose the Sweep As Solid icon then enter sketch mode where you will draw the cross-section of the sweep. You should see two references passing through the end of the origin curve and if you look carefully a reference has been added to the end of each of the four curves – shown as small crosses. Draw the section shown in Figure 5 locking on to these references.

Figure 5 : Sweep Cross Section
After leaving the skether you should see a prediction of the final shape in the graphics window – if you don’t you have done something wrong. Check you have selected the curves in the correct order and drawn the correct section. Finish the sweep feature by pressing the green tick icon.

Figure 6 : The Sweep

To make the flat ends of the sweep more interesting we will use and extrusion to cut them. You will need to create two separate extruded cuts using the TOP datum as the sketch plane. The sketches for these are shown in Figure 7. They must be drawn as two separate cuts.

Figure 7 : Separate End Cuts

Blending
Don’t try this now but this is not the only way of creating such a shape. An alternative which might be more appropriate in some circumstances is blending. With blending you draw (or select) several cross section curves then create (using INSERT > BLEND) a solid which ‘morphs’ between these.
Cut Reversal

The next step is to add a battery compartment. Although this is a simple shape we will use it to illustrate a useful technique. Start the extrusion like all others selecting FRONT as the sketch plane and drawing the simple shape in Figure 9. Notice the extra reference that has been added to the bottom edge of the sweep. Exit sketcher.

This cut (don’t forget to press \( \square \) to remove material) needs to go right through the sweep in both directions. The correct way to achieve this is to click on the Options menu in the dashboard and choose Through All in both the Side 1 and Side 2 fields. Now click on the preview button in the dashboard. You should see one of the shapes in Figure 10. Click on \( \checkmark \) again then click on the second \( \checkmark \) button in the dashboard to reverse the material to be removed by the cut. Preview and you should see the other shape in Figure 10. One of these shapes is the start of the remote control and the other is the start of the battery cover which will exactly match the remote. So finish the extrusion ensuring you have the correct side to make the main body of the remote. If you now choose FILE > SAVE A COPY and type the name BatteryCover in the New Name field you will have a copy of the current model saved. Later we can go back to this second model and EDIT DEFINITION on the last feature (the cut) and reverse its direction to start to define the battery cover in the sure knowledge that they will exactly match each other. Two models for the price of one!

Now we will make two screw holes at the opposite end to the battery compartment to join the parts of the remote together. First create a new datum plane Offset from the RIGHT datum by 30 and call it HOLES. Make a revolve feature then draw the sketch in Figure 11 on this datum. Exit sketcher and choose the Remove material icon \( \square \) to make the first hole. The second hole is identical so choose EDIT > MIRROR then select the cut feature and pick the FRONT plane to make a copy on the opposite side of FRONT datum. Finish the mirror feature by pressing the green tick icon \( \checkmark \)
Now it is time to hollow out the remote control using the INSERT > SHELL function. Choose a thickness of 1. Which surfaces should be removed from the shell? Obviously the large flat surface on the top of the remote but the holes also need to be open. Select the circular surfaces at the bottom of both holes too (hold the CTRL key to select several surfaces).

ProEngineer has a special function to avoid this problem. It is like an intelligent extrusion command that automatically mates to adjoining surfaces correctly – it’s called a rib.

Before making the rib we need to prepare some geometry. The rib command requires you to draw a shape to enclose the material to be added. So we need a line which touches the outside of the hole surfaces and also touches the inside of the shell. The hole surfaces have a ‘true’ silhouette so you can easily create a reference for that and draw to that reference. But the ‘problem’ is the inside of the shell – since that is a freeform surface it does not have a silhouette – we need to make one. The line we need to reference is a curve along the intersection between the HOLES datum and the inside of the shell. To create this curve select on internal surface of shell shown in Figure 14. The first time you pick this surface you actually select the whole shell feature – we only want one surface of the shell. Pick again in the same place and Pro Engineer will ‘look inside’ the shell and find the surface (depending on how you drew the original section curve for the body - Figure 5 - you will either select the whole internal surface or just half of it). Next with the CTRL key held pick the HOLES datum plane. The geometry is selected so now choose EDIT > INTERSECTION. You should see the intersection curve created.

Now we are ready to create the rib feature. The command is INSERT > RIB – try it now.
Go into sketch mode (REFERENCES > DEFINE) picking the HOLES datum you created earlier as the sketching plane. The curve you just created can be picked as a reference curve along with external surface of the holes. Draw a line between these two curves. Because the ends of this line a locked onto the references which themselves are locked onto the underlying surfaces the rib will correctly join to these surfaces.

The next step is the battery holder. This is not complicated it is made up of two extrusions and a cut. The cut is sketched onto the side of battery holder. Rather than making a second cut on the other side you can use the EDIT > MIRROR command to make a copy.

**Full Round**

Here is a chance to demonstrate a new type of round. Up till now all rounds have been edge rounds – rounds applied to an existing edge. There are other options for rounds in ProEngineer for example the FULL ROUND. We can use this to add a round to the end of slots (Note : this could have been added by drawing the correct shape for the initial cut but then we wouldn’t have had an excuse to demonstrate full rounds!). Choose INSERT > ROUND as before and select the two edges shown in Figure 18 using the CTRL key. By default you will get edge rounds on these selected edges. Click on the SETS tab in the dashboard and you will see a button called Full Round – this button is only active if you have exactly two edges selected. Click on this to change the type of round and you should see the round created.

Now we want a round on the other slot too. Since for a full round you can only have two edges selected we can’t select any more edges. You could close the dashboard and repeat the procedure above but there is an alternative that allows you to group similar rounds together. In the Sets

---

**Figure 16 : The Sketch Curve and Rib**

Close the sketch. Check that the arrow drawn on the curve points towards the material which you want added – if it doesn’t use the FLIP option in the references menu to change it. Type a thickness of 2 and end the dashboard with the green tick. Create a second rib (mirror?) on the opposite side.

**Figure 17 : Battery Holder**

**Figure 18 : Full Round**

NOTE : This command can sometimes fail dependant on the exact shape of the outside surface.
menu you should see the name Set1 and below this the words NEW SET – click on this and Set2 will be created and you can now select the two edges on the other slot creating two rounds in one command.

**Using Projection Curves**

Now we will add a simple logo to the remote. This is a letter S surrounded by a circle. If the surface was flat this would be a simple matter of drawing a circle and two arcs for the S then using the SWEEP command to cut away material. But the surface isn’t flat so how do we draw a curve onto a non flat surface? The answer is we can’t! But we can project curves onto a surface. Choose INSERT > MODEL DATUM > SKETCH and pick the TOP datum as the sketching plane. Draw a circle and two arcs to make the S logo. Exit sketcher.

Now click on the curve in the browser panel and choose EDIT > PROJECT. In the project dashboard pick the External surface of the remote (depending on how you drew the original section curve for the body - Figure 5 - you will may need to select twice using the CTRL key to get the whole surface). Close the dashboard. A copy of the curve will now be sitting on the surface.

Now you have the curves you can use the INSERT > VARIABLE SECTION SWEEP command using these curves and a circular cross-section to cut the grooves in the surface. You will have to do a separate sweep for each of the two curves. If you need reminding how to do these simple sweeps refer to the section Sweep Features in the Intermediate Modelling Tutorial.

**Using Offset Curves**

To finish this part we will add a cut to the top edge to make a dust seal when this part is assembled with the keypad. As always there are several ways of approaching this – we will use a simple extrusion.

Choose INSERT > EXTRUDE and pick the TOP datum as the sketching plane. We will use a command to make the curve we need which was introduced in the Introduction To Modelling Tutorial. The edges of the seal will follow the outside edges of the remote. Chose the command SKETCH > EDGE > OFFSET and in the Type dialog choose CHAIN. Now pick on an outside edge of the remote – one edge highlights. Now pick on an adjacent edge – the whole loop around the remote highlights and you choose ACCEPT in the side menu. Enter an offset distance of 0.5 – a negative value may be needed to go the opposite way to the direction arrow. A series of lines is created offset from the edge of the surface. Exit sketcher.

Choose the options to remove 1 material into the remote and that’s it the model is finished. Remember, you can use the second icon to change the material side to be removed.

**The Battery Cover**

Remember that we saved the model earlier to the name BatteryCover. Open this model now and you will see the remote at a much earlier stage of its development. We saved this so that we could easily make the cover for the battery. The last feature in the browser should be a cut. Right click...
on this and choose EDIT DEFINITION. This takes you back to the dashboard with all the options set. Reverse the side of the cut to remove material by pressing the second icon. Close the dashboard and you should have the battery cover. Here are some pictures to help you finish the model. Your dimensions may vary a little from those stated – feel free to use a bit of creativity.

REVOLVE
Remove material for a finger grip.
Sketch on FRONT and choose 360 degree option.

ROUND
Add 4 round

SHELL
Remove 2 faces and choose 1 thickness.

EXTRUSION
Sketch on TOP. Mirror to make second side. Use Extrude To Next option.

EXTRUSION
Make a new datum 8 away from front face of cover. Sketch on this datum. Mirror to make second side. Use Extrude To Next option.

That’s the both halves of the model completed. In a later tutorial you will learn how to assemble these two pieces together.

**Figure 21 : The Completed Battery Cover**

**Review**

So what should you have learnt?

- How to create complex surfaces.
- How to make thin walls with shell.
- How to create ribs.
- How to create full rounds.
- How to use projection curves.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
Creation of drawings from PRO/Engineer models is a straightforward task.
Completing a drawing can be broken down into two stages:

1. **Drawing Layout** - Elements making up a drawing are brought together. These include selecting a drawing sheet, positioning views of your model on the sheet, adding cross-section or scaled views, etc.

2. **Drawing Detail** - Adding information such as dimensions, geometric tolerances and drawing notes to your drawing.

This document covers the first of these stages, drawing layout, the second stage is covered in a companion document ProTutor05.

This drawing layout tutorial covers the following procedures…

- Creating a drawing sheet and assigning a model to the drawing.
- Positioning drawing views onto the drawing sheet. The position of the first view of the specified model is important since it determines the layout of other views. Subsequent views are placed as projections of this view and PRO/Engineer automatically determines the view orientation based on the projection mode.
- Additional views can be placed which are not projections. For example it is often useful to add a 3D view (an isometric projection) to the drawing as this can aid visualisation of the part.
- Cross-sections are also a useful tool for communicating ideas. Cross-sections, either planar or dog legged, can be added and numbered quite easily in PRO/Engineer.

The drawing tutorial is based on the main housing of a valve. The model for this part can be found at the location where you found this document. Copy the model called **valve_housing** to your directory before you start.

### Creating a Drawing

A new drawing is created using FILE > NEW choosing the type as DRAWING and giving a suitable name (**valve_housing** suggested). At this point the drawing format definition dialog appears, as shown in Figure 1. The default model will be set to none (unless you already have a model open). Use the browse button to locate the model you want to create a drawing of – in this case valve_housing.

Also from this dialog box the size of the drawing can be specified. When you are choosing the size bear in mind the size of printer or plotter that is available for the final output. If only an A4 printer is available then choosing the A0 option is not sensible since by the time the page is shrunk to fit on an A4 sheet the text will be unreadable. For student work it is acceptable to choose an A3 format and plot this onto an A4 sheet as this gives more room for dimensions to be shown. Another way of specifying the size is to choose a Template or a Format. This is like starting with a pre-printed drawing sheet with boxes for drawing title and other information but we will show you how to add this in later. For this model choose Empty, Landscape and select the A3 standard size.

---

**Figure 1: Creating a new Drawing**

A new window will be displayed in which your drawing will be created with the file extension .DRW. If you have chosen one of the standard sheet sizes a rectangle will be displayed indicating the extents of the drawing sheet. All drawing should take place inside this rectangle. Figure 2 shows the new drawing sheet, as it should appear on your screen.

**Figure 2: A Drawing Sheet**
To position the first view of your model choose INSERT > DRAWING VIEW > GENERAL (if by mistake you left the model name as none in the original dialog box you will be asked to enter the name of the model that you want to detail - choose valve_housing). After the system has located the model you are asked to indicate the position of the view within the drawing. Click inside the drawing in the lower right-hand quadrant (see Figure 3) and a default view of the housing model will be shown.

Next the DRAWING VIEW dialog will appear. This dialog offers all of the options for setting up views.

Figure 3: The First View is Placed and Awaiting Orientation

Although the view is located on the drawing it is not correctly orientated. The VIEW ORIENTATION section of the dialog allows you to change this. If you click on GEOMETRY REFERENCES this works in the same way as orientating the display and setting up sketch planes. Choose TOP in reference 1 and click on DTM2, then choose LEFT in reference 2 and click on DTM3. The view should be orientated to show a side view as in Figure 4. Choose OK in the DRAWING VIEW dialog.

The projections from this first view can now be created. Choose INSERT > DRAWING VIEW > PROJECTION and click to the left of the first view.

The view is projected from the currently selected view so click on the first view you created (a red box should highlight around the view) then repeat the process to add a third view this time clicking above the first view. You should now have three projected views on the drawing.

To complete the views choose INSERT > DRAWING VIEW > GENERAL again. Locate the view in the top-left quadrant and accept the default orientation by pressing OK in the DRAWING VIEW dialog.

Note: If you want some isometric view other than the default it is best to open the model and using the dynamic rotation option using the middle mouse button set up the view that you want and save it under a name using the ORIENT tab in the VIEW > VIEW MANAGER dialog.

The drawing should now look like Figure 5. If any of the views are incorrect click on the view to highlight it with a red outline then choose EDIT > DELETE. You will be asked to confirm removal then you can add it again.

Figure 4: The First View is Orientated

Figure 5: Four Views Positioned
The views are positioned but they can be moved if you wish. You may decide for example that an extra view is needed showing a cross-section. To accommodate this, the first view you placed needs to be moved to the left. The movement of views is probably locked – check the icon on the toolbar is NOT pressed. Now click on the bottom right view (the one you placed first). A dotted box will be drawn around it with ‘grab’ handles at the corners (if you don’t get the grab handles you need to press the icon). Now click and drag the view to the left. Note that the view above it also moves because it is a projection from the view that was moved. The first view placed can be moved freely. Projected views can only be moved along the projection. If you tried to move the top view to the left or right it would not move, it could only be moved up or down. Try it and see.

![Figure 6: More Room Available](image)

The view is not sectioned yet so select it and choose EDIT > PROPERTIES (or double click on the view). The DRAWING VIEW dialog should appear. On the left of this dialog click on SECTIONS then click on 2D CROSS-SECTION and finally the icon. An ‘old-fashioned’ style menu will appear on which you should accept the defaults of a PLANNAR | SINGLE cross-section. After choosing DONE you will need to enter a name for the section. This is usually a single capital letter such as Z. Next choose DTM1 to indicate where the model is to be cut to create the section. Choose APPLY in the DRAWING VIEW dialog to see the section and if it is correct choose CLOSE.

If you feel the cross-section lines are not suitable, for example the spacing between the lines is too wide, then click on the cross hatching to select it and choose EDIT > PROPERTIES (or just double click on the hatching). On the ‘old-fashioned’ style menu to the right choose SPACING and OVERALL | HALF.

You may have noticed that hidden details (the lines showing what is going on inside the model) are shown on all views. It is not normal practice to show these lines on isometric or sectioned views. So to finally tidy up the drawing the cross-section (bottom right) and general view (top left) need to have hidden detail lines removed. Select one of these two views by clicking on it then choose EDIT > PROPERTIES. The familiar DRAWING VIEW dialog appears – you need to choose the VIEW DISPLAY option on the left. In the DISPLAY STYLE list box choose NO HIDDEN. APPLY and CLOSE the dialog. The finished drawing layout is shown in Figure 7.

![Figure 7: Finished Layout](image)
To fit the views onto the sheet Pro Engineer has chosen an overall scale. The text in the bottom left of the graphics window tells you what the scale is (probably 1.00 in this case). You can change this to increase or decrease the size of all of the views giving you more or less room for dimensions to be added. Simply double click on the scale text at the bottom left and type in a new value – try 0.5 in this case to make the views smaller.

The format has boxes where you can fill in your name and other information. To do this choose INSERT > NOTE choose the options from the menu and then choose MAKE NOTE and click to position your text then type in the text you want to appear. Press RETURN twice to end text entry.

At the start of the drawing process we said we would show you how to add a drawing format (information boxes etc.) to your drawing so here is how to do it. Choose FILE > PAGE SETUP and you will see the dialog in Figure 9. It shows you that you already have a format in the drawing called A3Size. This is the rectangle bounding the drawing area. Click on this and Browse to change it to bfrm (the standard formats distributed with Pro Engineer are only in American sizes where ‘B’ is the nearest to A3). Click OK and you should see the format sheet around your drawing.

At the start of the drawing process we said we would show you how to add a drawing format (information boxes etc.) to your drawing so here is how to do it. Choose FILE > PAGE SETUP and you will see the dialog in Figure 9. It shows you that you already have a format in the drawing called A3Size. This is the rectangle bounding the drawing area. Click on this and Browse to change it to b frm (the standard formats distributed with Pro Engineer are only in American sizes where ‘B’ is the nearest to A3). Click OK and you should see the format sheet around your drawing.

Review

So what should you have learnt?
- How to create a drawing.
- How to create general, projection and sections views.
- How to reposition views.
- How to add a drawing format.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.

What Next?

You need to experiment with creating drawings of your own parts perhaps investigating how to do scaled views.

Now you know how to layout the drawing it would be good to move on to annotating the drawing with dimensions and other information. This is covered in the next tutorial.
Creation of drawings from ProEngineer models is a straightforward task. Completing a drawing can be broken down into two stages:-

1. **Drawing Layout** – elements making up a drawing are brought together. These include selecting a drawing sheet, positioning views of your model on the sheet, adding cross-section or scaled views.

2. **Drawing Detail** – Adding annotation information such as dimensions, geometric tolerances and drawing notes to your drawing.

The companion document ‘Drawing Layout’ covers the first stage of the process and should be worked through first, the second stage is covered here.

Since the model has already been built all of the dimensions to fully define the model have already been entered it would be stupid to have to enter all of these dimensions again on the drawing. ProEngineer is not stupid and does not expect you to be either! So the first stage of the detailing process allows you to show the existing dimensions on the views. Having done this you will probably find that the position of the dimensions on the drawing needs changing to make the drawing easier to read. Certain dimensions may not be displayed on the most suitable view so this can be changed too. Finally certain cosmetic features may not be to your liking so minor changes can be made to dimensions for example the arrow heads can be flipped around.

**Showing Dimensions**

You should already have completed the companion tutorial so you should have a drawing called valve_housing which can be retrieved using FILE > OPEN. Having retrieved the drawing lets take the sledge hammer approach and show on this drawing ALL of the dimensions which were used to create the model. Choose VIEW > SHOW AND ERASE and you should see the dialog in Figure 1.

In the dialog box which appears click on the button with a picture of a dimension and then press SHOW ALL and confirm your action. The confirmation step is required because with a big drawing showing all of the dimensions can create a very confusing jumble. You don’t always have to crack a nut with a sledge hammer – there are other choices available to you as you can see from the dialog. In this case the drawing is not too complex so this is probably the easiest way however it would be useful for you to investigate the other options. After showing the dimensions you are left in preview mode where you have the choice of picking dimensions to erase or as we require in this case simply pressing the OK menu option to keep all the dimensions shown. The result of this command is shown below. The drawing clearly needs tidying up!
Positioning Dimensions

To see how to tidy up the drawing lets concentrate on the view in the top middle. Zoom in to this view to see it better. The dimensions are all overlapping the drawing so the first thing to do is to position them better.

Use the selection tool ![ ] and move each dimension in turn. Click on the dimension to select it, to start moving click again, drag the dimension then when the dimension is positioned better click a third time. Work on this part of the drawing now until the appearance is as shown in Figure 3.

Although this is better there is still work to do. The 28, Ø14 and Ø25 dimensions all refer to the boss and its central holes. Is this the best place to show these dimensions? This feature can be seen much better on the sectioned view. Why not add the dimensions here instead? You will have to zoom out a bit before you can do this so that you can see the section view as well. Use the selection tool ![ ] and select these three dimensions now (hold the CTRL key to select multiple dimensions). Choose EDIT > MOVE ITEM TO VIEW and point to the view that you want them to be moved to – in this case the sectioned view.

Take a closer look at the section view and you will see that the switched dimensions need tidying again. Rather than moving them individually there is an automated way of tidying up the dimensions. You will need to ensure the three dimensions you just moved are selected then choose EDIT > CLEANUP > DIMENSIONS. Set the two tabs in the dialog box to the values shown in Figure 4 and then APPLY to see the changes.

Now return to the original top view. If you look at this view you will probably decide that the 120° dimension is not required, since this information is inferred from the 60° dimension. We have shown a dimension that we don’t need. The original command we used to show the dimensions can also be used to erase them again. From the pull down menu choose VIEW > SHOW AND ERASE. In the dialog box which appears (see Figure 1) click on the ERASE button and make sure the

---

**Figure 2**: All of the dimensions shown on a drawing.

**Figure 3**: Improved Positioning of Dimensions

**Figure 4**: Cleaning Up Dimensions
button with a picture of a dimension is pressed and then select the 120° dimension and finally OK and the dimension will disappear. CLOSE the dialog.

Now some of the dimensions have been moved or erased there is more room in this view so try to position the dimensions better. You will probably find that as you move the $\varnothing$5 dimension the text stays on the wrong side of the leader line. You will notice that when a dimension is selected small square boxes are drawn on key points of the dimension. These can be moved individually. The one on the end of the text allows you to move the text to the other side of the leader. Also whilst moving a dimension the right mouse button can be pressed to flip the arrows to a new position.

**Dimension Parameters**

The $\varnothing$5 holes are probably going to be drilled together and so it is good practice to keep all of the information for these holes together as a single note. The actual text of a dimension can be changed too. Select the 5-diameter dimension and from the drop down menus use the command EDIT $>$ PROPERTIES. This will bring up the properties dialog. On the DIMENSION TEXT tab there is a simple editor to modify the text of the dimension. You will see some unusual characters like $\varnothing$@D. These make up the existing dimension text – a diameter symbol followed by the value of the dimension represented by @D. Don’t change these in any way but add your note to them as follows…

3 holes $\varnothing$@D x 8 deep.

This solution looks correct but really it is incomplete. The number 8 is the depth of the hole which appears elsewhere as a dimension. The beauty of Pro Engineer is that all occurrences of a model are linked or associated. You will see later that it is possible to change a dimension in a drawing and the model will be updated to reflect the change and vice-versa. Since the depth of the hole in this note is not a dimension, its just a text note, it will not be updated automatically. A better solution would be to include a reference to the actual dimension in the text note. Here is how to do that.

In Figure 5 you will notice that the highlighted 8 depth and the $\varnothing$38 both relate to the 3 holes. If you hover your cursor over each of these in turn you will notice that in the information line at the bottom of the screen it will say ‘d49:F21(HOLE)’ and ‘d50:F21(HOLE)’.

The reference d49 and d50 are the names that Pro Engineer uses for the dimensions. Take a note of the name of these i.e. 8 is called d50 and $\varnothing$38 is called d49. Having noted these names, go back to the properties dialog for dimension we were editing earlier. Edit the note replacing the 8 with &d50 and adding ‘on &d49 PCD’ to the end (PCD stands for Pitch Circle Diameter meaning the holes are equally spaced around a circle). DO NOT FORGET TO PRECEED THE NAMES WITH &. The note should now be correct and will be automatically updated if any changes are made to the model. The original dimensions 8 and $\varnothing$38 can be ERASED to avoid duplication.

Continue to use the techniques you have learnt to tidy up the remaining views. Be prepared to switch dimensions to other views as you feel necessary. Make sure to use the handles on the end of the dimension extension lines to move them so that they do not overlap the model.
Modifying Dimension Values

Earlier in the tutorial it was mentioned that the links between models and drawings allows dimensional modifications to be made from within the drawing. You have no doubt already seen how modifications can be made within a model. The process from within a drawing is very similar. Just click on a dimension to select it THEN double click on it to edit it (NOTE: If you just double click with out first selecting you will get the Properties dialog you met earlier).

Try this now on the Ø49 for the central bore. Select, double click then type in a new value for this, say 55 and press RETURN. The colour of the dimension will change to show that it has been modified but the model will not change until you choose EDIT > REGENERATE > MODEL. The before and after of this exercise is shown in Figure 6.

![Figure 6 – Model Modifications Can Be Made From The Drawing](image)

Printing a Drawing

Printing a drawing is straightforward using FILE > PRINT. One point worth noting is how do you print an A3 drawing on an A4 printer? Simple – in the Print dialog choose Configure – in the Page tab choose Size as A4 then in the Model tab choose Plot as FULL PLOT. The entire drawing should now be scaled to fit onto an A4 sheet.

This completes the drawing tutorial. The completed drawing is shown in Figure 7 at the end of the tutorial.

There are other additions that more advanced users may wish to include in their drawing such as geometric tolerances, machining and other symbols.

Review

So what should you have learnt?
- How to show and erase dimensions.
- How to reposition dimensions.
- How to maintain dimension parametrics.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
Often when creating features in a model other features, created earlier, are referenced. These references are called parent child relationships. For example a hole cut into a block clearly references the block! The block is the parent the hole is the child. The child cannot exist without the parent. If the parent is removed the child must go too, or else another parent must adopt the child. It is important to understand the hierarchy that is being created in this way, as with a little thought it can be used to help your design and not hinder it. This is particularly true when the design requires modifying.

Relationships are created all the time within Pro Engineer. It is often possible to design a feature in several ways, with apparently the same result, but creating different parent child relationships. Some of these methods will capture the design intent better than others. As an example a hole may be created in another circular feature, a boss. The hole could be dimensioned independently of the first feature. If the boss is moved the hole will not move as well since there are no parent child relationships to the first feature. If however the hole is made concentric to the boss a relationship is built in that describes the design intent – the hole and boss are intended to always be concentric. Now the hole moves with the boss to maintain the concentric relationship.

**Parent Child Relationships**

This tutorial is designed to show that solid modelling in a parametric system need not be a rigorous fully structured procedure. Good technique can allow flexibility in the design process. It is assumed that the reader has already completed the previous modelling tutorials and is competent at creating models.

Start by creating a new part called COVER using the mmns_part_solid template. Next create an extruded protrusion as shown in Figure 1. The protrusion should use the TOP datum as the sketching plane and the FRONT datum as the BOTTOM reference and be created to a depth of 100.

What parent child relationships have been created in this feature if any? As previously stated some dimensions (usually location dimensions) create relations. Which of the dimensions you entered have created a relationship? Which dimensions referenced other features for location? The 100 and 150 dimensions control the position of the box relative to the FRONT and RIGHT datums so a parent child relationship exists there. Is there any relationship to the TOP datum? You chose the TOP datum as the sketching plane (and the FRONT datum as a bottom plane) which also creates a relationship. So your block is related to all of the previous features! None of the datum planes could be deleted without deleting the block. You can prove this by choosing from the pull down menu INFO > PARENT/CHILD and picking on the block. A window appears as shown in Figure 2 which states that the block has no children but its parents are the TOP, RIGHT and FRONT datums.
You may be already aware that the dimensions assigned to any feature are not fixed. Their value can be changed at any time by using the EDIT or command in the pop up menu. As a reminder – right click on the protrusion in the feature tree and choose EDIT. All of the dimensions used to define the block will be displayed. Double clicking on these dimensions will let you change the value. The modified value will be displayed in green indicating the change. The modification will not affect the 3D model until you choose EDIT > REGENERATE. Try this now by changing the 100 thickness of the block to 200. Regenerate to see the change and then change it back to 100.

Next create a second protrusion for a flange. The flange should use the TOP datum as the sketching plane and FRONT as the BOTTOM reference and should be created in the same direction as the first protrusion maintaining the overall height of 100. The sketch for the flange (Figure 3) should be created by using the offset edge icon \( \text{Offset Edge} \). The LOOP option and click on the top surface of the first block allows all four sides to be offset in one go – choose and offset of 10. Finish the sketch and choose the BLIND option with a length of 10.

This is an example of another type of parent child relationship. The use edge and offset edge both reference existing geometry and so a parent child relationship is formed.

**Reordering Features**

Since this part is going to be a cover the centre needs hollowing out. A cut could be used for this but Pro Engineer has a special feature for this purpose. It is called a shell feature – you may have met it before. Use INSERT > SHELL and pick on the bottom most surface in Figure 3 enter a shell thickness of 10. The surface you picked will be removed and all of the remaining surfaces will be offset by 10 to make the shell.

**Figure 2 : Information On Parent Child Relationship**

**Figure 3 : The Flange**

**Figure 4 : The Shell**
The cover is full of sharp corners so add rounds (INSERT > ROUND). There are eight edges to be rounded all around the outside of the cover. There are four around the top and the four vertical sides so you will need to hold the CTRL key whilst selecting them. Enter a radius of 25 for all rounds.

The problem with this is that rounding the outside edges does not round the inside edges! The wall thickness is no longer constant. Ideally the rounds should have been added before the shell feature. Do we have to delete the shell and add it again after the round? No. The order of features can be changed – within the bounds of parent child relationships since you cant place a child before its parents. There are no parent/child relationships stopping this move. To reorder a feature click and drag the name in the feature tree. Drag the last round feature up the feature list – if you try and drag it before its parents the feature names will be highlighted in blue. The model will regenerate with internal and external rounds and the thickness of the whole model will be the same – just like you had added the rounds before the shell.

Inserting Features

The next step is to add a circular boss protruding from the top surface of the cover. If this is created as an extruded protrusion then once again there will be a material thickness discrepancy because the boss has been created after the shell. We could add it now and then re-order it to the correct position but since you noticed this problem early (you did didn’t you!) there is an alternative method. The new feature can be inserted into the tree by dragging the Insert Here reference in the feature tree to below the second protrusion. The model will be taken back in time to the point before the rounds and shell were added. Now add the boss using the dimensioning scheme shown in Figure 7. The 80 and 30 dimensions reference the FRONT and RIGHT datums. The boss thickness is 15. After creating the boss bring back the rest of the model by dragging the Insert Here reference up the feature list.
Here reference in the model tree to the end of the list. The model will be regenerated with the boss before the shell maintaining a constant wall thickness.

Drag the Insert Here reference in the feature tree to the bottom of the list to continue modelling in the normal manner. Now complete the model with a hole through the boss. This should be an EXTRUSION using the THRU ALL option to remove material and should be created with the dimensioning scheme shown in Figure 8. This is an identical scheme to the boss and is not the obvious way to do it, it’s not even the correct way of doing it – but it illustrates a point!

Now further down the design cycle it is found that this boss (and it’s hole) need to be moved. No problem! Right click on the boss in the feature tree (the third protrusion) and choose EDIT and change the 80 length to 60. Regenerate the model and all’s well! Not quite – try it!
The hole hasn’t moved because it was dimensioned independently of the boss. No parent/child relationship was established even though this would be good practice in this case. You could just modify the dimensions of the hole as well but let’s change the model to capture the design intent.

First modify the (now) 60 back to it’s original 80 and EDIT > REGENERATE so the boss is back to its original position. The hole needs the dimensioning scheme changing. To do this, right click on the hole in the feature tree (the cut) and choose EDIT DEFINITION. Enter the sketch mode with PLACEMENT > DEFINE and delete the circle. Create a new circle this time using the concentric option [ ] . Choose the icon click on the circle around the boss and click again to place the circle. You will notice that no linear (positional) dimensions are created because the circular hole is aligned to the boss thereby creating a parent/child relationship. End the sketch and the definition. Now try making the modification again and the hole should move with the boss.

**Adding Draft Angles**

Finally to show you the power of what you have learnt and as an excuse to introduce a new feature type lets assume that to allow the part to be removed from the injection moulding machine easily we need to angle the sides. These are called draft angles. Again to ensure we keep a constant thickness we need to add the draft before the shell. Drag the Insert Here icon to below the second protrusion in the feature tree. Now choose INSERT > DRAFT or the [ ] icon.

In the dash board click on References menu and the options in Figure 11 will be shown. First click in the Draft surfaces pane then select with the CTRL held the four vertical walls of the cover (see Figure 12). Next click in the draft hinges pane and click on the large top surface (see Figure 12). Type in a draft angle of 2 and click on to change the draft direction if necessary.

**Review**

So what should you have learnt?

- Understand Parent Child Relationships.
- How to reorder feature.
- How to insert features.
- How to create Draft Features.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
What Next?
You may wish to experiment yourself with these techniques whilst modelling the shape below. Scale or estimate all dimensions. Notice that most faces are angled to aid moulding so you will need to use Draft Features or other techniques.
An assembly is a collection of parts oriented and positioned together. As such it is the highest level of data that can be manipulated within ProEngineer as shown in Figure 1.

**Figure 1 : Structure of ProEngineer Models**

The first part placed in an assembly is known as the base component. All other parts are assembled to this part and are located by applying constraints. A constraint is a restriction of movement. Any part located in free space has six degrees of freedom, three translational (movements along x, y and z axes) and three rotational (rotations around x, y and z axes). For a part to be completely fixed in space all six degrees of freedom need to be constrained. ProEngineer allows components to be assembled together without constraining all six degrees of freedom – so a shaft can be left free to rotate in a hole.

Constraints are applied by using typical engineering metaphors. For example, two planar surfaces can be mated together so that they touch. This effectively restricts movement in 3 degrees of freedom (2 rotational and 1 translational). The six most common constraints are described diagrammatically in Figure 2. It may be interesting to work out what degrees of freedom are constrained by each.

**Figure 2 : Constraint Options**

The first stage in assembling two components is to determine how you would assemble the parts in real life – “I would push that shaft in that hole until this face butts up against this face”. Then you have to translate these words into the types of constraints that Pro Engineer offers – “INSERT the shaft in the hole then MATE the two faces”. Then the constraints are applied to the new part. In each case, the constraint will require a location on the assembly and a location on the component to be chosen. For example, if a mate constraint is chosen two planar faces (or datum planes) need to be chosen - one on the assembly and one on the component. The assembly constraints are maintained even if modifications occur to the original parts.

The assembly file itself is saved with a .ASM file extension. This file does not contain any geometry defining the components. It contains references to the original part files. If the original part files are deleted, moved or renamed the assembly model will report an error and will not open correctly.
Creating a Sub Assembly

If you have not already been given them, the parts for the valve assembly used in this tutorial can be found in the same directory on the Web as this document (http://www.staffs.ac.uk/~entdgc/tutorials.html). All 5 parts should be copied to your local system before you start.

A sub assembly is a small collection of parts which are assembled first then later they are added to the main assembly. As an example a car engine would be completely assembled first before it is added as a single unit to the car on the main assembly line. Pro Engineer can treat any assembly as a sub assembly.

Create a new assembly component using NEW from the FILE drop down menu choosing the Assembly option and giving a suitable name - in this case valve_sub. Choose the empty template and click OK. A new window contain default assembly datums will be displayed into which parts will be assembled.

The first part in the assembly is known as the base component. It is usually obvious which part in your assembly should be considered as the base part since other parts are attached to it. Choose the command INSERT > COMPONENT > ASSEMBLE or icon and pick the base part called valve_shaft from the file list. The base part will now be shown in the assembly window. Since this is the first component it is automatically located at the default position. (If you had used a template which contained some datums then this would not have been the first component and you would have had to locate the part using the techniques you are about to learn).

![Figure 3: The shaft in default position](image)

The second part can now be placed using INSERT > COMPONENT > ASSEMBLE as before. Choose the name of the second component valve_cover. The part will appear at some random position in the assembly and the Component Placement Dialog box is shown ready to add the first constraint.

It is now time to apply constraints to the valve_cover. As each constraint is applied the window updates to show the constraint and states whether the component is sufficiently constrained to be placed. The valve_cover needs to have (at least) two constraints. You will see that under Constraints Type in the dialog there is a drop down list. This list contains the constraint types. It also has the option of Automatic. If Automatic is selected (the default) ProEngineer will decide on the type of constraint based on the type of geometry you choose. Leave the choice as Automatic and pick on the central hole in the cover. Now pick on the shaft on the 14mm dia. near where the keyway is located (see Figure 5). This adds the first constraint, which is reported in the component placement dialog box. Since you have chosen 2 cylindrical surfaces ProEngineer assumes you want an Insert constraint.
This is not enough to place the cover. A second constraint needs to be added. Pick on one of the flat faces of the cover then pick on the flat face of the largest shoulder of the shaft. Type in a distance of 0.

This adds the second constraint, which may be reported in the component placement dialog box as an Align type. This is not correct it should be a Mate type. You can see the difference from Figure 2. This error is easily corrected by pressing the change orientation icon. This is now sufficient constraints to place the cover as you can tell since Fully Constrained is reported at the bottom of the dialog box. Choose OK to place this second component as shown in Figure 7.

The remaining component can now be placed by following the same procedure for starting with INSERT > COMPONENT > ASSEMBLE. Place the valve_arm with three constraints. For the first constraint pick the shaft on the 14mm dia. then pick the hole in the arm. This will be reported as an Insert.

Next pick one of the flat faces of the arm with the front face of the first step in the shaft typing a distance of 0. This will be reported as an Align constraint.
The component will be reported as fully constrained but this assumes that the rotation of the handle around the shaft is not important. In this case it is important because the keyways must align (unfortunately the default positions of the two parts happens to make the slot and keyway align but this is purely coincidental!). This can be achieved with a further constraint by pressing the add constraint icon $\mathcal{E}$. We now need to pick the side of the keyway and then the side of the slot. But these faces are ‘inside’ the model and so cannot be picked in the normal way. Pick the side of the keyway using the RIGHT mouse button and one of the outside surfaces will be selected. Keep clicking with the RIGHT button until the correct face is selected then press the LEFT button. Repeat this for the side of the slot.

Creating Assemblies

Any assembly created within ProEngineer can be used as a subassembly within a larger assembly. In fact the assembly that was created in the tutorial earlier is going to be used as a sub-assembly. So lets now create the main assembly for this valve.

Create a new assembly called valve using FILE > NEW. Choose the Empty template. Add the base component, called valve_housing, using INSERT > COMPONENT > ASSEMBLE or the icon. Having successfully placed the base component the next stage is to add the other parts and apply constraints to each in turn. Using INSERT > COMPONENT > ASSEMBLE, assemble the following parts with the constraints specified.

1. VALVE_SUB (the sub assembly you made earlier) with three constraints. Pick the shaft on the 14mm dia. and the hole in the
top of the housing. This will be reported as an Insert type. Now pick bottom face of the cover in the sub-assembly and the top of boss in the housing. If necessary change orientation using \( \text{Mate} \) to make a Mate type. Add another constraint using \( \text{Insert} \) and pick one of the 3 holes in the cover with the matching hole in the housing. This will be an Insert type.

2. VALVE_BUTTERFLY with three constraints. Pick one small hole in the butterfly and one hole in the shaft to make an Insert type. Pick the other small hole and the other hole in the shaft to make and Insert type. Pick one of the flat faces of the butterfly with the flat on the shaft. If necessary change orientation using \( \text{Mate} \) to make a Mate type.

Figure 12 : Assembly after 2 parts.

Figure 13 : Assembly after 3 parts

The assembly is now complete. Don’t forget to save the assembly using FILE > SAVE.
Modifying Assemblies

Choosing EDIT > DEFINITION and picking one of the components allows modification of the constraints you have applied (Alternatively you can right click on the component name in the feature tree on the left then choose EDIT DEFINITION). The familiar Component Placement dialog box will appear showing the placements already applied. Clicking on one of the constraints makes it current. As each constraint is made current the references (the surfaces you selected to define the constraint) on the assembly and the component are highlighted. The current constraint can be deleted and/or an additional constraint can be added.

It is also possible to modify component dimensions of parts from within the assembly. First you need to select one of the features in one of the parts. At the very bottom of the Pro Engineer window you will see the selection list. This controls what will be selected when you click on an object in the graphics window. This will probably be set to SMART so that ProEngineer tries to ‘guess’ what to select for you. Change this option to FEATURES. Now when you move the cursor over a part in the graphics window the individual features are highlighted and selected if you left click on them. Select a feature then press and hold the right mouse button. A popup menu will appear and you can choose Edit – the dimensions of the selected feature will appear and you can change them by double clicking on them. To see the changes you will need to choose EDIT > REGENERATE. Don’t forget to reset the selection list to smart.

Exploding Assemblies

Sounds exciting! Bang! Actually an exploded assembly is nothing more than the parts shown separated from each other. This can be achieved in ProEngineer using a simple command VIEW > EXPLODE > EXPLODE VIEW – try it in the valve assembly. ProEngineer will make certain assumptions based on the type of constraints applied and ‘guess’ at a suitable exploded state. As you can see from Figure 15 this is rarely perfect but it is a good starting point.

Having exploded the assembly and found it is not quite correct the exploded positions can be modified and the parts moved to a more appropriate position. You are moving the parts in the exploded state. This means that you are not actually altering the assembled model, only how the parts will be shown when exploded. The modified positions of the model when exploded will be saved so that next time you explode the model it will be shown correctly.

In this case the exploded directions chosen by ProEngineer are fine, but the distances it has been exploded are insufficient and some parts overlap. Looking at the assembly you will need to move the valve_butterfly and valve_shaft up by the same amount. To make room for this movement...
the valve_cover and valve_arm will need to be moved up as well. It may also look better if the valve_butterfly is moved forward.

To make sure these modifications are permanently saved choose VIEW > VIEW MANAGER. To show the view manager dialog in Figure 16. In the Explode tab choose EDIT > REDEFINE > POSITION to reposition the parts. The explode position dialog will be shown as in Figure 16.

CTRL key whilst picking (pick the valve_butterfly, valve_shaft, valve_cover and valve_arm) and click OK. You can now click and drag to move the parts. You may also decide to move the butterfly forward a little. To maintain a true explosion this part should only be moved in a direction at right angles to the flat on the shaft. Click on the arrow button in the motion reference field and click on the flat face of the butterfly. This now sets the movement direction correctly and the butterfly can be moved as before. Choose OK to save these modifications.

Creating Bills of Materials

A bill of materials is a list of each component needed to make up an assembly. Often it contains more than just a simple list of parts. It may be important to list part number, material type, cost and weight and other data
for each part. Also subassemblies may be recorded as either a single part or they may be broken down as well to show their make-up. These would normally be indented in the list to show they are part of a subassembly. The bill of materials list is a good example of the way in which a CAD system can form the core data for more general data retrieval system. The bill of materials information is needed for stock control and order processing systems.

To create a simple Bill of Materials report from an assembly choose INFO > BILL OF MATERIALS. A dialog box appears as shown in Figure 18.

![BOM Dialog Box](image)

The default options are probably fine so just click on OK and a window will appear showing the details of the assembly. You can see from this that the VALVE Assembly contains 2 parts and one sub-assembly. The sub-assembly itself contains 3 parts. The valve assembly contains a total of 5 parts. This listing appears on the screen and is also written to the disk as a text file under the name valve.bom.1. You could add this text to a drawing (not an assembly) by choosing INSERT > NOTE then FILE ⇒ MAKE NOTE locate the notes position and type in the filename valve.bom.1.

![Figure 19 - A Bill of Materials Report for Valve](image)

**Review**

So what should you have learnt?
- How to create assemblies.
- How to assemble components using insert, align and mate.
- How to edit features in an assembly.
- How to explode an assembly.
- How to create simple parts lists.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.

**What Next?**

You need to experiment with other assemblies of your own as there are more constraints which we have not covered here.

Also assemblies are the starting point for mechanism analysis so take a look at the mechanism tutorials.
Most CAD systems have functionality to allow the user to add tolerance information to dimensions. This allows drawings to reflect design or manufacturing intent but since the tolerances are nothing more than an additional text note applied to the dimension no additional functionality can be gained from the tolerance value. These ‘unintelligent’ tolerances can serve no benefit for analysing such things as tolerance build up problems and volume/weight variations.

Pro Engineer builds three-dimensional models and allows the defining dimensions to have tolerances applied to them. These tolerances can be displayed in the three-dimensional model window as well as appearing on the subsequent drawing derived from the model. Since these tolerances are inherent in the defining dimensions of the part they can be used in a much more ‘intelligent’ way for analysing the parts performance in an assembly as will be shown in the following scenario.

**Tolerance Overview**

All Pro Engineer components are built with nominal values. The nominal values represent the ideal sizes that are intended by the designer. However manufacturing practice dictates that no dimension can be guaranteed exactly. All manufacturing processes require a dimensional tolerance range within which the size can be guaranteed. The smaller the tolerance range required the more expensive the manufacturing process required is likely to be. Assigning very narrow tolerances to every dimension causes a component to be more expensive than is necessary to achieve the function intended. It is the designers’ role to analyse the product and decide which dimensions are critical to achieving the product function.

All dimensions entered in Pro Engineer are given a default tolerance value. To see these values make sure that the option DIMENSION TOLERANCES is checked in the TOOLS > ENVIRONMENT dialog. Every dimension for a feature will now be displayed with tolerances shown. Also the part window will display the default tolerances as follows...

<table>
<thead>
<tr>
<th>Tolerance</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>X.X</td>
<td>+/- 0.1</td>
</tr>
<tr>
<td>X.XX</td>
<td>+/-0.01</td>
</tr>
<tr>
<td>X.XXX</td>
<td>+/-0.001</td>
</tr>
<tr>
<td>ANG</td>
<td>+/-0.5</td>
</tr>
</tbody>
</table>

This shows that the default tolerance varies according to the number of decimal places assigned to a dimension. The number of decimal places is determined whilst in the sketcher by SKETCH > OPTIONS on the PARAMETERS tab under NUM DIGITS. The default values, shown above, can also be changed choosing ANNOTATION in the selection filter at the bottom of the screen and double clicking on the tolerance value. Any modifications you make to these default tolerances apply only to dimensions subsequently created. Previous dimensions will have the default tolerances active when they were created. If, for example, you normally work with a general tolerance of +/- 0.3 on all unspecified dimensions, you could change all of the linear values to 0.3 and then assign suitable tolerances to individual dimensions as required later.

**Assigning Tolerances To Part Dimensions**

The two components shown in Figure 1 and Figure 2 are simple parts which are intended to fit together as part of an assembly. They are to be constructed as two separate Pro Engineer parts called tol1 and tol2. Using your existing knowledge of Pro Engineer create these two separate parts now using mmns_part_solid template. The L shaped block in tol1 can be created as an extruded protrusion and the three pegs are a second extruded protrusion created by sketching three circles onto the top face. **ENSURE YOU DIMENSION THE PARTS EXACTLY AS SHOWN.**
Having created the two parts it would be interesting to see what tolerance has been applied to each dimension. Open part tol1 now. First make sure that the DIMENSION TOLERANCES is checked in TOOLS > ENVIRONMENT. The default number of decimal places in sketcher is 2. If you have not changed this or the default tolerance values the tolerance on all dimensions with two decimal places X.XX should be reported in the graphics window as +/- 0.01. Confirm the tolerances are as you expected by right clicking on a feature in the model tree on the left of the screen and choosing EDIT. The dimensions should now be shown with their upper and lower limit values as you can see in Figure 3.

As an example of what tolerances can be used for at a part level the volume of material in a component could be calculated. Clearly since the dimensions have a tolerance the volume would also have a tolerance. To find out the volume range we need to calculate mass properties at maximum and minimum material conditions. The part dimensions are set to an extreme value by EDIT > SETUP > DIM BOUND > SET ALL > UPPER > DONE. Notice that SET ALL can be used for tol1 since maximum material conditions are when all dimensions are at the upper limit. If the part had a hole the dimensions for the hole feature would need to be set to the lower limit for maximum material. The volume can now be calculated using ANALYSIS > MODEL ANALYSIS and choosing the Type as Model Mass Properties and Compute. The density can be set to 1. Note the volume is calculated as 76 495 mm³. The calculation can now be repeated after first setting the dimensions to minimum material condition using EDIT > SETUP > DIM BOUND > SET ALL > LOWER > DONE. Note the volume is calculated as 75 863 mm³ a total variation of 632 mm³. Use EDIT > SETUP > DIM BOUND > SET ALL > NOMINAL > DONE to reset the bounds to their normal state.
Showing Tolerances on Drawings

To show dimensions on a drawing is a simple matter so long as the system has been set-up correctly. The following paragraph describes how to set up the system. You should be working in a drawing for these commands to work. Refer to Tutorials 4 and 5 for creating drawings and adding dimensions. Create a drawing of part tol1 now positioning the dimensions as shown in Figure 5.

The configuration for your drawing appearance (text height, arrow size etc.) is stored in a drawing set-up file. The current settings can be altered using FILE > PROPERTIES > DRAWING OPTIONS. A new dialog window will appear showing all your current settings. If tolerances are to appear in your drawing is important that this file contains a line that says tol_display yes. In the Option field type tol_display and set the value field to yes. Click Add/Change to change the value then close the dialog.

Now that the drawing is set correctly any dimension(s) can be selected and the command EDIT ⇒ PROPERTIES given. A form will appear showing the dimension settings as shown in Figure 6. The Tolerance Mode should be set to NOMINAL if you do not want tolerances displayed. Choose LIMITS or PLUS-MINUS to display tolerances. Notice that you can also adjust the value of the dimension and the tolerance from here.

Select the 12 diameter dimension of the pins and change the Tolerance Mode to Limits now to see the difference.

Figure 5 : Initial Drawing

Figure 6 : The Modify Dimension Form

Figure 7 : A Dimension with Tolerance
Analysing Assemblies with Tolerances

The holes and pins in parts tol1 and tol2 are intended to assemble together with a clearance fit of H9e9 as designated by BS4500. Reference to this standard shows that the tolerance for a 12mm shaft of this specification is –0.032 to –0.075. The matching hole would be +0.000 to +0.043. Change the tolerance of these two features now. In the tol1 part right click on the feature for the pins in the model tree and choose EDIT. Since you just set the tolerance mode for the diameter dimension to Limits two diameter values (12.01 and 11.99) should be displayed. Double click on the lower diameter dimension value for the pins (11.99) and type in the new value of 11.880. Double Click on the upper dimension value (12.01) and type in the new value of 11.950. In tol2 you will need to Edit the feature then click on the diameter dimension and choose EDIT > PROPERTIES so that you can set this to Tolerance Mode Limits. Then repeat the changes setting the lower dimension to 12.000 and the upper to 12.043.

To illustrate these concepts create a new empty assembly called tolass and assemble the two parts, tol1 and tol2, together. Use tol1 as the first component. Apply three constraints as tol2 is placed as shown in Figure 8. Make sure that the first mate constraint references the end from which the 15 dimensions is taken on tol2.

Mate These 2 Faces First

Mate These 2 Faces

Align the two front faces

Figure 8 : The Assembly Constraints

Once the assembly is complete analysis can take place. One problem that often occurs with tolerances is that assembled components will not work correctly when the parts in an assembly are all at one extreme of size. ProEngineer can calculate whether two parts in an assembly interfere with each other. In the assembly tolass issue the command ANALYSIS > MODEL ANALYSIS and choose the type of analysis as PAIRS CLEARANCE. Pick the two parts in the assembly and Compute. At this stage ProEngineer should report a zero clearance. Of course since the two parts are designed to touch along two faces this is what you would expect. What is the clearance between the pins and their holes? To find this use the command ANALYSIS > MODEL ANALYSIS and choose the type of analysis as PAIRS CLEARANCE but this time choose SURFACE as the From and To option. Pick on the cylindrical surface of one pin then right click until you pick the cylindrical surface of the corresponding hole. ProEngineer should report a clearance of 0. 0.0529799mm and a red marker will be displayed at one of the points of minimum clearance. Why is there this clearance value? Because the calculations are currently being performed on the parts at nominal sizes. The calculation is...

Pins at (11.88+11.95)/2=11.9150mm diameter.

Holes at (12.043+12.000)/2=12.0215mm diameter.

Clearance of (12.0215-11.915)/2=0.053mm.

If you do not get this value make sure you have set the dimension bounds to nominal (EDIT > SETUP > DIM BOUND > SET ALL > NOMINAL > pick part > DONE for each part).

The question remains that if the parts are at their worst extremes of tolerance will the parts still assemble? What are the worst extremes? This clearly occurs when the pins are at there biggest and the holes are at there smallest. Also if the distance between the pins is at a minimum and the distance between the holes is a maximum (or vice versa) a worst case scenario exists. To achieve this condition in ProEngineer we need to set up the dimension bounds as we did before but in the assembly. Use EDIT > SETUP > DIM BOUND > SET SELECTED > LOWER and pick the part tol1 on one of the pins. The dimensions for this feature will be displayed and you can now pick each spacing dimension in turn (i.e. 15mm, 20mm and 20mm) followed by DONE. These will be displayed in white indicating they are set to lower. Now using the similar command set the diameter of the pins to the UPPER tolerance. This time the dimension will be displayed in grey indicating an upper tolerance. Repeat this procedure for the holes in tol2 (use right click until you pick on the holes). This time the spacing needs to be set to UPPER and hole diameters to LOWER.

The assembly is now set to one extreme of tolerance. If the interference analysis between the two parts is performed again interference will be
reported the red areas where the parts overlap is highlighted. The assembly will NOT work as intended with the current tolerances. To make it work the tolerances on the spacing of the holes could be reduced but this is likely to increase the cost of the component. Is there an alternative?

If you look at the previous interference analysis you can see that the interference occurs on the last two pins, why? The problem is called tolerance stack up. Consider Figure 10 which shows two alternative dimensioning schemes.

The two schemes apparently are no different until you consider tolerances. If a tolerance of +/- 0.01 is applied to each dimension what is the overall distance to the centre of the right most circle. Using the chain-dimensioning scheme the tolerances are cumulative so the answer is 55 +/- 0.03. Using the baseline dimensioning scheme the dimension is specifically stated so the tolerances do not add up and the answer is 55 +/- 0.01. An improvement in accuracy has been achieved with no tightening of tolerances and no extra cost. In general baseline dimensioning is more accurate and should always be used except when chain dimensioning better reflects the critical dimensions.

You may like to return to the parts tol1 and tol2 and EDIT DEFINITION on the features so that the dimensions for the holes and pins reflect the baseline scheme. If you perform the analysis again you will find there is no interference and the assembly will work as intended.

**Review**

So what should you have learnt?

- How to define tolerances on part dimensions.
- How to show tolerances on drawings.
- How to use tolerances for analysis.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
Having created a model of your part it is often necessary, dependant on the manufacturing technique, to develop a mould system for injection moulding or casting. This document introduces the process of producing moulds covering the creation of mould halves from the defined part. It does not cover other aspects of mould creation such as adding mould filling channels, ejection pins etc.

The tutorial starts by assuming you already have a part designed and this is suitable for moulding. You should use the standard part provided for this tutorial. This can be downloaded from the internet and can be found at [http://www.staffs.ac.uk/~entdgc/WildfireDocs](http://www.staffs.ac.uk/~entdgc/WildfireDocs) under the Casing link in the Basic Moulding section. Save this part to your working directory.

**PREPARING TO MOULD**

Before we start to create the mould it would be good to check out the part to be moulded. Choose FILE > OPEN and choose the name casing.prt to load the part we are to mould.

![Figure 1: The Casing Model](image)

You should see the bottom half of a casing for an electronic hand held device in the Pro Engineer window as shown in Figure 1. If you can’t find this part check that you have downloaded it correctly from the website and you saved it in the current directory. There is nothing unusual about this part but to make life a little easier for the moulding process we can create a coordinate system in the part. A coordinate system defines the origin and the X, Y and Z directions of a model. To define a coordinate system choose INSERT > MODEL DATUM > COORDINATE SYSTEM. A dialog will be displayed. Select whilst holding CTRL the 3 datum planes in the mould part. Choose them in this order – CASING_RIGHT, CASING_FRONT, CASING_TOP. Since we have picked 3 datums Pro Engineer assumes we want an origin defined at intersection point of all the datums. The order that we picked the datums defines the X, Y, Z directions. Go to the properties tab and type in the name CASING_ORIGIN then click OK to create the coordinate system. Save the part.

The first step in the process of creating moulds from a model is to create a new file in which to work. Choose FILE > NEW and in the subsequent dialog box choose the options for MANUFACTURING and MOLD CAVITY and type in the name mould. Choose the mmns_mfg_mold template. This creates a new assembly ready for the definition of the mould.

![Figure 2: Creating a Mould Manufacturing Part](image)

**PLACING MOULD COMPONENTS**

Into this mould we need to assemble all of the parts to make the mould. In this simple case this means the actual part to be moulded and the block of material from which the mould will be made.

Start with the actual part to be moulded since we already have that.

Choose the icon and choose the part casing.prt from the list. A dialog will appear entitled Create Reference Model – choose the SAME MODEL option and OK. Then the layout dialog will be shown. Since we have a coordinate system in both parts this is automatically filled in for us aligning the coordinate system in the casing with the one in the mould. The layout section of the dialog allows you to create a mould with multiple cavities (or impressions). We only want one so leave this set to SINGLE and press OK. The casing should appear in the graphics window.

Now we need to place a block of material (called a workpiece) around this part. If we had a suitable block already defined we could simply ASSEMBLE it using the WORKPIECE option. Since we do not have a suitable block already defined we can create one now using MOLD MODEL > CREATE > WORKPIECE > AUTOMATIC or choose the icon.
Basic Moulding

SPLITTING THE MOULD

We now have the part to be moulded and the material from which the mould is to be made positioned correctly together. The next stage is to prepare to split the material block into two halves to make the mould. To do this we need to define another feature that will act as the ‘knife’ to cut the material in two halves. This feature defines the split-line in this case a flat plane. You could do this using the command PARTING SURF > CREATE but we will use the automated icons provided. First choose the \begin{figure}[h]
\centering
\includegraphics[width=0.9\textwidth]{split_lines}
\caption{The Split Lines}
\end{figure}

icon and simply click OK in the following dialog as all options are correctly defined automatically. You should see red lines appearing in the model as shown in Figure 5. These lines indicate where the casing will be split to create the mold. You may be thinking how does Pro Engineer know where to split it? The answer is simple it infers much of the information from the location of the original coordinate system which is why when we defined the first coordinate system in the casing model the location was important as this defined the position of the split and also the orientation was important as the Z axis defines the direction of the split.

The next step is to use these curves to define a split surface which will eventually be used to cut the mould into two parts. Choose the \begin{figure}[h]
\centering
\includegraphics[width=0.9\textwidth]{workpiece_defined}
\caption{Workpiece Defined}
\end{figure}

\begin{figure}[h]
\centering
\includegraphics[width=0.9\textwidth]{workpiece_creation_dialog}
\caption{Workpiece Creation Dialog}
\end{figure}

icon and type in the name MOULD_SPLIT_SURFACE. Click OK then select the red curves you just created followed by Done and OK. A new surface
will be created inside the material (Figure 6) which we will now use to cut the mould into two parts.

Figure 6 : Split Surface

Now we have the split surface we can use this to chop the mould material into two halves. The command structure for this is MOLD VOLUME > SPLIT or chose the icon then TWO VOLUMES | ALL WRKPCS | DONE. Now pick the split surface you just created then OK and OK on the dialog box. Accept the names provided for the two halves of the mould and if you want use the Shade button on the Volume Name dialog to see each part as it is created.

This operation has split the model into the two halves ready to define the mould. The information for the two halves is not yet stored as a solid model. It is in fact just a collection of surfaces. Before we proceed we must convert these to solids. This is done with the command MOLD COMP > EXTRACT or the icon and choosing all of the parts with from the dialog box and OK. This operation has created two separate parts (mold_vol_1.prt and mold_vol_1.prt), that can be retrieved individually and used (e.g. machined).

VIEWING THE MOULD

To better see what this procedure has done look at the Model Tree (see Figure 7). This shows that mould.asm contains four items…

1. CASING.PRT This is the model of the lower half of the casing.
2. MOLD_WRK.PRT The model of the block of material we created.
3. MOLD_VOL_1.PRT The model of the mould upper half.
4. MOLD_VOL_2.PRT The model of the mould lower half.

It’s easier to see the two mould halves if we first make some information invisible and then ‘open’ the mould. At the top of the main window you should see an icon . Click this to bring up the Blank/UnBlank dialog.
In this dialog click on the name MOULD_WRK below visible components and press BLANK at the bottom of the dialog. Now press and blank the parting surface. Close the dialog. This leaves just the two mould halves and the casing visible but with the mould in the closed position. The open position of the mould is defined by the command MOLD OPENING or the icon. Now choose DEFINE STEP > DEFINE MOVE and pick the top half of the mould. To define the move direction click on one of the vertical edges of the mould and type in a distance of 100. Repeat this for the lower half moving it down by -100. The drop down menu command VIEW > EXPLODE > EXPLODE VIEW controls the movement of the model between its open and closed state.

![Figure 9: The Completed Open Mould](image)

**Review**

So what should you have learnt?

- How to define coordinate systems for moulds.
- How to create and locate basic mould components.
- How to split into mould halves.
- How to show mould components in the open position.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
Introduction to Injection Moulding

Injection moulding is a process that has been used in a wide variety of industries for many years. This process uses amorphous and crystalline thermoplastic resins that are heated to a stable temperature and compressed into a mould. The diagram in Figure 1 shows the process of injection moulding.

Cold polymer is feed from the hopper into the screw where it is heated; the ram then forces the hot molten polymer into the cold mould. The polymer is then left to cool for a pre-determined time before the mould is opened and the part is ejected. This process can be used to produce both simple and very complex components in a very short time. Examples of familiar products produced by this technique are computer cases, mobile phones casings, garden chairs etc.

One of the main problems with injection moulding is the set up cost; this includes the mould design and the tooling required. This makes it suitable for high volume production where the cost of moulds can be amortised over a large number of products. To help to reduce the cost of setting up this process ProEngineer has designed a package called Pro Plastic Advisor. This is an optional package – there is no guarantee any system (outside of Staffordshire University) will include the software. This package can be used to analyse the moulding process and increase confidence in the design before significant costs are incurred in mould manufacture.

Pro Plastic Advisor Analysis

In this tutorial you will be introduced to some of the basic functionality of Pro Plastic Advisor. This will include loading the part into the Advisor package, selecting a fill point, selecting a suitable material and producing a report of the product analysed. The first step is to download the part to be analysed from the Internet. The part name is casing.prt and can be found at http://www.staffs.ac.uk/~entdgc/WildfireDocs. Download the part and save it to your working directory. Start ProEngineer and load this part.

Pro Plastic Advisor is a separate package closely linked to Pro Engineer. To start an analysis, transfer the part into Pro Plastic Advisor using the following process APPLICATIONS > PLASTIC ADVISOR then press the middle mouse to miss out the injection point definition (for now).

Pro Plastic Advisor will now open. To show the part to be analysed choose WINDWO > CASING. Holding down the left mouse button and moving the mouse will rotate the view of the part. The middle mouse button zooms in/out and the right button pans. You can also use the arrow keys to rotate the view.
Injection Location

The first step in defining and analysis is to position the injection location where the polymer will enter the mould. Consideration must be taken to find the best place to inject the polymer. In the first exercise we will inject the polymer from the top of the model. Orientate the part as shown in Figure 4.

To select the polymer injection location, click the polymer injection location icon that can be found at the top of the screen then click in the centre of the model. An arrow will appear as shown in Figure 4. Is this a good location from a design perspective? Injection locations will leave marks on the product so you would normally choose to inject on the inside of a product.

Material Definition

The next step is to define a suitable polymer. ProPlasticAdvisor has a built in polymer materials database with over 4000 polymers to choose from. When selecting a polymer for a product the physical and mechanical properties such as strength, stiffness, hardness, etc. must be considered. The diagram in Figure 5 shows a generalised performance spectrum of plastic materials.

The product in this tutorial is the back of a mobile phone. Mobile phones are often made from ABS so this is the material we will used in this tutorial. To select a material open the materials database by clicking on the mould parameter button. This will display the mould parameters dialogue box where the material needed for this operation can be selected. Click on specific material and the choose the material shown in Figure 6. Click on the DETAILS button to see some of the properties of this material.
Analysing the Model

We are now ready to analyse the model. This process is started by ADVISER > ANALYSIS SELECTION or by clicking on icon. The dialog box displayed allows you to choose the type of analysis required. Choose plastic flow analysis and START.

This process will take about 30 seconds to complete, although this depends on the performance of your computer. During the analysis the part will be displayed transparent and will gradually fill with material starting from the injection point. On completion a results summary box will appear giving information on the process and also stating whether the model is suitable for analysis. The results summary box for this analysis will show amber traffic lights indicating there are possible problems - in particular weld lines and air traps may be created. Press the More… button to show a help page explaining these results in more detail.

Close the results summary box. The main graphics display will have changed to show confidence of fill which is entirely green indicating the part should fill correctly. Click on the Weld line Locations button. This will show red lines on the model where weld lines may form. Weld lines are where two separate flows of material within the mould meet and weld together. They can cause weaknesses in the final product and so should be minimised or avoided.

Click on the Air Traps Location button. This will show blue dots around the bottom edge of the model. This is the location where air may get trapped in the moulding process. Air pockets can result in incomplete filling of the mould causing weaknesses or poor surface finish in the final product and so should be minimised or avoided.
Remember it is rare to achieve a perfect mould analysis and good mould can be achieved even when nominal problems are reported. This analysis for example may well achieve a good mould even with these reported problems.

To improve your understanding of the analysis you can choose ADVISER > ADVISER or the icon. This displays a dialog with two tabs – choose the Quality Prediction tab. Areas of the model are shown in yellow showing problems exist.

![Quality Prediction](image1)

**Figure 10 : Quality Prediction**

Click with the RIGHT mouse button on a yellow area to get info on the problem. The dialog warns that the cooling time is too high and clicking on More… will give advice on the problem. It suggests you could…

- Decrease the melt temperature.
- Decrease the mold temperature.
- Make the problem area thinner.

You may have noticed that both the weld lines and the low quality area occur around the screw holes. One of the design goals for plastic injected parts is to maintain constant wall thickness. The material is much thicker in this area – could this be a source of the problem? Could a design changes in the part help?

The software also gives the user access to additional information on the RESULTS > SHOW menu. This menu will display the confidence of fill, fill time, pressure drop, injection pressure and flow front temp. Let's look at fill time. Choose RESULTS > SHOW > FILL TIME. When any time based result is displayed the ‘video’ control buttons are active at the top of the window. These let you view the results over time. Click the play results button 🎥. This will play a small animation showing the module filling with polymer and also gives the fill time on the right hand side of the screen.

### Generating Reports

Pro Plastic Advisor can produce a web based data sheet showing all the information on the products progress. This is achieved by clicking on the Report button 📊. A wizard will appear asking for information about the product and allowing you to choose what analysis elements you want to include. You will now need to select a location where you wish to save the report. Since the report will contain many files it is a good idea to keep them all together by creating a new directory. The program will generate a report in web page format and save all the information in the chosen directory. The web page will load up in the analysis software. If this does not happen or you wish to view the page at a later date then in Windows open the directory and double click on file **index.htm**.

![Fill Time Display](image2)

**Figure 11 – Fill Time Display**

### Review

So what should you have learnt?

- How to start a mould flow analysis.
- How to position injection points and select materials.
- How to perform analyses.
- How to understand results.
- How to generate reports.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
What Next?
Now you have a general idea of how to operate the software you may want to try a correctly structured analysis either on this or another part of your own. The table below shows the sequence of steps you should undertake to correctly perform a full analysis and generate all possible feedback.

<table>
<thead>
<tr>
<th>Sequence Description</th>
<th>Analysis Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select material based on experience or databases such as CES.</td>
<td>Bayer AG Bayblend 45</td>
</tr>
<tr>
<td>Perform Gate Analysis to find best position for injection point.</td>
<td></td>
</tr>
<tr>
<td>Position injection point and perform a moulding window analysis to determine best material conditions.</td>
<td></td>
</tr>
<tr>
<td>Use the conditions specified and performs a plastic flow analysis to determine mould ability.</td>
<td></td>
</tr>
<tr>
<td>Perform a Cooling Quality analysis.</td>
<td></td>
</tr>
<tr>
<td>Perform a Sink Mark analysis.</td>
<td></td>
</tr>
</tbody>
</table>
Mechanism design in Pro Engineer is very comprehensive. You can assemble components of the mechanism together using joints which accurately reflect their movements, you can animate the movement creating movie files which can be displayed on any PC and you can ask Pro Engineer to calculate the forces and movements of a mechanism to enable you to determine the suitability of the mechanism.

**Degrees of Freedom**

Understanding degrees of freedom is critical to selecting the appropriate joints for your mechanism. In mechanical systems, the number of degrees of freedom (DOF) represents the number of independent parameters required to specify the position or motion of every body in the system. A completely unconstrained body has six degrees of freedom, three translational and three rotational. Joint connections act as constraints, or restrictions, on the motion of bodies relative to each other, reducing the total possible degrees of freedom of the system. If you apply a pin joint to a body, you restrict the body's movement to rotation around the pin joint, and the degrees of freedom for the body reduce from six to one. Below is a table describing the joint connections you can create in Mechanism Design and the degrees of freedom corresponding to each joint.

<table>
<thead>
<tr>
<th>Joint</th>
<th>Diagram</th>
<th>No. of DOF</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pin</td>
<td><img src="image" alt="Pin Diagram" /></td>
<td>1 0</td>
<td>Rotates about an axis.</td>
</tr>
<tr>
<td>Sler</td>
<td><img src="image" alt="Sler Diagram" /></td>
<td>0 1</td>
<td>Translates along an axis.</td>
</tr>
<tr>
<td>Cylinder</td>
<td><img src="image" alt="Cylinder Diagram" /></td>
<td>1 1</td>
<td>Translation along and rotation about a specific axis.</td>
</tr>
<tr>
<td>Planar</td>
<td><img src="image" alt="Planar Diagram" /></td>
<td>1 2</td>
<td>Bodies connected by a planar joint move in a plane with respect to each other. Rotation is about an axis perpendicular to the plane.</td>
</tr>
<tr>
<td>Ball</td>
<td><img src="image" alt="Ball Diagram" /></td>
<td>3 0</td>
<td>A &quot;ball-in-spherical-cup&quot; joint allows rotation in any direction.</td>
</tr>
<tr>
<td>Bearing</td>
<td><img src="image" alt="Bearing Diagram" /></td>
<td>3 1</td>
<td>Combination of a ball joint and a slider joint.</td>
</tr>
<tr>
<td>Weld</td>
<td><img src="image" alt="Weld Diagram" /></td>
<td>0 0</td>
<td>Glues two parts together.</td>
</tr>
<tr>
<td>Rigid</td>
<td><img src="image" alt="Rigid Diagram" /></td>
<td>0 0</td>
<td>Glues two parts together while changing the underlying body definition. Parts constrained by a rigid connection constitute a single body.</td>
</tr>
</tbody>
</table>

**Mechanism Design**

It will be valuable if you already understand the assembly process in Pro Engineer and have completed the assembly tutorial. We will use the pair of mole grips as a basis for explaining how to assemble mechanisms together. Mole grips are like a pair of pliers – with one additional function. They have an over centre mechanism so that when they are squeezed to
grip a bar they stay locked until they are released by the user. To achieve this they must be correctly adjusted to the size of the bar using the adjuster screw on the end of the handle.

![Figure 2: Mole Grips](image)

To design a mechanism in Pro Engineer you must first design the individual parts of the mechanism. The part files for this model can downloaded from the internet and can be found at [http://www.staffs.ac.uk/~entdgc/ProeDocs](http://www.staffs.ac.uk/~entdgc/ProeDocs) in the Mechanism section. Save all 8 parts to your working directory.

Use FILE > NEW to create a new assembly called mole_grips using the Empty template.

Choose INSERT > COMPONENT > ASSEMBLE and choose the part mole_main. The main handle of the grips should be placed in the graphics window (If the component placement dialog appears you did not choose the Empty template for the assembly – start again!).

![Figure 3: Main Part Added](image)

Choose INSERT > COMPONENT > ASSEMBLE and choose the part mole_jaws. The component placement dialog should appear this time. In this dialog click on the connect tab (see Figure 4) to show an alternative dialog which must be used for assemblies involving mechanisms.

![Figure 4: Mechanism Connections](image)

You should notice that the default joint type is PIN. This type of joint constrains a pin into a hole aligning their axes and also mates 2 faces. This is the correct type of joint in this case. Pick the cylindrical surfaces of the two matching holes on each part (see Figure 5).

![Figure 5: Pin Join First Step](image)
This will align the axes of the two holes and the jaws will move to make this alignment however you have not yet constrained the position of the jaws along this axis. You should notice that the Component placement dialog has moved on to Translation and is waiting for you to make further selections. To be correctly positioned the jaws must be in the centre of the mole_main part – in other words datum plane DTM3 on the jaws should be aligned with datum plane DTM3 of the mole_main part. Click on these two datums now and the joint should be made (Can't see any datums? Then choose TOOLS > ENVIRONMENT and tick next to Datum Planes). This is the only joint we need so click OK to finalise the placement of the jaws.

The joint definition is identical to the previous PIN joint so choose the correct two holes and DTM3 in the handle and jaws. IMPORTANT NOTE: All of the defining surfaces for a joint must come from the same pair of components – since the holes were in the handle part and the jaw part the two datums must be in these parts to. You could not for example pick DTM3 in the mole_main part. Close the dialog and perhaps try dragging the mechanism.

Joints are indicated by a yellow symbol in the graphics area. In the Model Tree you should notice a small square next to the name MOLE_JAWS.PRT (see Figure 7) – this is correct and indicates that this part is not fully constrained as the jaws are free to rotate around. You can prove this by clicking on the DRAG icon (if you can't see this icon then choose APPLICATIONS > MECHANISM then MECHANISM > DRAG). You should now be able to click on the jaws and move them, spinning them around the joint!

The next part to assemble is mole_handle so choose INSERT > COMPONENT > ASSEMBLE to assemble this now. Don't forget to click on the CONNECTION tab in the component placement dialog (see Figure 4).
Drag the parts so the strut is in a more realistic position (See Figure 10).

The final part in the mechanism is mole_screw. This is the adjuster screw. As you turn the screw it moves in and out. The strut touches the end of the screw so that as the screw moves it has the effect of altering the distance between the jaws. Let’s try and simulate this now so that you can understand it better.

Choose INSERT > COMPONENT > ASSEMBLE to assemble the mole_screw. Don’t forget to click on the CONNECTION tab (see Figure 4). We need a different type of joint this time called a SLIDER so choose this now below the word TYPE. A slider joint allows movement along an axis so that we can move the screw in and out (we won’t bother simulating the screw rotation). The joint definition is similar to the previous PIN joint. First we need two axes to align so choose the hole in the end of the mole_main part and the cylindrical surface of the mole_screw. A slider also requires two planar surfaces to stop rotation – pick DTM3 in mole_screw and DTM3 in mole_main (of course strictly speaking our screw does rotate but it does not matter). DO NOT close the Component Placement dialog yet!

We now have to link the strut to the screw. This means we need an extra joint so the screw will have two joints. Click + in the Component Placement dialog to make a new joint. The type of joint we need here is a Cylinder so choose it now below Type. A cylinder joint is a PIN joint without the translation surfaces – it just needs two axes to align. If you look carefully you will see that the strut has an axis through the cylindrical surface at the end and the screw has an axis which has been especially created the same distance away from the end of the screw as the strut radius. They are both labeled A_2 and are highlighted in Figure 11. Pick these now to complete the joint. Don’t worry if the pin moves to the wrong position along the axis. Close the placement dialog and try dragging the pin to a more realistic position.

As you are dragging parts in this mechanism you may notice that when dragging the handle the screw moves in and out. In real mole grips the screw position would not change when moving the handle. How can we make this work correctly?

Go to APPLICATIONS > MECHANISMS and MECHANISM > DRAG and notice the DRAG dialog box. This has a tab called Constraints. Click on it now and then click on the body-body lock constraint icon. This allows you to restrict movement of a joint. Click on the mole_main part then click on the mole_screw part and choose OK. These two parts will be locked in their current position. You should now be able to drag the handle without the screw moving. You can remove this lock by removing the tick next to the body-body lock in the constraints tab. The screw is then free to move again and can then be locked again in a new position by adding the tick.
Mechanism Animation

You have seen how by dragging you can move the mechanism through its range of movement. This can be used to generate a sequence of movements for the mechanism that can be replayed within Pro Engineer whilst modifying some design parameters or can be saved as a video in one of the standard Windows video formats then replayed outside of Pro Engineer in Windows Media player or similar.

To define an animation choose APPLICATION > ANIMATION. The screen will change with the important addition of an area below the main graphics window. This is where the timeline editor will appear. A timeline defines what events happen and at what they start/stop. But what are these events and how do we define them? In simple terms an event is a mechanism position. The model can be dragged to different positions and a snapshot taken of the model in that position. Here is how...

First let’s set the mechanism up correctly. The command ANIMATION > SNAPSHOT is used to drag the mechanism. Choose this now and in the Constraints tab click on the body-body lock constraint icon. Click on the mole_main part then click on the mole_screw part and choose OK to lock the screw in place like before.

Make sure by dragging that the mole grips are in the closed position with the handle near horizontal. At the top of the drag dialog you will see the camera icon. Press this now and Snapshot1 should be created in the snapshots tab. This has memorized the position of the mechanism as it is now. Move the handle to the fully open position and press again. You should now have 2 snapshots. Go back to the Constraints tab and change the unlock (remove tick) the Body-Body lock. Move the screw to a new position then replace the tick to lock the screw movement. Take two more snapshots with handle closed (Snapshot3) and open (Snapshot4). Close the dialog. We have just defined 4 events that need to be turned into an animation.

Press the icon or choose ANIMATION > KEY FRAME SEQUENCE. Choose NEW and the Keyframe Sequence Editor dialog appears (see Figure 13). Type Mole in the name field. Below Keyframe Snapshot1 should be listed and time 0.000. In the dialog press to add this Snapshot1 to the animation. Then select Snapshot2 from the list and change the time to 2 and press again. Press OK. You should see the Mole animation appearing in the timeline.

Now in the animation toolbar press or ANIMATION > START to generate all the intermediate frames between Snapshot1 and Snapshot2. Once generated you can press or ANIMATION > PLAYBACK to play the sequence again using the Animate dialog which has controls like a video recorder.

Figure 13 : Key Frame Editor
You will see that the open of the mole grips happens in the first 2 secs of the animation. We can add more events to the animation. Click on the Mole animation in the timeline to select it then right click on it and choose EDIT KFS. The Keyframe Editor will be displayed. Select Snapshot1 from the dropdown list, type a time of 4 and press [‎+‎]. Select Snapshot3 from the dropdown list, type a time of 6 and press [‎+‎]. Select Snapshot4 from the dropdown list, type a time of 8 and press [‎+‎]. Select Snapshot3 from the dropdown list, type a time of 10 and press [‎+‎]. The events are all shown in Figure 13. Close the dialog. Now in the animation toolbar press [‎+‎] or ANIMATION > START to generate all the intermediate frames again.

Next press [‎+‎] or ANIMATION > PLAYBACK to play the animation. The mole grips should open and close, the screw position should move and then they should open and close again.

In the Animate dialog the CAPTURE option can be used to capture an MPEG movie from the sequence which can be replayed in Media Player.

**Review**

So what should you have learnt?

- How to assemble mechanisms using different joint types.
- How to drag mechanisms.
- How to create and save animations.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
This tutorial builds on the experience of working with mechanisms provided in the MECHANISMS tutorial. It is essential that you have completed and fully understand that tutorial before you progress on these more advanced functions.

Two new functional areas are covered here. First the concept of using gears and drivers to power mechanisms is covered. Secondly a novel use for mechanism in preparing assembly instructions is demonstrated. The whole tutorial is based around the mechanism shown in Figure 1 which is a simple wash/wipe assembly for the rear window of a hatchback car.

**Figure 1 : Wash/Wipe Mechanism**

**Mechanism Review**

By way of review we will go through the process of assembling the mechanism. This uses the techniques already shown in the MECHANISMS tutorial and so instructions will be brief. If you need to, refer back to the earlier tutorial.

Create a new empty assembly file called wipermechanism and assemble the mechanism in the following order using the joint properties described in this table. Some assembled pairs (marked assembly only) do not require a joint and should be assembled in the normal way. The steps with a grey background can be omitted without affecting the function of the mechanism if you are short of time.
<table>
<thead>
<tr>
<th>Part</th>
<th>Joint Type</th>
<th>Axis Alignment</th>
<th>Translation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pinion.prt</td>
<td>Pin Joint</td>
<td>A_2 with motor A_2</td>
<td>top of pinion with top of motor shaft</td>
</tr>
<tr>
<td>Nut3mm.prt</td>
<td>Assembly Only</td>
<td>A_2 to motor axis A_5</td>
<td>mate base surface of nut3mm to underside of motor bracket</td>
</tr>
<tr>
<td>Axle.prt</td>
<td>Assembly Only</td>
<td>A_2 to bracket axis A_7</td>
<td>mate base surface of axle to top of bracket</td>
</tr>
<tr>
<td>Nut7mm.prt</td>
<td>Assembly Only</td>
<td>A_2 to bracket axis A_7</td>
<td>mate base surface of nut7mm to underside of motor bracket</td>
</tr>
<tr>
<td>Arm.prt</td>
<td>Pin Joint</td>
<td>A_10 with axle A_2</td>
<td>base of axle with top of step on axle shaft</td>
</tr>
<tr>
<td>Longarm.prt</td>
<td>Pin Joint</td>
<td>A_5 with gearwheel A_46</td>
<td>top of step on gearwheel</td>
</tr>
<tr>
<td>Nut7mm.prt</td>
<td>Assembly Only</td>
<td>nut7mm to arm axis A_10</td>
<td>mate base of nut7mm with step on gearwheel with 2.5 offset.</td>
</tr>
<tr>
<td>Arm.prt</td>
<td>Pin Joint</td>
<td>nut7mm to arm axis A_6</td>
<td>top surface of arm with 2.5 offset.</td>
</tr>
</tbody>
</table>
If you have assembled the mechanism correctly you should now be able to enter mechanism mode (APPLICATION > MECHANISM) and drag the wiper blade to flex the mechanism using the MECHANISM > DRAG. If the mechanism does not flex you will need to check each of the assembly steps for accuracy – particularly check that you have selected the axis of the correct body at each stage.

Gears

You may notice as you drag the mechanism that the pinion gear on the motor does not move. There is no connection between the two gears. A connection can be created using MECHANISM > GEARS and pressing the NEW button. The dialog in Figure 2 will be shown.

Drivers

Of course with a real wiper you don’t move it by dragging the wiper! You turn on the motor. The equivalent in Mechanism is to define a driver to turn the gear on the motor. One type of driver – called a servo motor - can be created using MECHANISM > SERVO MOTORS and pressing the NEW button. The dialog in Figure 3 will be shown.

Like gears you first have to select the axis of the motor so pick the yellow arrow symbol – at the centre of the large gearwheel. Click on the Gear2 tab and pick the joint axis for the pinion gear. On the properties tab change the Gear Ratio to user defined. The gearwheel (Gear1) has 42 teeth and the pinion (Gear2) has 12 teeth so enter these values in the boxes.

Exit the dialog and try dragging the mechanism to check that the gears now mesh correctly.
To see the motor in operation it is necessary to define an Analysis using MECHANISM > ANALYSES and creating a New analysis. First define the graphical display parameters. Enter the values shown in Figure 4. Also click on the Motors tab and press the or button to add the motor definition to the analysis. When this is done you should be able to press the RUN button at which point the motor will run and the mechanism will be flexed through its full range of movement – you should see the movement on the screen.

Assembly Simulation

One novel use of mechanisms is to simulate the steps undertaken in the process of assembling the components together. To achieve this is a different set of joints would be needed than those used in the mechanism so it is necessary to save the assembly simulation as a different file from the mechanism simulation. So to start open the wipermechanism assembly and choose FILE > SAVE AS and enter a new name such as wiperassembly. You will notice that the file that is open in front of you now is still wipermechanism so choose FILE > CLOSE WINDOW then FILE > OPEN and locate the newly created wiperassembly file. This is of course currently identical to the original assembly file.

Now we need to modify this file to simulate the assembly. Basically each part in the assembly needs to be defined by a joint which allows the part to move along the direction it will be assembled.

For example the second part in the assembly is the washer. Originally this was assembled without a joint at all. It now needs to be assembled with a joint that allows the washer to move along the axis of the washer – this type of joint is called a cylinder (you could also use a slider but that also restricts rotation which is not necessary). This modification (using EDIT DEFINITION) is shown in Figure 5.

Other parts, such as the gearwheel already have a joint defined but the joint is the wrong type and can be changed e.g. the pin joint can be changed to a cylinder joint).
So to prepare the current model into an assembly simulation you need to go through each part in turn, right click on the name in the feature tree and choose EDIT DEFINITION then create or change the joint type. Finally, drag the part to a position away from the assembly – in the position where it would start the assembly process. Close the assembly dialog and move on to the next part. The following table describes the joints for each part.

<table>
<thead>
<tr>
<th>Part Name</th>
<th>Modification</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bracket.prt</td>
<td>No Change</td>
<td></td>
</tr>
<tr>
<td>Washer.prt</td>
<td>Delete the MATE constraint. Convert to CYLINDER joint. Move to starting position.</td>
<td></td>
</tr>
<tr>
<td>Gearwheel.prt</td>
<td>Convert PIN joint to CYLINDER. Move to starting position.</td>
<td></td>
</tr>
<tr>
<td>Gearshaft.prt</td>
<td>Delete the MATE constraint. Convert to CYLINDER joint. Move to starting position</td>
<td></td>
</tr>
<tr>
<td>Motor.prt</td>
<td>Delete the MATE constraint. Convert to CYLINDER joint. Move to starting position.</td>
<td></td>
</tr>
<tr>
<td>Pinion.prt</td>
<td>Convert PIN joint to CYLINDER. Move to starting position.</td>
<td></td>
</tr>
<tr>
<td>Nut3mm.prt</td>
<td>Delete the MATE constraint. Convert to CYLINDER joint. Move to starting position.</td>
<td></td>
</tr>
<tr>
<td>Axle.prt</td>
<td>Delete the MATE constraint. Convert to CYLINDER joint. Move to starting position.</td>
<td></td>
</tr>
<tr>
<td>Nut7mm.prt</td>
<td>Delete the MATE constraint. Convert to CYLINDER joint. Move to starting position.</td>
<td></td>
</tr>
<tr>
<td>Arm.prt</td>
<td>Convert PIN joint to CYLINDER. Move to starting position.</td>
<td></td>
</tr>
</tbody>
</table>
Delete the MATE constraint. Convert to CYLINDER joint. Move to starting position.

Delete the MATE constraint. Convert to CYLINDER joint. Move to starting position.

Convert PIN joint to CYLINDER at both ends. Move to starting position.

NOTE THIS IS DIFFERENT TO ALLOW THE BLADE TO SLIDE INTO POSITION.

Delete the ALIGN constraint. Convert to PLANAR joint. Move to starting position.

Delete the MATE constraint. Convert to CYLINDER joint. Move to starting position.

Delete the MATE constraint. Convert to CYLINDER joint. Move to starting position.
The assembly should now have all the joints defined and the parts in their starting positions. Now we have to create an animation. You did this in the MECHANISM tutorial but we will review and introduce some new functions now.

Creating an Animation

To define an animation choose APPLICATION > ANIMATION. (You may get a warning message about invalid servo motors because the servo motor defined earlier is no longer valid – this can be ignored) The screen will change with the important addition of an area below the main graphics window. This is where the timeline editor will appear. A timeline defines what events happen and at what time they start/stop. But what are these events and how do we define them? In simple terms an event is a mechanism position. The model can be dragged to different positions and a snapshot taken of the model in that position. Here is how…

Choose the icon or the ANIMATION > SNAPSHOT command. The Drag Dialog shown in Figure 6 will appear.

![Figure 6: The Drag Dialog](image)

You can use the camera icon at the top of the dialog to take snapshots of the ‘mechanism’ in its current position. Do this now to save a snapshot of the ‘mechanism’ in its starting position. This will be saved under the name Snapshot1.

We now have to create a snapshot with each component in its assembled position. You could use the drag icon to position each part in its assembled position but there are some more accurate functions we can use.

The CONSTRAINTS tab provides functions to control the position of components. There are functions similar to assembly functions such as MATE and ALIGN but these are temporary constraints only. Choose the MATE icon now and pick the top surface of the bracket and the bottom surface of the washer. The washer should snap to the correct assembled position. You may find that some of the other parts move as well due to the internal relationships. You can use the drag icon to reposition these other parts to their original position at which point you can use the camera icon again to take another snapshot of the ‘mechanism’ after the washer is assembled. This will be called Snapshot2.

This basic procedure needs to be repeated for every part if the assembly. Some of the parts (the Blade) may require MATE and/or ALIGN functions to correctly position them. Don’t forget after each position is defined to take a snapshot. When the ‘mechanism’ is fully assembled you should have 17 snapshots or events defined that need to be turned into an animation. Close the Drag dialog.

![Figure 7: Key Frame Editor](image)
Press the icon or choose ANIMATION > KEY FRAME SEQUENCE. Choose NEW and the Keyframe Sequence Editor dialog appears (see Figure 7). Type Assembly in the name field. Below Keyframe Snapshot1 should be listed and time 0.000. In the dialog press to add this Snapshot1 to the animation. Then select Snapshot2 from the list and change the time to 1 and press again (The time of 1 sec could be set to the actual time that this part of the assembly takes). Repeat this process for each of the 17 snapshots defined. Press OK. You should see the Assembly animation appearing in the timeline. You can right click on the timescale at the bottom of the screen and choose EDIT TIME DOMAIN to change the overall time (to 16 secs) and frame rate of the animation period.

Now in the animation toolbar press or ANIMATION > START to generate all the intermediate frames between the snapshots. Once generated you can press or ANIMATION > PLAYBACK to play the sequence using the Animate dialog which has controls like a video recorder.

![Figure 8 : Animate Dialog](image)

In the Animate dialog the CAPTURE option can be used to capture an MPEG movie from the sequence which can be replayed in Media Player.

Notice that position of the mechanism and the view that you are looking at the mechanism from is independent so you can look at the mechanism from any viewing position before playing the animation. It is normal to zoom in on the centre of the assembly – in this case the bracket – so that the parts ‘appear’ from of the screen as they are assembled.

However you may wish to change the view during the animation – this is possible using the ANIMATION > VIEW @ TIME or icon. First though you have to define the views that you want using the VIEW > VIEW ORIENTATION > REORIENT command (use the mouse to get the view you want then press type in a meaningful name then press SAVE).

Create two views now one called CLOSEUP which is zoomed into the motor end of the bracket and one called FAR which shows the whole assembly. Now you have the views you need choose ANIMATION > VIEW @ TIME or icon. Choose CLOSEUP as the name and a time of 0 then press the apply button. Choose CLOSEUP again and a time of 12 then press the apply button. Choose FAR and a time of 14 then press the apply button. Close the dialog. In the timeline at the bottom of the screen a second line should have appeared with the view names. Now in the animation toolbar press or ANIMATION > START to generate all the intermediate frames between the snapshots and then or ANIMATION > PLAYBACK to play the sequence. The animation should start with a close-up then after 12 secs zoom out.

**Review**

So what should you have learnt?

- How to assemble mechanisms using different joint types.
- How to create gears and motors
- How to simulate the assembly process.
- How to create and save animations.
- How to change the view during an animation.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
It is essential that you have completed the previous two tutorials on mechanisms from this series before starting this one. The part and assembly files for this model can downloaded from the internet and can be found at [http://www.staffs.ac.uk/~entdgc/ProeDocs](http://www.staffs.ac.uk/~entdgc/ProeDocs) in the Dynamics section. Save all 7 parts and 1 assembly to your working directory.

Open the assembly and you will see that the mountain bike has already been assembled for you and operates correctly as a mechanism. Check this out now by using the DRAG command. Some points worth noting are:

1. The method used to model the frame of the bicycle.
2. The front wheel is the first part assembled and is effectively locked to ground so it doesn’t move.
3. The rear wheel is assembled using a planar joint so it is free to move backward and forward as the suspension flexes since the wheelbase will change.

![Figure 1: The Bike](image)

Review all these features now and ensure you understand how they were achieved by referring to the earlier mechanism tutorials. You may even prefer to create your own assembly file and assemble your own cycle to ensure you fully understand the process.

**Joint Definitions**

As you drag this mechanism you will probably have noticed that the damper joint moves too far. The parts can actually move so they pass through each other. This means the suspension travel is much too large. Any joint in Pro Engineer can have its movements restricted – here’s how.

First use the DRAG tool to position the mechanism such that the damper is near one extreme of its travel as shown in Figure 2 (you may want to switch to hidden line display to see this). Then choose MECHANISM > JOINT AXIS SETTINGS and pick the SLIDER joint to define its settings. Press the MAKE ZERO button to define the current position as the zero location. Next click on the Properties tab in this dialog and tick Enable Limits and enter the values for maximum and minimum travel. This damper has a range of 50mm and the travel is in the opposite direction to the joint so the maximum value will be 0 and the minimum -50.

![Figure 2: Joint Limits](image)

Now if you DRAG the model the movement should reflect a real bike frame.

**Springs**

Although the bike moves correctly there are some elements of the bike suspension that are missing. The first of these is the spring. It is possible to model a spring using the HELICAL SWEEP command and this would look like a spring. For the analysis of mechanisms we need a spring that reacts correctly like a spring applying forces as it is compressed. This type of spring can be defined in mechanisms. Make sure you are in mechanism analysis mode (APPLICATION > MECHANISM) then choose
MECHANISM > SPRINGS and create a NEW spring. From the dialog box which appears (Figure 3) you will see there are two ways of defining the spring – on a joint axis or point-to-point. We will use the point-to-point option so choose this then pick the 2 points that have already been created in the model called SHOCKTOP_POINT and SHOCKBOTTOM_POINT. One of the advantages of using point-to-point is that Pro Engineer will create a visual representation of the spring – untick the Default option for the icon and type a diameter of 36.

Finally we have to define the dynamic properties of the spring. The force created by a spring is directly related to the compression of the spring (Pro Engineer has no facility for variable rate springs). Most springs start of with some pre-compression so the actual force from a spring is given by the formula Force=k*(x-U) where K is the spring stiffness (N/mm) and U is the free length of the spring (mm). Enter values of 190 for k and 125 for U. Choose OK to see the spring icon which may not be perfect but it is a reasonable representation.

**Dampers**

The second missing element is the damping action which is created in a similar manner. Choose MECHANISM > DAMPERS and create a NEW damper. From the dialog box which appears (Figure 3) you will see there are three ways of defining the damper. Though it is less important in this case we will be consistent and use the point-to-point option so choose this then pick the same two points SHOCKTOP_POINT and SHOCKBOTTOM_POINT. The damping force created by a damper is related to the velocity of movement of the damper multiplied by a damping constant C (Pro Engineer has no facility for variable rate dampers or different rates for compression and bump). Enter a value of 1.1 for the damping constant C. Choose OK to finish the definition.

**Materials**

Closely related to the gravity settings are the material properties. The default density assigned by Pro Engineer is 1 tonne/mm³ which means parts will be extremely and have very high inertia – they will be difficult to move! To set the correct density values choose MECHANISM > MASS PROPERTIES.
Pick one of the parts in the mechanism (say the frame) and change the Define Properties by to Density. The DENSITY field should now be editable and you can type in a value in tonne/mm³. (Aluminium 2.7936e-9, Steel 7.82708e-09, Nylon 1.20014e-09). Change the value to aluminium for ALL the parts in this assembly. Don’t forget to do all the parts otherwise the later calculations will not work correctly.

Gravity Forces

If the mechanism is to react correctly gravity must be specified. This is easily set using MECHANISM > GRAVITY. Note the units required in this dialog mm/sec² so the normal (earth) value is 9810. The direction for this model is -1 in Y.

Initial Conditions

We are soon going to start to analyse this mechanism soon. To do this it is useful to have a known starting position called an Initial Condition in Pro Engineer. Initial conditions can specify the start position, velocity and acceleration of a mechanism. We are only interested in the start position which is defined by a snapshot. Drag the mechanism so that the damper is fully compressed and save this as a snapshot called DamperMin as described in the earlier Basic Mechanisms tutorial (hint : use the icon in the DRAG dialog). Now choose MECHANISM > INITIAL CONDITIONS to define the start conditions. Create a NEW condition and the dialog in Figure 7 will be displayed. Call the condition COMPRESSED and select the snapshot you have just saved.

Static Analyses

Now we are ready to start to analyse the model. The first type of analysis we will investigate is called a static analysis. This type of analysis will take into account all of the forces on the mechanism and find the equilibrium position. Let’s start with a simple situation – the bike is standing still with no rider seated just supporting its own weight. In this situation you would expect that if the suspension is designed correctly the damper would be stretched to its maximum limit. Let’s see how we can prove this.

Choose MECHANISM > ANALYSES and create a NEW analysis. Change the settings in the dialog to reflect those in Error! Reference source not found.. You will need to change the Name, Type, Initial Configuration and Tick Enable Gravity in the Ext Loads tab.

Figure 6 : Gravity

Figure 7 : Setting an Initial Condition

Figure 8 : Defining a Static Analysis
If you press RUN now you should see the model gradually changing the position as the program iterates the equilibrium position. The graph that appears also reflects the program ‘homing’ on the correct position – if the final point is plotted at a Y axis value of zero you know the model has found the equilibrium. If you look carefully at the damper you should see that it has stretched to its maximum length as you would expect. Press OK to finish this analysis.

**Loads**

Let’s use a similar analysis to find out how much the damper would compress when a rider sits on the seat. The rider weighs 12 stone/168lbs/76Kg so the force which will be applied to the seat will be 750N. This load can be created using MECHANISM > FORCE/TORQUE and creating a NEW force.

Just like the last analysis the model should home in on the equilibrium position but you would now expect the damper to be just a little compressed – zoom in to the damper to see this is the case.

**Dynamic Analyses**

A second type of analysis will also be useful in designing this bike. If the rider goes over a large jump a correctly designed suspension should compress but not reach its full travel or ‘bottom out’. Let’s test this using a dynamic analysis. The parameters for this test are that a force of 8 times the rider’s weight will be applied for 0.02 sec and then a constant load equal to the rider’s weight will be applied.
To prepare for this analysis create a second force called JUMP which is 8 times the RIDER load (6000N).

Now create a new analysis called JUMP. Change the type to DYNAMIC and the duration to 0.1 then switch to the EXT LOADS tab and add both the RIDER load and the JUMP load over the durations shown in Figure 11.

Run the analysis and you should see the damper compresses to near its full extent then bounces back before settling back to normal riding position.

**Measures**

Watching the action on the screen is not very accurate. You may need to know more precisely some value from the mechanism such as how the damper length varies over the duration of the dynamic analysis. This is known in Pro Engineer as a measure. Measure are available for lots of things such as velocity, acceleration, forces as well as distance.

To create a measure choose MECHANISM > MEASURES. In the dialog choose to create a new measure. Type a name of DAMPERLENGTH and a type of SEPERATION picking the SHOCKTOP_POINT and SHOCKBOTTOM_POINT. Click OK on the Measure Definition dialog. Now highlight the DAMPERLENGTH measure and the JUMP result set and the small graph icon at the top of the dialog should activate. Press this icon to see the results.

**Figure 12 : Creating a Measure**

You could experiment with the spring and damper definitions to see the effect on this analysis – don’t forget to RUN the analysis after you make each change.

**Review**

So what should you have learnt?

- How to define joint limits, springs, dampers and forces.
- How to create static and dynamic analyses.
- How to create measures.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
Warp Modeling

Warp features are a fairly new addition to Pro Engineer Wildfire that allows global modifications to be made to a solid model. It is like having the ability to turn your solid model into a lump of plasticine and then bend twist and stretch the whole model into shape. These techniques allow you to make some very complex shapes which you could not make by any other method within a solid modeller. The tools you have for the control of these shapes are fairly versatile (if a little tricky to use at first) but due to the global nature of the modifications the control may not be as precise as with other functions you are used to in Pro Engineer Wildfire. That said, as you can see from Figure 1 you can make some very unusual shapes.

Figure 1 : Completed Lamp

Creating the Bracket

Create a new part called Lamp_Bracket and choose mmns_part_solid as the initial template. In this part create the simple extruded hexagon shown in Figure 2. To help you draw the hexagon in the skether draw a 25 circle then right click on it and choose CONSTRUCTION. The circle will then be shown dotted as a construction line and you can draw the six lines making up the hexagon inside this circle. Make three of the lines equal in length to ensure it really is a hexagon. Extrude it to 300mm length.

Now its time to warp this simple shape into something more interesting. Choose INSERT > WARP and you will see the warp dashboard displayed at the bottom of the screen. This has several for the different warp functions and a series of menus which hide functions which are very useful.

Figure 2 : Initial Extrusion

The different warp functions are summarised in Figure 4. The functions all operate by allowing the operator to interactively change the geometry. This is done by dragging control points on the geometry around with the mouse.

Figure 3 : The Warp Dashboard

<table>
<thead>
<tr>
<th>Transform</th>
<th>WARP</th>
<th>Spine</th>
<th>Sculpt</th>
<th>Stretch</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate, scale or translate the model.</td>
<td>Uses edges and corners of a surrounding box to change the shape of the geometry.</td>
<td>Use a curve to adjust the overall shape of the model either linearly or radially.</td>
<td>Use a mesh of control points to adjust the overall shape of the model.</td>
<td>Stretches the geometry along an axis. You can control the range and scale of the stretch.</td>
</tr>
</tbody>
</table>

Figure 4 : Warp Functions
Your First Warp

We will introduce the warp functions by working on the hex bar we have just created to make it taper along its length. If you have just issued the INSERT > WARP command Pro Engineer should be waiting for you to select the solid to be warped so pick the extruded hex bar and click on OK in the select dialog on the right of the screen. You will immediately be asked to pick a reference for the warping so pick the coordinate systems PRT_CSYS_DEF. The warp tools should now be active in the dashboard - press on the second button . The bar should now be surrounded by a box (known as a marquee) with square ‘grab handles’ with which you can drag the model. Try dragging the model now to see what effect each of the drag handle has – when you click on a corner you will get additional drag arrows to play with

![Figure 5: Warp Drag Handles](image)

When you have played with the drag handles your model may well be distorted. We need to restore its shape – this is no problem because the warp function has its own history under the LIST menu. Click on this menu now and use the delete icon to delete all of your modifications except the first WARP : REFERENCE function. The dialog should look like Figure 6.

![Figure 6: Warp History](image)

So how do you use this to add a taper? The drop down list box on the warp dashboard will probably be set to OPPOSITE – change this to CENTRE. Now drag the arrow handle highlighted in Figure 7 to create a tapered bar.

![Figure 7: Warp taper](image)

As you drag a handle you get visual feedback of the changing shape. There is also a numeric value that you can change which appears in the OPTIONS menu. The higher this number the greater the effect of the warp command and the more the shape tapers – change this value to 6. If you tick the adjacent box the value can be changed later using the EDIT command like any other dimension. Press the green tick to finish the warp feature creation.

The Twist Warp

You should now have a tapered hexagonal bar. Let’s twist it around its length. Choose INSERT > WARP again and pick the extruded hex bar and click on OK in the select dialog on the right of the screen. You will immediately be asked to pick a reference for the warping so pick the coordinate systems PRT_CSYS_DEF. The warp tools should now be active in the dashboard - press on the sixth button . A numeric input window should appear in the dashboard into which you can type a twist value in degrees. Type a value of 360 and tick the adjacent box to export the value as an editable value. After entering this value the shape on the screen will be unrecognisable! This is because it is twisting around the wrong axis. Press the to cycle through the 3 axis until the shape is correct. The icon changes the direction of the twist.
Figure 8: Different Twist Axes

Press the green tick to finish the warp feature creation.

The Bend Warp

To finish the bracket we will add a bend. Choose INSERT > WARP again and pick the twisted hex bar and click on OK in the select dialog on the right of the screen. You will immediately be asked to pick a reference for the warping so pick the coordinate systems PRT_CSYS_DEF. The warp tools should now be active in the dashboard - press on the fifth button. A numeric input window should appear in the dashboard into which you can type a bend value in degrees. Type a value of 90 and tick the adjacent box to export the value as an editable value. After entering this value the shape on the screen will be as expected! This is because it is bending around the wrong axis. Press the to cycle through the 3 axes until the shape is correct. The icon changes the direction of the bend and the icon rotates the shape by 90 degrees around the bend axis.

Figure 9: Different Twist Axes

Press the green tick to finish the warp feature creation.

Figure 10: Complete Bracket

To complete this part go back (move the insert here icon) and add an extruded hole for the electric wires to go through (Extrude 3) and a lug to aid assembly.

Creating the Shade

Warps can be applied to models which can contain more than a single feature. Making a lamp shade by the technique will show this.

Create a new part called Lamp_Shade and choose mmns_part_solid as the initial template. In this part create the simple extruded circle of 200mm diameter shown in Figure 11. Extrude it to 250mm length.

Figure 11: Lampshade Feature 1

Next create a circular extrusion through the edge of the whole bar removing material.
Warp Modeling

Figure 12: Lampshade Feature 2
Make a pattern of 6 of the original extruded cuts at 60 degree intervals around the central axis (use the AXIS option).

Figure 13: Lampshade Pattern Feature
This is the basis of the lamp shade.

Combined Warp
The more interesting shape of the lamp will be created by a Spine, Warp and Twist Warps. These can be done as independent warps like we did with the bracket or they can all be combined into a single warp feature. This is what we will do here.

The Spine Warp
The spine warp lets us squash and stretch our ‘lump of plasticine’ into a new shape. Choose INSERT > WARP again and pick the lamp and click on OK in the select dialog on the right of the screen. You will immediately be asked to pick a reference for the warping so pick the coordinate systems PRT_CSYS_DEF. The warp tools should now be active in the dashboard - press the third button. This is the spine tool which controls the shape by modifying an edge curve. Pick any one of the edges of the rounds as the control curve and click on OK in the select dialog on the right of the screen.

Figure 14: Spine Warp
You can adjust the shape of this curve by dragging the control points (dots) and the arrows which control the start direction (Figure 14a). Try this now but don’t be too ambitious in what you attempt! The results probably won’t be what you expected (Figure 14b). This is because you are using the wrong TYPE of control. There are three types of control. Click on the last of the three buttons and pick the controlling curve again and edit it so that this time the effect of the curve is felt all around the shape (Figure 14c).

Remember we are combining several warps so DON’T press the green tick yet. Next we will taper the lampshade so click on second button and drag one of the corners at the top of the lampshade and drag to a suitable taper (don’t forget to set the CENTRE option - refer back to Your First Warp as a reminder).

Figure 15: Warp
We haven’t finished so DON’T press the green tick yet. Next we will twist the lampshade so click on sixth button and type a twist angle of 60 degrees. Press the icon twice to cycle through the 3 axis until the shape is correct (refer back to The Twist Warp as a reminder).

![Figure 16: Twist Warp](image)

Take a look at the LIST menu and you should see the warp history of the commands you have just completed. You can use the buttons at the bottom to step backwards and forwards reviewing the procedure.

![Figure 17: Warp History](image)

Press the green tick to finish the warp feature creation. All these warps appear as a single feature in the feature tree.

Finish the lampshade design off by adding rounds, a shell, a full round and an extruded cut.

![Figure 18: Complete the Lampshade](image)

The other parts of the lamp are made from standard extrude and revolve features. You may like to design these and create an assembly of all the parts to complete the exercise.

**Review**

So what should you have learnt?

- How to create individual warps
- How to combine warps into a single feature.
- Understand the limitations of using warp features

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.

The Transform, Stretch and Sculpt Warps have not been discussed here. Experiment with these on your own models.
Underlay

It is a common technique to use a photograph as an underlay or guide when sketching in a CAD model. Though not an explicit function of ProEngineer this can be achieved with a little work as follows.

Before you start you will need one or more orthographic digital pictures of a product (photographs of a real object or scanned sketches of your own design).

Create a new part using the mmns_part_solid template. Insert a new sketch (INSERT > MODEL DATUM > SKETCH ) and draw a simple rectangle on the FRONT datum. Adjust the size of this rectangle to be the overall size of part to be modelled.

The next step is to fill this rectangle with a surface. Make sure the sketch is selected in the model tree then choose EDIT > FILL. A surface will be created to fill in the rectangle – it will be more visible if you shade the model.

Now we need to associate a picture with this surface. Choose View > Color and Appearance to show the materials palette. In this dialog choose MATERIAL > NEW and change the name of the material to FrontPicture. Click on the MAP tab and click on the square button next to DECAL. At the top of the dialog choose TEXTURE > ADD and using the dialog that appears to locate the texture. This can be any of the common picture file formats (bmp, jpg etc) but you are strongly advised to copy the picture file to the same directory as the model before you apply it. After loading the picture click on its name to apply it to the surface and CLOSE the Appearance Placement dialog. In the Advanced tab of the Appearance dialog you may wish to adjust the Transparency to say 80% so the texture is see through. Finally below Assignment choose Surfaces and pick the fill surface choose OK and BOTH. You can now use this picture as an underlay when drawing. You can visually sketch on it but you cannot lock the points onto the picture.
You may want to repeat this procedure for the other datum planes adding pictures of the model from other directions.

**Method 1 – Multiple 2D tubes**

The first method recognises that many 3D tubes can be made up of several planar tubes connected at their ends. Think of a traditional racing bicycle handle bars. These can be made up of two planar curves as shown in Figure 4. This shows two curves being drawn on separate datum planes. The ends of these curves meet and they are tangent. The tube was made using the Variable Section sweep tool and the References > Details button was used to add both curves to the Origin chain.

**Method 2 – Tubes Thru Points**

If the shape you want is a genuine 3D shape, use this procedure...

First create a series of datum points to control the shape. Use INSERT > MODEL DATUM > POINT > OFFSET COORDINATE SYSTEM and pick on a coordinate system as a reference. Now enter the coordinates shown in Figure 5.

You can now use these points to create a datum curve using INSERT > MODEL DATUM > CURVE (not SKETCH). Choose THRU POINTS | DONE then pick one of the points (since they are a group they will all be selected). Choose DONE and OK in the Dialog box to create the curve.
Figure 6 shows the difference between the curve type options. Now use the Variable Section sweep tool to create a tube from this curve.

Figure 6: Curve Types (Spline, Single Rad, Multiple Rad)

Springs

There is a special function for creating springs in ProEngineer. Choose INSERT > HELICHAL SWEEP > PROTRUSION. From the side menu choose the parameters you want for the spring CONSTANT | THRU AXIS | RIGHT HANDED | DONE. Next choose a sketching plane such as the FRONT datum then OK and DEFAULT. You should now be in sketcher. Draw a line representing the outside shape of the spring. In the case of the 80 dimension represents the length of the spring and the 20 is half the diameter of the spring. You will also need to draw a centre line for the spring. After leaving sketcher you will be asked for the pitch of the spring – type in 20. You will now be back in sketcher this time to draw the cross-section of the wire from which the spring is made – draw a 5 circle on the end of the line. Exit sketcher and choose DONE to see the spring.

Figure 7: Springs

If you change the length of the spring now by editing the 80 dimension to say 100 you will see that an extra coil is added. The spring hasn’t stretched as you might expect. To make the spring act more realistically you can build in some relationships. Choose TOOLS > RELATIONS to see the dialog in Figure 8. Click on the spring in the main window and choose to show ALL dimensions. The dimension names – not their values will be shown. Notice that the pitch of the spring is d2 and the length is d0 (if yours are different use your values. Enter the formula shown in into the dialog. Click OK and now when you change the length of the spring the coils should stretch just like the real thing. Can you work out what this formula is doing? (Hint there are 4 coils in this spring)

Figure 8: Spring Relationships
This tutorial introduces the concept of machining of turned parts using a 
CNC lathe. A sample model of a turned part is provided for you to work 
with in this tutorial. There is a link to it next to this tutorial at 
http://www.staffs.ac.uk/~entdgc/WildfireDocs/tutorials.htm and it is called 
turnedpart.prt. This part should be downloaded to your working directory 
before starting the tutorial.

Machining Setup

To start the tutorial, create a new file for the machining data using FILE > 
NEW. Select MANUFACTURING and NC ASSEMBLY as shown in Figure 
1 and type in a name such as turnedpart. In the New File Options dialog 
that follows choose EMPTY.

The blank file created is ready to store all of the manufacturing 
information. The first data to be inserted into the file is the actual model to 
be machined. This is specified by the command from the right side menu 
MFG MODEL ⇒ ASSEMBLE ⇒ REF MODEL and choosing turnedpart.prt 
in the file list box. After the model to be machined appears in the window 
choose DONE/RETURN.

As an aid to visualising the machining process it is beneficial (though not 
essential) that the stock material from which this part will be machined is 
defined. To do this choose MFG MODEL ⇒ CREATE ⇒ WORKPIECE 
and type in the name turnedpart_work. Now choose PROTRUSION ⇒ 
EXTRUDE | SOLID | DONE to enter the extrude dashboard. If you have 
completed the modelling tutorials you will be familiar with this function. 
Enter the sketcher by choosing PLACEMENT and DEFINE from the 
dashboard. Choose the RIGHT datum as the sketching plane then the 
TOP datum as the reference plane. In the sketcher choose the FRONT 
and TOP datums as references. Draw a 50mm diameter circle to represent 
the bar from which this part is turned.
Exit sketcher and type a length of 75mm for the extrusion. A cylindrical block of material the same size as the original bar from which the part is to be turned will be shown. After pressing ✔ to exit the dashboard the material should be shown in transparent green.

**Figure 4 : Reference Model and Workpiece**

When machining it is essential that you define the origin (0,0,0) for machining. It is normal when turning to use centre of the end of the bar as zero. This is done in Pro Engineer with a coordinate system. It would be useful to create one now. Choose INSERT > MODEL DATUM > COORDINATE SYSTEM. The coordinate system dialog is displayed. This is an ‘intelligent’ dialog – it will try and make sense of what you select. Click on the FRONT, TOP and ENDFACE datum planes with the CTRL key held down and the new coordinate system will be created at the intersection point of these 3 planes. Use the controls in the ORIENTATION tab in the dialog to ensure the Z axis of this coordinate system is pointing along the axis of the bar. If you picked the datums in the order suggested you will just need to press the top FLIP button to make the Z direction out of the workpiece.

**Figure 5 : Defining the Coordinate System**

It is ESSENTIAL that the Z axis is correctly oriented if the turning operation is to be correct. The Z axis defines the rotation of the work in the lathe chuck. If the Z axis is incorrectly oriented then Pro Engineer will try and machine from the wrong direction. Click OK to close the dialog and ACS0 should appear in the model tree.

It is also useful to define the location of the position that the tool will return to before/after each cut is taken. To specify this point we will define a datum point with INSERT > MODEL DATUM > POINT > OFFSET CORDINATE SYSTEM... As a reference point, choose the coordinate system ACS0. Type a name of HOME and add a value of 30 in the X column and 5 in the Z. Click OK to close the dialog and create this point.

**Defining the Machining Operation**

An operation is the term Pro Engineer uses to define the type of machine that will be used for a sequence of cuts. Choose the command MACHINING from the side menu and the dialog shown in Figure 6 appears in which you define the Operation. Type in an Operation Name of Turning. Press ✔ to go to the machine Tool Dialog and type in a machine name of CNCLathe, choose a Machine Type of Lathe then press OK to return to Operation Setup. Next click on next to Machine Zero and pick on the coordinate system ACS0. Close the dialog with OK.
Defining the First Cut

We can now start the machining process. It would be good at this stage to plan the sequence of events for machining. For this shape we will first remove the mass of material around the finished part with a large tool, leaving some material to be removed by a second finer cut. Later we will machine the grooves and other features.

Now we start to define the first cut into the material. Choose MACHINING ⇒ NC SEQUENCE ⇒ MACHINING | AREA | DONE. A series of parameters is offered. Ensure that Name, Tool, Parameters, Start and End are checked and then choose DONE. Type the name as RoughCut. Enter the tool values as shown in Figure 7a and APPLY OK.

![Figure 7: Roughing Tool and Manufacturing Parameters](Image)

From the MFG Params menu choose SET and enter the values as shown in Figure 7b then File > Exit and DONE. Now define the position of the tool at the start by picking the HOME datum point created earlier then pick the same HOME datum point a second time to define the position of the tool at the end of the machining sequence.

Next you will see the CUSTOMIZE dialog. This dialog allows you to define the geometry that will be machined. Press INSERT to define a new cut then choose CREATE PROFILE. There are lots of ways of creating the profile which is going to be machined. We will start of by using the SECTION | DONE option.

![Figure 8: The Customize Dialog](Image)

After choosing this option a line around the part will be drawn through the cutting plane. A cross is shown on each corner of this line. Choose the two crosses shown in Figure 9a to limit the extent of this cut. Next choose ABOVE CTRLN > DONE and if necessary TOGGLE PROFILE to get the curve shown in blue in Figure 9a before pressing DONE/RETURN.

![Figure 9: Defining a Profile by Section](Image)

This has defined the profile which the tool will follow but the shape includes the grooves around the part and the hole in the end. These should not be included so they need to be removed. In the CURVE: TURN PROFILE dialog double-click on ADJUST TURN PROFILE to show the ADJUST PROFILE dialog. In this dialog click ADD to create a new adjustment then pick the points in Figure 10. Press PREVIEW to see that...
the machine profile now misses out the groove – the two points you chose are joined by a straight line. Add a similar adjustment to the other groove. Click OK in the ADJUST PROFILE dialog and OK in the CURVE: TURN PROFILE dialog. ProEngineer next offers the opportunity to extend the profile at each end to ensure a clean cut – choose the options NEGATIVE Z | DONE for the first end and POSITIVE Z | DONE for the second end as shown in Figure 9b. Then choose DONE CUT and the toolpath will be previewed. Choose OK in the CUSTOMIZE dialog to finish the definition of this cut.

Figure 10 : Profile Adjustment

This has defined all of the parameters needed to perform the cut. To see the result of this machining exercise choose PLAY PATH ⇒ SCREEN PLAY. The actual tool paths will then be calculated and displayed in red followed by a tool path simulation that can be run by pressing the button. After this completes choose DONE SEQ. IF YOU DON'T DO THIS YOU WILL LOOSE THE DEFINITION OF THIS TOOLPATH!

Figure 11 : The Rough Machine Toolpaths

Defining the Second Cut

Have you pressed DONE SEQ. IF YOU DON'T DO THIS YOU WILL LOOSE THE DEFINITION OF THIS TOOLPATH!

Having completed the roughing toolpath we can now define a second toolpath for the finishing cut. Choose NC SEQUENCE ⇒ NEW SEQUENCE ⇒ MACHINING | PROFILE | DONE. Again a series of parameters is offered. Ensure that Name, Parameters, Start and End are checked then choose DONE. (Note : We haven’t chosen the Tool option this time so the same tool as the previous cut will be used which is fine in this case)

Type the Name as FinishCut. At the MFG Params menu choose SET and enter the values as shown in Figure 12 and FILE > EXIT and DONE.

Figure 12 : Finish Manufacturing Parameters

SELECT the HOME datum point for the start and then SELECT the HOME datum point a second time for the end of the cut. At the CUSTOMIZE dialog choose INSERT. There is no need to create a new profile – we can use the same profile that we used for the previous cut so just choose SELECT PROFILE and pick TURN_PROF_000 in the model tree (see Figure 12b). Choose DONE CUT and OK in the CUSTOMIZE dialog.

To see the result of this machining exercise choose PLAY PATH ⇒ SCREEN PLAY like before. You may spot that the toolpath is actually wrong! To see this more clearly choose PLAY PATH ⇒ NC CHECK. This
uses software called Vericut to simulate the machining process. A graphical representation of the part should appear on the screen after a few moments. You can use the buttons in the bottom right of the screen to play the toolpath. Use the solid green arrow to play the path now.

**Figure 13 : Cut Verification for Finish Cut**

The yellow material shows the starting shape. The grey material is correctly machined. The red colour shows the error. In its rush to get to the home position the tool went straight through the part trying to cut at very high speed. How can we stop this happening?

Close Vericut with FILE > EXIT. In the NC SEQUENCE menu choose SEQ SETUP and tick PARAMETERS to redefine some of the settings for this toolpath. Choose DONE then tick NC SEQUENCE | DONE SEL > SET. The PARAM TREE dialog shown in Figure 12 should be shown. Only the simple parameters are shown – there are many more parameters which are hidden until you press the ADVANCED button. Press this and scroll to the bottom of the list where you will see a parameter called START MOTION. Change this to Z FIRST (select then use the INPUT list box at the top of the dialog). You will see a second parameter called END MOTION. Change this to Z LAST. This will ensure the movement at the start and end of the toolpath will move in two stages Z then X or X then Z. Choose FILE > EXIT then PLAY PATH in Vericut to see the changes. The red band should have gone leaving the correct shape in grey.

After this completes choose DONE SEQ. IF YOU DON'T DO THIS YOU WILL LOOSE THE DEFINITION OF THIS TOOLPATH!

---

**Defining the Groove Cuts**

Have you pressed DONE SEQ. IF YOU DON'T DO THIS YOU WILL LOOSE THE DEFINITION OF THIS TOOLPATH!

Having completed the roughing toolpath we can now define a second toolpath for the finishing cut. Choose NC SEQUENCE ⇒ NEW SEQUENCE ⇒ MACHINING | GROOVE | DONE. Again a series of parameters is offered. Ensure that Name, Tool, Parameters, Start and End are checked then choose DONE.

Type the Name as GrooveCut1 and in the Tool Setup dialog define a new tool as shown in Figure 14 finishing with APPLY and OK.

**Figure 14 : Grooving Tool and Parameters Definition**

At the MFG Params menu choose SET and enter the values as shown in Figure 12. Also change the START MOTION and END MOTION (under ADVANCED) to the values used before then FILE > EXIT and DONE.

SELECT the HOME datum point for the start an end of the cut. At the CUSTOMIZE dialog choose INSERT. We will use another method of defining the profile for the groove so choose CREATE PROFILE ⇒ SELECT SURFACE | DONE. Using this option you have to define the surfaces forming the first and last segment of the cut profile. Choose the surfaces shown in Figure 14b.
Figure 15: Start and End Surfaces

Next choose ABOVE CTRLN | DONE and OK in the Turn Profile dialog. There is no need to modify this profile but the profile needs to be extended at both ends with POSITIVE X | DONE. Finish with DONE CUT and OK in the CUSTOMIZE dialog. PLAY PATH either to the screen or in Vericut (which will only show this groove path) before finishing with DONE SEQ.

Have you pressed DONE SEQ. IF YOU DON’T DO THIS YOU WILL LOOSE THE DEFINITION OF THIS TOOLPATH!

Repeat the process creating a new sequence for the second groove. The step on the end of the part should also be machined as a groove. You can also use grooves to define parting off operations.

NOTE: You have been shown two ways of creating the geometry to be machined – SECTION and SELECT PROFILE. The most flexible method is SKETCH which allows you to draw the profile in sketcher. This method is not covered here but it is intuitive if you are familiar with sketcher.

Having completed all of the machining steps you may want to check the whole machining process by viewing in Vericut. To join all the steps together you need to create an intermediate file containing all of the toolpaths. CL DATA > OUTPUT > SELECT ONE > OPERATION then pick the operation name TURNING > FILE > DONE and accept the name turning.ncl for the filename. This has created a .ncl file in your working directory. Choose DONE OUTPUT > NC CHECK > CL FILE and select the file you just created. Choosing a final DONE will take you to Vericut where you can view the whole machining process seeing the results in Figure 17.

Figure 16: First Groove

Axial Drilling

All lathes have the option of using a drill as a tool to cut holes axially along the centreline of the work. Some lathes (like the Beaver Turning Centre at Staffordshire University) can have ‘live’ tooling – drills which are powered by the tool post and so can cut holes off the axis of rotation. This section describes how to program such movements.

The model you have been working on has holes designed in it. These are currently suppressed so they are invisible. To resume them so you can see them follow the following steps illustrated in Figure 18…

Expand the model tree under TURNEDPART.PRT
1. Click on SETTINGS at the top of the model tree
2. Choose TREE FILTERS to display the dialog.
3. Tick Suppressed Objects and OK
4. Two patterns of holes will be shown in the model tree. The black dot next to the name shows they are suppressed.
5. Right click on each pattern and choose RESUME.
Two sets of holes should now be visible. The four holes in the end of the part are the axial holes which will be drilled first. These holes are relatively easy to generate toolpaths for as the procedure is very similar to the other sequences we have already created. From the MANUFACTURE menu choose MACHINING ⇒ NC SEQUENCE ⇒ NEW SEQUENCE ⇒ MACHINING | HOLEMAKING | DONE ⇒ DRILL | STANDARD | DONE. Again a series of parameters is offered. Ensure that Name, Tool, Parameters, Retract, Holes, Start and End are checked then choose DONE. Type the Name as AxialDrill and in the Tool Setup dialog define a new MILLING tool as shown in Figure 14 then APPLY and OK.

At the MFG Params menu choose SET and enter the values as shown in Figure 12. Also change the START MOTION and END MOTION (under ADVANCED) to the values used before then FILE > EXIT and DONE.

SELECT the HOME datum point for the start and end of the cut. PLAY PATH to the screen to see the toolpath. If you try and play this path in Vericut it will not simulate correctly as the holes are off the centre of rotation. Choose DONE SEQ to finish.
Radial Drilling

Have you pressed DONE SEQ. IF YOU DON'T DO THIS YOU WILL LOOSE THE DEFINITION OF THIS TOOLPATH!

To drill the final set of radial holes requires a machine type where the tool moves along the X axis rather than the Z on a normal lathe. This type of machine is known as a mill/turn as it combines the functions of both a milling machine and a lathe. Since Pro/Engineer does not allow you to change an existing machine type once you have created sequences for it we need to create a complete new machine. Do this with MACHINING ⇒ OPERATION (from the MANUFACTURE menu) and you will see the Operation dialog from Figure 23. Choose FILE ⇒ New in this dialog to create a new operation. Type in an Operation Name of MillTurn. Press to go to the machine Tool Dialog and choose FILE ⇒ New in this dialog. Type in a machine name of CNCMiller, choose a Machine Type of Mill/Turn, 3 Axis and tick Head 1 for Milling Capability then press OK to return to Operation Setup. Next click on next to Machine Zero and pick on the coordinate system ACS0. Close the dialog with OK.

Post Processing

Post Processing is the act of converting the toolpaths from a standard language called a cutter location file (.ncl) to the language of your specific CNC machines controller. The resultant file in Pro/Engineer is known as a tape file (.tap) which contains all the ‘G’ codes to control the CNC machine. The post processor is a program that performs the translation process. Even though Pro/Engineer comes with some general post processors you must have the correct post processor for your specific machine controller otherwise breakages may occur.

You were instructed how to create a CL file in the previous section. This same file can be used to produce the CNC instructions via post processing. To use this file choose CL DATA ⇒ POST PROCESS and then select the filename turning.ncl followed by DONE. Pro/Engineer should
now generate a list of the post processors available on your system. These have names from UNCX01.1 to UNCX01.99 (milling) and UNCL01.1 to UNCL01.99 (lathe). As you move the cursor over these names a description of the post processor will be shown at the bottom of the main window. To use the Beavor Turning Centre at Staffordshire University choose UNCL01.99 as the post processor. On completion an information window will be displayed and the file turning.tap will have been created in your working directory. This file should be uploaded to the CNC machine and checked by the operator before running.

Review

So what should you have learnt?

- How to create a coordinate system.
- How to define stock material.
- How to define an operation.
- How to define a cut area, profile groove and holemaking.
- How to post process a file.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.

APPENDIX

File Structure

The machining operation in Pro/Engineer brings together data from several places. This requires several files to be associated to the manufacturing process. It is important to understand the structure of these files because if one of these required files is deleted by mistake the whole manufacturing process may be lost. Figure 25 shows this file structure.

![Diagram of file structure](image)

**Figure 25 : Manufacturing File Structure**

The first part of the filenames will vary with your naming convention. The grey boxes or ticked rows in the table must be kept to avoid loss of data. The white files or crossed rows are not essential and can be deleted as they will be recreated if required.
Important Manufacturing Parameters

ProEngineer provides an enormous amount of parameters to control each machining sequence. These are set for any sequence through SEQ SETUP ⇒ PARAMETERS | DONE ⇒ SET | DONE. A table of parameters will be displayed (See Figure 7, Figure 12 and Error! Reference source not found.). The ADVANCED button at the top of the table will show all of the manufacturing parameters. There follows and explanation of the most important ones…

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Explanation</th>
<th>Typical Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>OUTPUT_POINT</td>
<td>The position on the tool which is programmed. Should match the tooling offset on the machine you are using.</td>
<td>CENTER – the centre of any radius on the tool tip is output.</td>
</tr>
<tr>
<td>GOUGE_AVOID_TYPE</td>
<td>Checks whether the tool will incorrectly cut into the part.</td>
<td>TIP &amp;_SIDES</td>
</tr>
<tr>
<td>STOCK.Allow</td>
<td>Amount of material to be left on the part for a finishing cut.</td>
<td>Operator choice</td>
</tr>
<tr>
<td>CUT_FEED</td>
<td>The feed rate of the tool along the work. See CUT_UNITS.</td>
<td>Use Figure 28</td>
</tr>
<tr>
<td>CUT_UNITS</td>
<td>The units for CUT_FEED either mm/rev or mm/min.</td>
<td>MMPR</td>
</tr>
<tr>
<td>SPINDLE_SPEED</td>
<td>The rotational speed of the work. See SPEED_CONTROL.</td>
<td>Use Figure 27.</td>
</tr>
<tr>
<td>SPEED_CONTROL</td>
<td>The units for SPINDLE_SPEED either rev/min or constant surface speed.</td>
<td>CONST_SMM</td>
</tr>
<tr>
<td>START_MOTION</td>
<td>How the tool approaches the work. Normally the tool should be plunged into the work along X.</td>
<td>Z_FIRST</td>
</tr>
<tr>
<td>END_MOTION</td>
<td>How the tool leaves the work. Normally the tool should leave along X before being position along the work axis Z.</td>
<td>Z_LAST</td>
</tr>
</tbody>
</table>

Figure 26 : Important Sequence Parameters

Calculating Speeds And Feeds For Turning

Most tooling manufacturers catalogues will give formulas or tables for calculating the most efficient speed of rotation (rev/minute) of the work (known as SPINDLE_SPEED in ProEngineer) and feed rate (m/sec) of the tool along the work (known as CUT_FEED in ProEngineer). The manufacturers values should be used if available but if you do not have access to this information this simple method of calculating speeds and feeds can be used.

To calculate the lathe spindle speed (N rpm)

$$N = \frac{1000S}{\pi D}$$

where:

- \(D\) = Diameter of workpiece (mm). Diameter of the finished piece is usually used although blank diameter or mean diameter can also be used.
- \(S\) = Recommended surface cutting speed (m/min) from the following table…

<table>
<thead>
<tr>
<th>Material</th>
<th>Surface Cutting Speed (m/min)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Rough Cuts</td>
</tr>
<tr>
<td>Machine Steel</td>
<td>27</td>
</tr>
<tr>
<td>Tool Steel</td>
<td>21</td>
</tr>
<tr>
<td>Cast Iron</td>
<td>18</td>
</tr>
<tr>
<td>Bronze</td>
<td>27</td>
</tr>
<tr>
<td>Aluminium</td>
<td>61</td>
</tr>
</tbody>
</table>

Figure 27 : Surface Cutting Speed

Alternatively, you can enter the surface cutting speed directly into Pro/Engineer. In the advanced parameters of the Param Tree dialog change the Speed Control from CONST_RPM to CONST_SMM (constant surface speed in m/min). The values from the table above can now be entered as the spindle speed.
A typical federate can be found from the following table.

<table>
<thead>
<tr>
<th>Material</th>
<th>Feed Rate mm/rev</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Rough Cuts</td>
<td>Finish Cuts</td>
<td></td>
</tr>
<tr>
<td>Machine Steel</td>
<td>0.25-0.50</td>
<td>0.075-0.25</td>
<td></td>
</tr>
<tr>
<td>Tool Steel</td>
<td>0.25-0.50</td>
<td>0.075-0.25</td>
<td></td>
</tr>
<tr>
<td>Cast Iron</td>
<td>0.40-0.65</td>
<td>0.13-0.30</td>
<td></td>
</tr>
<tr>
<td>Bronze</td>
<td>0.40-0.65</td>
<td>0.075-0.25</td>
<td></td>
</tr>
<tr>
<td>Aluminium</td>
<td>0.40-0.75</td>
<td>0.13-0.25</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 28: Feed Rate**

Pro/Engineer normally expects feed to be entered in mm/min although this can be changed in the advanced parameters of the Param Tree dialog (set CUT_UNITS to MMPR). To convert the values above to mm/min multiply by spindle speed.

### Tooling Available At Staffordshire University

<table>
<thead>
<tr>
<th>No</th>
<th>Type</th>
<th>Parameters</th>
<th>Diagram</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Axial Mill/Drill</td>
<td>Cutter Dia = 5&lt;br&gt;Length = 10&lt;br&gt;Corner Rad = -&lt;br&gt;No Teeth = 2</td>
<td><img src="image1.png" alt="" /></td>
</tr>
<tr>
<td>2</td>
<td>Not Defined</td>
<td></td>
<td><img src="image2.png" alt="" /></td>
</tr>
<tr>
<td>3</td>
<td>Turn / Groove</td>
<td>Width = 11&lt;br&gt;Length = 23&lt;br&gt;Nose Rad = 5.4</td>
<td><img src="image3.png" alt="" /></td>
</tr>
<tr>
<td>4</td>
<td>Not Defined</td>
<td></td>
<td><img src="image4.png" alt="" /></td>
</tr>
<tr>
<td>5</td>
<td>Radial Mill/Drill</td>
<td>Cutter Dia = 5&lt;br&gt;Length = 12&lt;br&gt;Corner Rad = 2.5</td>
<td><img src="image5.png" alt="" /></td>
</tr>
<tr>
<td>6</td>
<td>Turning</td>
<td>Length = 125&lt;br&gt;Tool Width = 29.5&lt;br&gt;Nose Rad = 0.4</td>
<td><img src="image6.png" alt="" /></td>
</tr>
<tr>
<td>7</td>
<td>Turn / Groove</td>
<td>Width = 3&lt;br&gt;Length = 20&lt;br&gt;Nose Rad = 0.4</td>
<td><img src="image7.png" alt="" /></td>
</tr>
<tr>
<td>8</td>
<td>Not Defined</td>
<td></td>
<td><img src="image8.png" alt="" /></td>
</tr>
<tr>
<td>9</td>
<td>Turning</td>
<td>Length = 125&lt;br&gt;Tool Width = 29.5&lt;br&gt;Nose Rad = 0.4</td>
<td><img src="image9.png" alt="" /></td>
</tr>
</tbody>
</table>
This tutorial introduces the concept of machining of freeform surfaces using a 3 Axis CNC miller. A sample model of a mould half is provided for you to work with in this tutorial. It can be found at [http://www.staffs.ac.uk/~entdgc/WildfireDocs/tutorials.htm](http://www.staffs.ac.uk/~entdgc/WildfireDocs/tutorials.htm) and is called mould.prt. This part should be downloaded to your working directory before starting the tutorial.

**Machining Setup**

To start the tutorial, create a new file for the machining data using FILE > NEW. Select MANUFACTURING and NC ASSEMBLY as shown in Figure 1 and type in a name such as mould.

The blank file created is ready to store all of the manufacturing information. The first data to be inserted into the file is the actual model to be machined. This is specified by the command MFG MODEL ASSEMBLE REF MODEL and choosing mould.prt in the file list box. Choose DONE/RETURN and the model to be machined should appear in the window. This is an (incomplete) half of a mould for an injection-moulded part. The cavity for the part is to be machined from a rectangular block of material. We can assume the outside surfaces of the block are already finished to the correct dimensions.

To enable visualisation of the machining process it is beneficial (though not essential) that the stock material from which this part will be machined is defined. To do this choose MFG MODEL CREATE WORKPIECE and type in the name mould_work. Now choose PROTRUSION EXTRUDE | SOLID | DONE and create a rectangular block of material the same size as the mould. (Hint: Pick the top surface of the mould as the sketch plane. In skether pick and pick the top surface again and ACCEPT to make a rectangle the same size as the mould. For extrude depth choose up to surface and pick the bottom surface of the mould). You should be able to work out how to do this from previous experience of model creation. When you have done this the material should be shown in transparent green.
When machining it is essential that you know where to consider the origin (0,0,0) for machining to be. It is common to define one corner of the top surface of the material as zero. This is done in Pro Engineer with a coordinate system. It would be useful to create one now. Choose INSERT > MODEL DATUM > COORDINATE SYSTEM. The coordinate system dialog is displayed. This is an ‘intelligent’ dialog – it will try and make sense of what you select. Click on the 3 sides of the block now in the order shown in Figure 4.

![Figure 4: Defining the Coordinate System](image)

The yellow icon shows the location of the coordinate system. Notice that the Z axis is pointing up. This is MOST important as the milling tool will approach the material down the Z axis. If the Z axis is oriented wrong then Pro Engineer will try and machine from the wrong direction. Click OK to close the dialog and ACS0 should appear in the model tree.

**DEFINING THE MACHINING OPERATION**

We can now start the machining process. It would be good at this stage to plan the sequence of events for machining. Since the outside surface are already finished we do not need to machine these at all. Starting with the rectangular block we will first remove the mass of material in the cavity with a large tool, leaving some material to be removed by a second finer cut with a smaller tool.

An operation is the term Pro Engineer uses to define the type of machine that will be used for a sequence of cuts. Since all our machining is taking place on a single milling machine we only need a single operation.

Choose the command MACHINING from the side menu and a dialog appears in which you define the Operation. A series of options are provided. Type in an Operation Name of Milling. Press to go to the machine Tool Dialog and type in a machine name of Miller, a Machine_Type of Mill, and Number of Axes of 3 then press OK to return to Operation Setup. Next click on next to Machine Zero, choose SELECT and pick on ACS0. Finally click on next to Retract Surface and choose ALONG Z AXIS and type a depth of 5. Close the dialog with OK.

![Figure 5: Operation and Machine Tool Setup Dialogs](image)

**DEFINING THE FIRST CUT**

Now we start to define the first cut into the material. Choose MACHINING ⇒ NC SEQUENCE ⇒ MACHINING | SURFACE MILL | DONE. A series of parameters is offered. Ensure that Name, Tool, Parameters and Window (don’t miss this one) are checked and then choose DONE. Type the name as RoughCut. Enter the tool values as shown in Figure 6 and APPLY OK.
Milling

From the MFG Params menu choose SET and enter the values as shown in Figure 7 then File > Exit DONE.

If your options are different to these you chose the wrong type of toolpath. Quit this sequence and create a new one ensuring you choose the SURFACE MILL option.

On the Define Wind menu Choose Create Wind and type in a name of cavity. Now Choose SELECT ⇒ TANGNT CHAIN and pick on the top edge of the cavity DONE and OK. A curve will be shown projected onto the retraction plane which you defined earlier being 5 from the top surface. This curve is a boundary within which the tool will be constrained. It will machine all of the surfaces it can inside this boundary.

This has defined all of the parameters needed to perform the cut. To see the result of this machining exercise choose PLAY PATH ⇒ SCREEN PLAY. The actual tool paths will then be calculated and displayed in red followed by a tool path simulation that can be run by pressing the button. After this completes choose DONE SEQ. If you don’t do this you are likely to loose the definition of this toolpath!
Having completed the roughing toolpath we can now define a second toolpath for the finishing cut. Choose NC SEQUENCE ⇒ NEW SEQUENCE ⇒ MACHINING | SURFACE MILL | DONE. Again a series of parameters is offered. Ensure that Name, Comments, Tool, Parameters and Window are checked but NOT Define Cut and then choose DONE.

Type the Name as FinishCut. Enter the values as shown in Figure 10 and also on the settings tab choose tool number 2 APPLY then OK.

![Figure 10: Finish Tool Parameters](image)

At the MFG Params menu choose SET and enter the values as shown in Figure 11 and FILE > EXIT and DONE.

![Figure 11: Finish Manufacturing Parameters](image)

There is no need to define a new window so just choose SELECT WIND, Close the search dialog then pick on the pink profile already created.

To see the result of this machining exercise choose PLAY PATH ⇒ SCREEN PLAY and then DONE. The actual tool paths will then be calculated and displayed in red followed by a tool path simulation. Don’t forget to save the toolpath with DONE SEQ.

The toolpath definitions are now complete and as we have seen they can be visualised to check accuracy using the PLAY PATH option. A true simulation of the actual machining process can be achieved by choosing MACHINING ⇒ NC SEQUENCE and pick an existing sequence name (ROUGH) then pick PLAY PATH ⇒ NC CHECK ⇒ RUN. This uses software called Vericut to simulate the machining process. A graphical representation of the part should appear on the screen after a few moments. You can use the buttons in the bottom right of the screen to play the toolpath. Use the solid green arrow to play the path now.
Having completed all of the machining steps you may want to check the whole machining process by viewing in Vericut. To join all the steps together you need to create an intermediate file containing all of the toolpaths. CL DATA > OUTPUT > SELECT ONE > OPERATION then pick the operation name MILLING > FILE > DONE and accept the name milling.ncl for the filename. This has created a .ncl file in your working directory. Choose DONE OUTPUT > NC CHECK > CL FILE and select the file you just created. Choosing a final DONE will take you to Vericut where you can view the whole machining process.

**POST PROCESSING**

Post Processing is the act of converting the toolpaths from a standard language called a cutter location file (.ncl) to the language of your specific CNC machines controller. The resultant file in Pro/Engineer is known as a tape file (.tap) which contains all the ‘G’ codes to control the CNC machine. The post processor is a program that performs the translation process. Even though Pro/Engineer comes with some general post processors you must have the correct post processor for your specific machine controller otherwise breakages may occur.

You were instructed how to create a CL file in the previous section. This same file can be used to produce the CNC instructions via post processing. To use this file choose CL DATA > POST PROCESS and then select the filename milling.ncl followed by DONE. Pro/Engineer should now generate a list of the post processors available on your system. These have names from UNCX01.1 to UNCX01.99 (milling) and UNCL01.1 to UNCL01.99 (lathe). As you move the cursor over these names a description of the post processor will be shown at the bottom of the main window. To use the Kryle Machining Centre at Staffordshire University choose UNCX01.99 as the post processor. On completion an information window will be displayed and the file milling.tap will have been created in your working directory. This file should be uploaded to the CNC machine and checked by the operator before running.

**FILE STRUCTURE**

The machining operation in Pro/Engineer brings together data from several places. This requires several files to be associated to the manufacturing process. It is important to understand the structure of these files because if one of these required files is deleted by mistake the whole manufacturing process may be lost. Figure 13 shows this file structure.

![Manufacturing File Structure](image)

### File Structure:
- **Mould.mfg**: Stores all manufacturing parameters
- **Mould.asm**: Assembles model and work parts together
- **Mould.prt**: The part to be machined
- **Mould_work.prt**: The model of the stock material
- **Mould_temp.tph**: Temporary geometry of all toolpaths
- **Milling.ncl**: Cutter location (CL) file
- **Milling.tap**: Post processed file which is sent to CNC machine
- **Cgpro1.***: Temporary files to interface with Vericut
- ***.acl, *.lst, *.mbx, *.tl**: Temporary files associated with creation of .tap file
- **Vericut.log**: Temporary log file for Vericut

![Figure 13: Manufacturing File Structure](image)
The first part of the filenames will vary with your naming convention. The grey boxes or ticked rows in the table must be kept to avoid loss of data. The white files or crossed rows are not essential and can be deleted as they will be recreated if required.

**EXERCISE**

As an exercise you might want to create a second finishing cut in exactly the same way as before however change the value for CUT_ANGLE from 0 to 90 (You can see this value in Figure 11). This value specifies the angle of the cut relative to the X axis – a value of 0 means cut along the X axis – a value of 90 means cut across the X axis. Two finishing cuts are sometimes used like this to improve surface finish.

**REVIEW**

So what should you have learnt?

- How to create a coordinate system.
- How to define stock material.
- How to define an operation.
- How to define a cut using volume mill.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.

**APPENDIX**

**CALCULATING SPEEDS AND FEEDS FOR TURNING**

Most tooling manufacturers catalogues will give formulas or tables for calculating the most efficient speed of rotation (rev/minute) of the work and feed rate (m/sec) of the tool along the work (speeds and feeds). These should be used if available but if you do not have access to this information this simple method of calculating speeds and feeds can be used.

To calculate the tool rotational speed (N rpm)

\[ N = \frac{1000S}{\pi D} \]

where:

- \( D \) = Diameter of tool (mm).
- \( S \) = Recommended surface cutting speed (m/min) from the following table…

<table>
<thead>
<tr>
<th>Material</th>
<th>S for Rough Cuts</th>
<th>S for Finish Cuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Machine Steel</td>
<td>27</td>
<td>30</td>
</tr>
<tr>
<td>Tool Steel</td>
<td>21</td>
<td>27</td>
</tr>
<tr>
<td>Cast Iron</td>
<td>18</td>
<td>24</td>
</tr>
<tr>
<td>Bronze</td>
<td>27</td>
<td>30</td>
</tr>
<tr>
<td>Aluminium</td>
<td>61</td>
<td>93</td>
</tr>
</tbody>
</table>

To calculate the feed rate (m/min)

\[ F = \frac{NkT}{1000} \]

- \( N \) = Tool speed (rpm)
- \( k \) = Machine Constant (use 0.17 for Kryle)
- \( T \) = Number of teeth on tool
Creating a Part

In this part of the tutorial we will introduce you to some basic modelling concepts. If you are already familiar with modelling in Pro Engineer you will find this section very easy. Before starting to work through this tutorial you need to be sitting in front of a computer terminal which has access to Pro Engineer and be logged on. You tutor should have advised you of how to log in already.

Start Pro Engineer by double clicking on the icon on your desktop or from the START menu. The main application window should appear shortly.

The next step is to create your first part. To do this use the menu FILE > NEW.

Well done – you have made your first part! The part contains some features already. The browser on the left shows 3 datum planes and a coordinate system. So what are datum planes? As the word plane implies these are flat areas that can be used as references for defining parts of your model. In some case you can define models with out any datum planes, in other cases they are essential. Many people choose to always have a basic set of default datum planes (like the ones in your model) defined as a starting point for their model. Datum planes are displayed as rectangles that are just big enough to enclose the model. They are given names by the system such as RIGHT, TOP and FRONT.

After choosing the new command a dialog box will appear as shown in Figure 1. Notice that the Part option is already checked and type in mechanica_bar as the name of this part (Note : Pro Engineer does not allow spaces and other special characters in names).

A second dialog will appear offering different options for parts – in particular different units of measurement. Choose mmns_part_solid which means the units of length will be millimetres and units of mass will be Newtons and click on the OK button.
Now let’s start modelling. Models are made from a series of building blocks called features. This model is so simple it will have only one feature called an extrusion.

Choose INSERT > EXTRUDE from the menu. You should see a new toolbar appear like the one in Figure 4. This is called the dashboard and contains all of the options for the type of feature you are creating.

![Figure 4: The Extrude Dashboard](image)

To start creating this feature click on PLACEMENT then DEFINE in the dashboard and the SKETCH dialog appears. Notice that this dialog has many fields but the sketch plane option is highlighted in pale yellow awaiting your input. The sketch plane is a flat surface onto which you will draw your shape. Choose the datum plane TOP by clicking on it in the graphics window or in the browser. The other fields in the Shape dialog are filled in automatically so you don’t need to worry about them at the moment – just click on the SKETCH button.

The graphics screen will change to a black background looking directly on to the sketch plane, and the drawing icons described will appear. You should also see a References dialog. References are used by Pro Engineer to locate dimensions. Pro Engineer guesses at suitable references and in this case will have chosen the Right and Front datum’s as shown in the main graphics window by the dotted lines. This is a good choice in this case so you can CLOSE this dialog.

![Figure 5: Outline Sketch](image)

You are now ready to use sketcher. Choose the circle tool or SKETCH > CIRCLE > CENTER AND POINT and draw the circle with two clicks as shown in Figure 5.

Your window should now look like Figure 5 but the diameter of the circle will be different. If the dimension isn’t positioned exactly as in Figure 5 don’t worry, just choose the select tool and click and drag the dimension text to a new position. Now to set the size of the circle to the correct value, choose the selection tool and double click on the dimension and type in the required value of 20. To end sketching choose and click OK in the Section dialog. To complete this first feature type 100 into the depth field of the dashboard (See Figure 4) and click the green tick to finish.

![Figure 6: First Feature](image)

This is all the modelling you will need to do for this very simple part. You are referred to the other modelling tutorials at http://www.staffs.ac.uk/~entdgc/WildfireDocs if you want to learn more.
Starting an Analysis

You are now ready to start the analysis process. We can try several different load cases on this simple bar and you can compare these with manual calculations.

ProEngineer has two ways of running analyses. You can run the ProMechanica software completely independently or you can run it in integrated mode from within ProEngineer – this has some small limitations but is much more streamlined. We will use integrated mode. Choose APPLICATIONS > MECHANICA now to take your model into analysis. Click OK on the box notifying you of the units of your model.

The MODEL TYPE dialog should appear. If the FEM Mode option is ticked you are running on a machine that does not have a licence for ProMechanica. You will not be able to continue with this tutorial. If this is not ticked accept the default STUCTURE mode and click OK.

ProMechanica can undertake different types of analysis. These are

- Motion – Analysis of mechanisms and assemblies. Only available when in an assembly file.
- Structure – Static loading of parts to calculate stresses. Also calculates vibrations.
- Thermal – Applying thermal gradients to calculate heat distribution.

This tutorial covers the structural analysis only. Make sure the MODE option is set to STRUCTURE and click OK.

Defining Constraints

The first step for this model is to define the constraints. Constraints determine where and how the model is held or fixed in position. We are going to apply a tensile (pulling) force to the bar so one end needs to be fixed.

Choose INSERT > DISPLACEMENT (or you could just pick the icon). The constraint dialog will appear.

Make sure the References option is set to SURFACE(S) then click on below. Now pick one end of the bar then click OK in the small SELECT dialog below the constraint dialog. You have picked one surface to constrain and the symbols show what movements are restricted – they all are, so this surface is fully constrained. Every model to be analysed must be constrained at some point in all six degrees of freedom. Click OK in the constraint dialog to finish.
Defining Loads

Definition of loads is similar to constraints. Choose INSERT > FORCE/MOMENT LOAD or pick the icon to apply a load over a surface. The Force/Moment Load dialog will appear.

Make sure the References option is set to SURFACE(S) then click on below. Pick the OTHER end of the bar (spin the view with the middle mouse button if you need to) then OK in the small SELECT dialog below the constraint dialog.

Defining Materials

The final definition for this analysis is to determine the material for the bar. Choose PROPERTIES > MATERIALS and the MATERIALS dialog will appear. Scroll down the MATERIALS IN LIBRARY to find STEEL and double click on it to transfer it to this model. If you choose EDIT you will see the material parameters defined for steel – the most important ones are Young's Modulus and Poisson's ratio. Press ASSIGN > PART and click on the bar and OK to assign the material. CLOSE the material dialog.
Running an Analysis

That’s it you are ready to run an analysis. Choose ANALYSIS > MECHANICA ANALYSES/STUDIES and the dialog in Figure 13 appears. From this dialog choose FILE > NEW STATIC and type the name BAR. Notice the METHOD is single pass adaptive. This method is used for quick checks to ensure everything is defined correctly and to get rough results quickly. For more accurate results you would change this to multi pass adaptive. Leave it as it is for now and OK. Choose the icon to run this analysis choosing yes for error detection. Press to watch the report of the analysis as it runs. After a few seconds (longer on a slower machine!) the report should state RUN COMPLETED. Close the REPORT dialog and the ANALYSES dialog.

![Image](Image-960594168226738x-376621653585586x-1963295238285742)

Figure 13 : Analyses and Design Studies Dialog

Seeing the Results

Results are handled in a separate though integrated module of Pro Engineer. Choose ANALYSIS > RESULTS (Note : this icon was available in the Analyses dialog as well). The main graphics window will go blank and the menus and icons will all change. Choose INSERT > RESULT WINDOW or the icon. In the RESULT WINDOW DEFINITION dialog that appears press and click (not double click) on the folder which is the same name as the analysis that is BAR. Make sure all the options are the same as in Figure 14 then click OK AND SHOW.

![Image](Image-960594168226738x-376621653585586x-1963295238285742)

Figure 14 : Results Definition

The resultant plot shows the stress distribution over the whole bar where the colours show the stress ranges and the values are shown on the scale to the right. The unexpected variation of stress at one end is due to being local to a constraint which can affect the result. Choose INFO > DYNAMIC QUERY to get more feedback on actual values. Now as you move the cursor over the model you will get the actual value at the cursor reported in the dialog box. You will see that the majority of the model is at about 3.18 N/mm² (notice the units are reported at the top left of main window). Is this value correct? For tension stress is calculated by load/area. The cross-sectional area of this bar is \( \pi \times \frac{20}{4} = 314 \text{mm}^2 \). The load we applied was 100000N so the stress should be \( \frac{100000}{314} = 318 \text{ N/mm}^2 \). Spot on - even though this was only a quick single pass adaptive check!

What else can we show? Choose EDIT > RESULT WINDOW to bring back the dialog in Figure 14. Below QUANTITY change STRESS to DISPLACEMENT then OK AND SHOW. Again a coloured plot appears with the colours relating to the amount of displacement. One end is blue with a displacement of 0 because it was constrained. The other end has stretched as the load is applied so this is shown in red with a displacement value of 0.00158mm.

We can combine the display of displacement with stress in a very interesting and informative way. Choose EDIT > RESULT WINDOW to bring back the dialog in Figure 14. Below QUANTITY change DISPLACEMENT back to STRESS then on the DISPLAY OPTIONS tab tick DEFORMED and ANIMATE. OK AND SHOW should now show the original stress plot on a model that is stretching as the load is applied. You
can control the animation with the icons at the top of the window. Close the results window with FILE > EXIT RESULTS then NO.

Additional Analysis – Bending

Let's try a different analysis. We will apply a bending moment to the bar rather than a tensile load. Pick the tensile load by clicking on the yellow arrows in the main graphics window (they turn red) then choose EDIT > DEFINITION. You should see the Force/Moment Load dialog (as in Figure 9). Change the load value to 0 in the Y direction and to 1000 in the Z direction. Check the load direction is as shown in Figure 15.

Figure 15 : Bending Moment

Re run the analysis and view the results. Note the value of the maximum stress. What should this value be?

\[
\text{Bending Stress} = \frac{My}{I} \\
\text{Second Moment of Area (I) for a circular beam} = \frac{\pi d^4}{64} = \frac{\pi 20^4}{64} = 7854 \text{mm}^4 \\
\text{Bending Stress} = 1000 \times 100 \times 10 / 7854 = 127 \text{N/mm}^2
\]

Do your results compare? You may find they are close but not exact. The analysis you performed was a quick single pass adaptive analysis. Just by looking at the results you will see that the maximum value does not occur at the end of the bar where it should. If you were to change to a multi pass adaptive analysis (by choosing EDIT > ANALYSIS/STUDY in the dialog in Figure 13) you should see improved results – especially if you decrease the percent convergence parameter and increase the maximum polynomial order. Of course you would have to re run the analysis if you change these parameters.

Additional Analysis – Torsion

To apply a torsional load we will need to create a cylindrical coordinate system. Choose INSERT > MODEL DATUM > COORD SYSTEM. In the COORDINATE SYSTEM dialog change the TYPE of the coordinate system to CYLINDRICAL then pick the RIGHT and FRONT datums and then the end of the bar IN THAT ORDER – you should get the icon displayed as shown in Figure 16.

Figure 16 : Cylindrical Coordinate System

Pick the bending load by clicking on the yellow arrows in the main graphics window (they turn red) then choose EDIT > DEFINITION. You should see the Force/Moment Load dialog (as in Figure 9). Click on below COORDINATE SYSTEM then pick the coordinate system you just created and OK. The load directions will change from X, Y and Z to R, Theta and Z. Next click on ADVANCED and change the DISTRIBUTION to TOTAL LOAD AT POINT and click on below DISTRIBUTION then pick a point on the circular edge of the end of the bar (since we will apply a moment force the location of this point is not critical but it must not be on the Z axis of the coordinate system). Enter a value of 100000 for Z in the MOMENT column and 0 in all the other FORCE fields. Preview the load direction is as shown in Figure 17.
Re-run the analysis and view the results for maximum shear stress. Note the value of the maximum stress. What should this value be (Torsional Stress = Tr/J)?

**Additional Analysis – Natural Frequency**

Another analysis type that can be undertaken by finite element analysis is to determine the natural frequency of vibration. This type of analysis does not require any loads to be applied (if any are applied they will be ignored). You do have to create a new analysis to perform this type of analysis. Choose ANALYSIS > MECHANICA ANALYSES/STUDIES and the dialog in Figure 13 appears. In this dialog choose FILE > NEW MODAL and type a name. Having created the analysis, choose the icon like before. The results for this analysis show the vibrations which will occur at different frequencies. Choose ANALYSIS > RESULTS then INSERT > RESULT WINDOW. Note that Mode 1 is ticked so in the DISPLAY tab pick tick DEFORMED then OK and SHOW. Repeat this, creating four different results windows, one for each of the four modes of vibration calculated. The first two are very similar vibrating in the vertical and horizontal planes. The third is a torsional vibration and the fourth is a second order vibration.

From Blevins’ “Formulas for Natural Frequency and Mode Shape”, the natural frequency of a clamped-free beam is:

\[ F = \left( \lambda^2 \sqrt{EI/M} \right) / \left(2\pi L^2 \right) \]

where:
- \( \lambda = 1.875 \) for first mode
- \( L = \) length of cantilever \((m)\)
- \( E = \) modulus of elasticity \((N/m^2)\)
- \( I = \) area moment of inertia \((m^4)\)
- \( m = \) mass per unit length of beam \((kg/m)\)

Which calculates the first natural frequency as 1420 Hz.

**Review**

So what should you have learnt?

- How to start analysis.
- How to define loads, constraints and materials.
- How to run an analysis.
- How to show results of an analysis.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.

**Where Next?**

Here is a more complicated model of a steel bracket which you can download from [http://www.staffs.ac.uk/~entdgc/WildfireDocs](http://www.staffs.ac.uk/~entdgc/WildfireDocs) under the bracket link. Try applying a 10000N vertical load to the circular hole and constraining the back surface as though it were glued to a wall.
Thermal Finite Element Analysis

It is anticipated that before starting this tutorial that you have completed the tutorial ‘Introduction to Finite Element Analysis’. You should therefore be familiar with the process of defining constraints, loads, materials and running analyses. If you are familiar with these techniques then the transition to performing thermal analyses will be straightforward as there is a direct correlation between stress and thermal analysis.

In a stress analysis loads (N) are applied to the model – in thermal analysis the equivalent is a thermal load measured in Watts. In a stress analysis boundary conditions are applied (known as constraints) which restrict the movement of the model – in thermal analysis the equivalent boundary constraints are either temperature (°C) or convection coefficient W/m²K).

A sample model of a saucepan is provided for you to work with in this tutorial. There is a link to it next to this tutorial at http://www.staffs.ac.uk/~entdgc/WildfireDocs/tutorials.htm and it is called saucepan.prt. This part should be downloaded to your working directory before starting the tutorial.

Starting a Thermal Analysis

You are now ready to start the analysis process. We will be investigating a relatively simple problem. If the saucepan is stood on the hot cooker for a long period of time how hot will the handle get – will it be too hot to hold? We are not interested in the heating up period just the steady state conditions after which the saucepan will not get any hotter.

ProEngineer has two ways of running analyses. You can run the ProMechanica software completely independently or you can run it in integrated mode from within ProEngineer – this has some small limitations but is much more streamlined. We will use integrated mode. Choose APPLICATIONS > MECHANICA now to take your model into analysis. Click OK on the box notifying you of the units of your model.

The MODEL TYPE dialog should appear. If the FEM Mode option is ticked you are running on a machine that does not have a licence for ProMechanica. You will not be able to continue with this tutorial.

ProMechanica can undertake different types of analysis. These are

- Structure – Static loading of parts to calculate stresses. Also calculates vibrations.
- Thermal – Applying thermal gradients to calculate heat distribution.

This tutorial covers the structural analysis only. Make sure the MODE option is set to THERMAL and click OK.

Defining Thermal Loads

The first step is to define the thermal loads on this saucepan. Thermal loads are heat sources applied to the model. In this case the heat source is the gas flame or an electric element which applies heat to the base of the pan. Choose INSERT > HEAT LOAD then pick SURFACE from the side menu or choose the icon. Select the base of the saucepan as the heat source and fill in the name as HeatSource and enter a heat load value Q of 3500000mW as shown in Figure 1.

![Figure 1: Thermal Load](image)

Defining Boundary Conditions

For this analysis the boundary conditions occur where the heat dissipates from the saucepan into the ambient air by means of convection. Choose INSERT > CONVECTION CONDITION then pick SURFACE from the side menu or choose the icon. Select all the surfaces of the saucepan except the base (hold CTRL key whilst picking) and fill in the name as...
Ambient and enter a convection coefficient of 0.03 and a Bulk Temperature (the temperature of the ambient air) as shown in Figure 2.

Running an Analysis
That's it you are ready to run an analysis. Choose ANALYSIS > MECHANICA ANALYSES/STUDIES and the dialog in Figure 4 appears. From this dialog choose FILE > NEW STEADY STATE THERMAL and type the name SAUCEPAN. Notice the METHOD is single pass adaptive. This method is used for quick checks to ensure everything is defined correctly and to get rough results quickly. For more accurate results you would change this to multi pass adaptive. Leave it as it is for now and OK. Choose the icon to run this analysis choosing yes for error detection. Press to watch the report of the analysis as it runs. After a few seconds (longer on a slower machine!) the report should state RUN COMPLETED. Close the REPORT dialog and the ANALYSES dialog.

Defining Materials
The final definition for this analysis is to determine the material for the saucepan. Choose PROPERTIES > MATERIALS and the MATERIALS dialog will appear. Scroll down the MATERIALS IN LIBRARY to find AL2014 and double click on it to transfer it to this model. If you choose EDIT you will see the material parameters defined for aluminium – the most important ones are Specific Heat Capacity and Thermal Conductivity. Press ASSIGN > PART and click on the saucepan and OK to assign the material. CLOSE the material dialog.

Seeing the Results
Results are handled in a separate though integrated module of Pro Engineer. Choose ANALYSIS > RESULTS (Note : this icon was available in the Analyses dialog as well). The main graphics window will go blank and the menus and icons will all change. Choose INSERT > RESULT WINDOW or the icon. In the RESULT WINDOW DEFINITION dialog that appears press and click (not double click) on the folder which is the same name as the analysis that is SAUCEPAN.
Thermal Finite Element Analysis

Make sure all the options are the same as in Figure 5 then click OK AND SHOW.

The resultant plot shows the temperature distribution over the saucepan where the colours show the temperature ranges and the values are shown on the scale to the right. Choose INFO > DYNAMIC QUERY to get more feedback on actual values. Now as you move the cursor over the model you will get the actual value at the cursor reported in the dialog box. You will see that the end of the handle is at around 40-50ºC. Is this too hot to hold?

Additional Analysis

You have now learnt the basics of thermal analysis. By returning to the modelling window and changing certain parameters you could answer various questions related to this design. Try to answer the following questions now…

- What is the effect on the handle temperature if the material is changed to STEEL? (Hint: PROPERTIES > MATERIALS)

- To accommodate the change to steel the main part of the saucepan must be increased in thickness to 4mm thick. What is the effect on the handle temperature? (Hint: You will need to return to APPLICATION STANDARD and EDIT the first revolve feature to change its thickness)

- How high can the heat load be increased before an aluminium saucepan would melt at 600ºC? (Hint: Locate HeatSource in the Model Tree window and EDIT DEFINITION. Increase Q value and analyse again. Repeat until max temperature exceeds 600ºC)

- The inside surface of the aluminium saucepan is coated in a non-stick material which reduces the convection coefficient to 0.02. What is the effect on the handle temperature? (Hint: You will need to define a second CONVECTION CONDITION for these surfaces with a different h value. Make sure you remove these surfaces from the original convection condition)

Combining Analyses

One of the consequences of heating things up is that they expand. This expansion is directly related to the temperature rise and can be calculated using the coefficient of expansion for that material. ProMechanica knows about this so it can calculate the expansion for you. This is done using a structure analysis. Here is how – but you should have covered structural analyses in the ‘Introduction to Mechanica’ tutorial so the instructions will be brief.

From the Mechanica modeling window change to structural analysis by choosing EDIT > MECHANICA MODEL TYPE. Like all structural analyses the model must be constrained. Lets assume the cook has picked up this saucepan (using an oven glove if necessary!) so to (roughly) simulate this INSERT > DISPLACEMENT constraint to the SURFACE at the very end of the handle. Fix movement in all directions.

The second thing required for a structural analysis is a load. In this case the load is due to the expansion caused by the temperatures already calculated in the Saucepan thermal analysis. These can be applied using INSERT > TEMPERATURE LOAD > MEC/T…The Design Study and Analysis should already be set to Saucepan in the MECT Temperature
dialog. This means that the temperatures previously calculated will be applied over the whole model causing differential amounts of expansion.

The final thing required for a structural analysis is a material but you have already assigned that as part of the thermal analysis so there is no need to do that here.

Choose ANALYSIS > MECHANICA ANALYSES/STUDIES. From this dialog choose FILE > NEW STATIC and type the name EXPANSION and OK. Choose the icon to run this analysis choosing yes for error detection. If you get an error message about model having changed since thermal analysis was run simply choose EDIT > MECHANICA MODEL TYPE to change to thermal mode – run the analysis again – return to structure mode and run this analysis). Press to watch the report of the analysis as it runs. After a few seconds (longer on a slower machine!) the report should state RUN COMPLETED. Close the REPORT dialog and the ANALYSES dialog.

To see the results choose ANALYSIS > RESULTS (Note : this icon was available in the Analyses dialog as well). The main graphics window will go blank and the menus and icons will all change. Choose INSERT > RESULT WINDOW or the icon. In the RESULT WINDOW DEFINITION dialog that appears press and click (not double click) on the folder which is the same name as the analysis that is EXPANSION. Make sure all the options are the same as in Figure 7 and also that DEFORMED is ticked in the Display Options tab then click OK AND SHOW.

In this plot the colours denote the internal stresses due to expansion and the shape is the exaggerated shape due to expansion. (Note temperature loads can be combined with any other structural load so you could for example add a gravity load to the saucepan and see the stresses due to gravity as well though they would be small compared to thermal expansion.)

**Review**

So what should you have learnt?

- How to start analysis.
- How to define thermal loads, boundary conditions and materials.
- How to run an analysis.
- How to show results of a thermal analysis.
- How to use temperature loads in structural analyses.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
You have probably already realised that the initial model is very important and can affect both the result accuracy and the time taken to perform the analysis. For example analysis is often undertaken on models where the majority of radii and other small features which have no significance on the results have been removed of suppressed – this can reduce analysis time tremendously. Of course it is down to skill of the operator to decide which features can be suppressed without affecting the results.

A particular area where correct modelling can improve analysis speed is in parts which have lots of thin walls of constant thickness. Examples of these include sheet metal parts (simple brackets or complex car bodies) and even moulded parts (since good moulding practice requires constant wall thicknesses wherever possible). The modelling technique used for these parts is called shell modelling. Here the designer will model the centreline of a feature then assign a thickness to the feature. Pro Engineer combines the information to generate a solid model which looks identical to one made from normal modelling techniques. When analysing the model the shell information can be used to reduce the analysis time – experience has shown that this can be by as much as 100 times in extreme cases.

Here is an example of the techniques involved. The tutorial uses a realistic part so the process is quite complex. Pay careful attention as you read – especially if you have not completed all of the modelling exercises in this series.

Even if you don't intend to use shell modelling the tutorial is worth completing as it introduces other techniques related to analysis. If you find the modelling instructions difficult to follow then have you completed the modelling tutorials? If you haven't you might find it helpful to do so.

The part we are going to analyses is the injection moulded base to a swivel chair as shown in Figure 1. The first thing you should notice about such a part is that it has 5 identical legs. This should immediately show you that you can save both modelling and analysis time by only looking at one of the five legs. Even more time can be saved if you recognise that each leg has a plane of symmetry along its length (see Figure 2) so even more modelling and analysis time can be saved.

Here is how to model the leg. Create a new part using FILE > NEW with a name of chair_leg. Choose the mmns_part_solid template.
Next create an extrusion (INSERT > EXTRUDE). From the dashboard choose the SKETCH icon then pick the datum plane TOP by clicking on it in the graphics window or in the browser then click on the SKETCH button.

Draw the sketch in Figure 3. Exit sketcher and type in the extrusion distance of 30. Finish the feature with.

![Figure 3: First Feature Sketch](image)

Next create an revolution (INSERT > REVOLVE). From the dashboard choose the SKETCH icon then pick the datum plane FRONT by clicking on it in the graphics window or in the browser then click on the SKETCH button.

Draw the sketch in Figure 4 – notice that the top line is inline with the top of the first feature. Draw a centreline on top of the RIGHT datum Figure 3.

Exit sketcher and type in the revolve angle of 36. Finish the feature with

![Figure 4: Second Feature Sketch](image)

Add a 13mm round (INSERT > ROUND) to the edge around the top of the leg – it should automatically propagate all around as the edges are all tangent.

![Figure 5: A Round](image)

Add a 16mm round (INSERT > ROUND) to the edge between the two features.

Add a 13mm round (INSERT > ROUND) to the edge around the top of the leg – it should automatically propagate all around as the edges are all tangent.

![Figure 6: A Second Round](image)

The steps so far should be familiar to you – there is nothing new. The next step should also be known to you – shelling. Create a shell feature to hollow out the leg using INSERT > SHELL. Pick the two surfaces shown in red in Figure 7a. Choose a shell thickness of 4. Before you finish this feature stop and think. The surface shown in Figure 7b is a web between two legs which should be 4 thick but only half of it is in this section of the model so it should be 2 thick here. This can be achieved in the shell command. Click on the references tab then click to activate the Non-default thickness pane you now can pick surfaces on the model which will have a different thickness to the rest of the model. Click the surface shown in Figure 7b and change the thickness for this surface to 2.
Now for something new in extrusions. Create a new extrusion INSERT > EXTRUSION. From the dashboard choose the SKETCH icon then pick the datum plane TOP by clicking on it in the graphics window or in the browser then click on the SKETCH button. Draw the sketch in Figure 9 (a simple semicircle) and exit sketcher. On the dashboard (Figure 8) choose the up to next surface option and use the button to make sure the extrusion is going the correct direction – towards the inside of the leg.

Figure 7 : Creating the Shell
Figure 8 : The Dashboard

Now click on the thicken sketch button. This button takes the single line sketch you have drawn and adds material to the thickness typed in the box next to the button – 4. Also the second button decides which side of the sketch to add material – click it till the material is outside of the arc.

Finish the feature with .

Figure 9 : Thin Protrusion

Analysing Shell Models

That’s enough modelling for now – more later. We will perform an analysis. Choose APPLICATION > MECHANICA now to take your model into analysis. Click OK on the box notifying you of the units of your model. Make sure the MODE option is set to STRUCTURE and click OK.

The first step is to define some simplistic constraints. In this case the hole where the central pillar of the stanchion fits needs to be fixed. Choose INSERT > DISPLACEMENT CONSTRAINT (or you could just pick the icon). The constraint dialog will appear. Click on below Surface(s) then pick the surface in this model which is part of the hole (Figure 10) then OK to return to the constraint dialog and OK to leave this surface fully constrained.
Definition of loads is similar to constraints. Choose INSERT > FORCE/MOMENT LOAD or pick the icon to apply a load over a surface. Click on below Surface(s) then pick the surface in Figure 11 then OK to return to the Force/Moment dialog. Type a value of 300 in the correct field for a vertical load on the leg (probably the Y direction). This will be half the total load applied to a single leg as we are only modelling half the leg. Press PREVIEW to check the arrows point in the correct direction. Click OK in the Force/Moment dialog to finish.

Choose PROPERTIES > MATERIALS and the MATERIALS dialog will appear. Scroll down the materials library to Find NYLON and double click on it to transfer it to this model. Press ASSIGN > PART and click on the chair leg and OK to assign the material. CLOSE the material dialog.

That’s it you are ready to run an analysis. Choose ANALYSIS > MECHANICA ANALYSES/STUDIES. From this dialog choose FILE > NEW STATIC and type the name leg and OK. Choose the icon to run this analysis choosing yes for error detection. Press to watch the report of the analysis as it runs. Note how many elements are used in this analysis and the elapsed time to complete the analysis. Close the REPORT dialog and the ANALYSES dialog.

The analysis should complete correctly and you could review these results if you wanted. This has performed a normal analysis – it has not used any information about shells at all. So how do we use shell information? The easiest way to do this is to use the automated INSERT > MIDSURFACES then choose AUTO DETECT. This takes any shelled surfaces or thickened protrusions and automatically generates thin shells from them. After this command you can see the shells by choosing COMPRESS > SHELLS ONLY > SHOWCOMPRESS.

Try running the analysis again – in the Status dialog you should notice it now uses Shell elements (Figure 13) and the time taken for the analysis will be much shorter. A look at the results will show you the display as shells too.
There is a problem with the analysis! Look carefully at the leg and you will see that as it is loaded it twists. This wouldn't happen in real life because we would have a full leg not just half. We can correctly simulate the other half of the leg without having to model it by correct use of constraints. Choose INSERT > SYMETRY CONSTRAINT and the symmetry constraint dialog will appear. Pick the edges in Figure 14 then OK to return to the constraint dialog and OK again to finish.

NOTE: edges are selected rather than the central surface because the surface ‘disappears’ when the model is collapsed into shells.

There is another problem with the analysis! There is another symmetry on the surface in Figure 16.

NOTE:- Cyclic Symmetry constraints (as these are called) can be defined using the symmetry constraint type. If we were analysing a whole leg this type of constraint could be used Since we are only analysing half a leg we cannot use this automated method – we will have to replicate this using displacement constraints.

This time the constraint is not along the normal X, Y or Z axes. We need to make a new definition for the direction of X, Y and Z. This is done in Pro Engineer with a coordinate system. We need to create one now. Choose INSERT > MODEL DATUM > COORDINATE SYSTEM. The coordinate system dialog is displayed. This is an ‘intelligent’ dialog – it will try and make sense of what you select. Click on the 3 surfaces/datums now in the order shown in Figure 15. Notice the new yellow coordinate system icon – the X direction is at right angles to the FIRST surface you picked and this is the direction which we will constrain. In the properties tab type the name ANGLED. Click OK to close the dialog and ANGLED should appear in the model tree under Simulation Features.

We will now add another constraint using this coordinate system. Choose INSERT > DISPLACEMENT CONSTRAINT. The constraint dialog will appear. Click on below Surface(s) then pick the surface highlighted in red in Figure 16 then OK to return to the constraint dialog. To use another coordinate system click on below Coordinate System then pick the ANGLED coordinate system. This constraint needs to stop movement across the symmetry plane (X) whilst allowing free movement in the plane (Y&Z). Set the constraints as shown in Figure 16b for both Translation and Rotation. (Hint – For symmetry rotation and translation constraints are opposite).
Figure 16: Second Symmetry Constraints

Reanalyse the part and the stress and deflection patterns should accurately mimic a real leg.

Figure 17: The Analysis

If you look at the deflection at the end of the leg it is too high. Normally such a structure would have strengthening ribs to improve the strength. Here is how to add such ribs – they are all added as thickened protrusions. Create a new extrusion INSERT > EXTRUSION. From the dashboard choose the SKETCH icon then pick the datum plane TOP by clicking on it in the graphics window or in the browser then click on the SKETCH button. Draw the appropriate sketch for this feature (see the comic strip in Figure 18) and exit sketcher.

On the dashboard choose the up to next surface option and use the button to make sure the extrusion is going the correct direction – towards the inside of the leg. Now click on the thicken sketch button. This button takes the single line sketch you have drawn and adds material to the thickness typed in the box next to the button – 4. Also the second button decides which side of the sketch to add material – click it till the material is on the correct side. Finish the feature with .
Perform an analysis on the strengthened model to determine the improvement in strength and stiffness of the leg.

**Review**

So what should you have learnt?

- How to create variable thickness shells.
- How to create thin extrusions.
- How to create symmetry constraints.
- How to use coordinate systems in analysis.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.
Joint Analysis

This tutorial looks at different ways of analysing bolted joints within Pro Mechanica. This is an important technique as correct analysis may have significant effects on the results for the whole part being analysed. The tutorial uses a simple bracket which can be downloaded from http://www.staffs.ac.uk/~entdgc/WildfireDocs/tutorials.htm under the bracket link.

Bonded Analysis

As a base point for our comparison of different methods of simulating joints we will analyse the bracket as though it was bonded (glued) to the wall (if you did the Introduction to Mechanica tutorial you should already have done this as a further exercise). Even this is a simplification and if you wanted to correctly analyse a bonded joint you would approach it differently to account for bond flexibility and other factors.

You are now ready to start the analysis process so load the part into Pro Engineer.

Choose APPLICATION > MECHANICA now to take your model into analysis. Click OK on the box notifying you of the units of your model. From the MODEL TYPE dialog choose STRUCTURE and OK.

As always the first step for this model is to define the constraints. We are going to roughly simulate the bracket being bonded to a wall so the back face needs to be fixed. INSERT > DISPLACEMENT (or you could just pick the icon). Click on below Surface(s) in the constraint dialog then pick the back surface of the bracket then OK to return to the constraint dialog. You have picked one surface to constrain and the symbols show what movements are restricted – they all are so this surface is fully constrained. Click OK to finish.

Next define the load on the bracket. Choose INSERT > FORCE/MOMENT LOAD or pick the icon to apply a load over a surface. Click on below Surface(s) in the Force/Moment dialog then pick the surface highlighted in Figure 3 then OK to return to the Force/Moment dialog. Type a value of -10000 in the Y field below Force. Press PREVIEW – the arrows should point the same way as in Figure 3. Click OK in the Force/Moment dialog to finish.

The final definition for this analysis is the material. Choose PROPERTIES > MATERIALS and the MATERIALS dialog will appear. Scroll down the materials library in the Materials dialog to Find STEEL and double click
Joint Analysis

on it to transfer it to this model. Press ASSIGN > PART and click on the bracket and OK to assign the material. CLOSE the material dialog.

That’s it you are ready to run an analysis. Choose ANALYSIS > MECHANICA ANALYSES/STUDIES and in the dialog that appears choose FILE > NEW STATIC and type the name BONDED and press OK. Choose the icon to run this analysis choosing yes for error detection. Press to watch the report of the analysis as it runs. After a few seconds (longer on a slower machine!) the report should state RUN COMPLETED. Close the REPORT dialog and the ANALYSES dialog.

After the analysis completes choose ANALYSIS > RESULTS menu. The main graphics window will go blank and the menus and icons will all change. Choose INSERT > RESULT WINDOW or the icon. In the RESULT WINDOW DEFINITION dialog that appears press and click (not double click) on the folder which is the same name as the analysis that is BONDED. Make sure all the options are the same as in Figure 4 then click OK AND SHOW.

Figure 4 : Results Definition

That’s the first analysis complete. Just note the stress distribution in the bracket for now and then try the next method. Choose FILE > EXIT RESULTS before continuing.

Creating the Holes

Now let’s try to analyse a bolted joint – for which we need some holes! Modelling is done outside of Pro Mechanica so choose APPLICATION > STANDARD. Next choose INSERT > EXTRUDE from the menu. You should see a new toolbar appear like the one in Figure 5. This is called the dashboard and contains all of the options for the type of feature you are creating.

Figure 5 : The Extrude Dashboard

To start creating this feature choose PLACEMENT > DEFINE in the dashboard and the Section dialog appears. Notice that this dialog has many fields but the sketch plane option is highlighted in pale yellow awaiting your input. The sketch plane is a flat surface onto which you will draw your shape. Choose the back surface of the bracket (the one you constrained in Figure 2) by clicking on it in the graphics window. The other fields in the Shape dialog are filled in automatically so you don’t need to worry about them at the moment – just click on the SKETCH button.

The graphics screen will change to a black background looking directly on to the sketch plane, and the drawing icons described will appear. You can CLOSE the References dialog.

You are now ready to use sketcher. Choose SKETCH > CIRCLE > CONCENTRIC and draw the circles with two clicks – the first click on the radius in the corner of the bracket, the second click to determine the size as shown in Figure 6 – press the middle mouse to finish drawing each circle. You should be able to get all four circles to lock on to the same size and showing an R1 symbol.

Figure 6 : Sketch for Four Holes

Your window should now look like Figure 6 but the diameter of the circle will be different. To set the size of the circle to the correct value, choose
Joint Analysis

the selection tool and double click on the dimension and type in the required value of 12. To end sketching choose and click OK in the Section dialog. To complete this first feature at the dashboard choose the thru all option and to remove (rather than add) material if the extrusion is going in the wrong direction press (see Figure 6b). Click the green tick to finish. You should have four bolt holes.

Edge Constraint

Now we have to modify the analysis to take account of these holes. The load and material will stay the same but the constraints will alter.

Choose APPLICATION > MECHANICA now to take your model back into analysis. From the MODEL TYPE dialog choose STRUCTURE and OK.

We are going to simulate a bolted joint by just holding the edges of the holes in position. We could delete the surface constraint we applied earlier and a new one but we can learn another technique. Choose INSERT > DISPLACEMENT (or you could just pick the icon). On the dialog there is a NEW button next to the MEMBER OF SET FIELD. Click on this button to create a new set of constraints by default called CONSTRAINTSET2. Click OK to return to the CONSTRAINT dialog. Below the word REFERENCES it will say SURFACE(S) – change this to EDGES(S)/CURVE(S) then click on below then pick the back edges of the holes in the bracket holding the CTRL key. When you have picked all 8 edges click OK to return to the constraint dialog. Click OK to finish defining this constraint.

The new constraints have been defined. They are stored in a separate set from the original constraint. You are ready to run an analysis. Choose ANALYSIS > MECHANICA ANALYSES/STUDIES and in the dialog choose EDIT > COPY and press OK. You now have two analyses which are currently identical except for their name. Choose EDIT > ANALYSIS/STUDY to edit the copy. Change the name of the analysis to EDGES. Below CONSTRAINTS choose CONSTRAINTSET2 so that the analysis will use only the edge constraints just defined then click OK.

Choose the icon to run this new analysis choosing yes for error detection. Press to watch the report of the analysis as it runs. After a few seconds (longer on a slower machine!) the report should state RUN COMPLETED. Close the REPORT dialog and the ANALYSES dialog. After the analysis completes choose ANALYSIS > RESULTS menu. The main graphics window will go blank and the menus and icons will all change. Choose INSERT > RESULT WINDOW or the icon. In the RESULT WINDOW DEFINITION dialog that appears press and click (not double click) on the folder which is the same name as the analysis that is BONDED. Make sure all the options are the same as in Figure 8 then click OK AND SHOW.

Figure 7 : Constraint Edges

Figure 8 : Results Definition

The results are very different. There are some very high stress concentrations around the edges you constrained which are masking the stresses elsewhere in the bracket. Stress concentrations around constraints are common but can be ignored as they are not realistic. If you look at the stress legend it goes from (about) 1.8e-1 to 4.3e2 whereas in the BONDED analysis it went from (about) 1.07e-2 to 2.2e1. To make an
accurate comparison we can show the two analyses side by side with the same legend values.

Choose INSERT > RESULT WINDOW or the icon. In the RESULTS WINDOW DEFINITION dialog that appears press and click (not double click) on the folder for the BONDED analysis then click OK AND SHOW. You will see the two analyses together. Click on each window in turn then choose FORMAT > LEGEND. Type 2 as the minimum value and 20 as the maximum value so that you can get a fair comparison.

Choose ANALYSIS > MECHANICA ANALYSES/STUDIES and EDIT >COPY a new analysis called SURFACES which uses CONSTRAINTSET3. Run the analysis and show the results of the three analyses side by side with the same legend values.

Accurate Analysis of Bolted Joints

In many situations where the area around the bolt is not critical the surface constraint technique would be acceptable (ignoring the stress concentrations around the holes). For greater accuracy a more complex technique is required.

To understand the technique it first important to understand how a bolted joint works. It may seem straight forward but it is not! A good source of research for this is where there is a tutorial on bolted joints.

We will need to define the area where the washer contacts the face of the bracket. Currently this is a single surface so we need to split it into what are called regions. This is done in Pro Mechanica using INSERT > VOLUME REGION > CREATE > EXTRUDE > DONE (we use volume region rather than surface region as we can split the front and back surfaces in one command). Pick the front face of the bracket as the sketch plane then OKAY > DEFAULT to enter sketcher. Draw 4 equal diameter circles concentric to the four holes. After exiting sketcher choose THRU ALL > DONE then OK. What this has done is created an imaginary extrusion. Where this extrusion passes through the bracket it has split the surfaces. This will only be visible if you are in a non shaded display.
We will also need to create 8 datum points – 1 at each end of the four holes. Choose INSERT > MODEL DATUM > POINT > POINT. The DATUM POINT dialog appears. Click on the edge of one of the holes and a datum point is created where you pick. We want the datum point to be at the centre of the arc so in the DATUM POINT dialog click on the word ON and change it to CENTRE then click on NEW POINT. Repeat this for the 8 points. Don’t forget to click on new point after each point is defined. Close the dialog with OK.

Now the bolt needs to be connected to the bracket. If the bolt is designed and fitted correctly it should not move relative to the bracket so we will use rigid connections. These don’t allow any movement. Choose INSERT > CONNECTION > RIGID CONNECTIONS > CREATE and in the RIGID CONNECTION dialog click on icon then pick the edges of the volume region and the adjacent datum point IN THAT ORDER. Click OK then close the dialog with OK. Repeat for each end of the four holes (8 times).
Finally, all that is needed is to correctly constrain the model. Create a new DISPLACEMENT CONSTRAINT in a new constraint set. Change the reference type to POINT and pick all four datum points on the back of the bracket. You should now be able to analyse this model creating a new analysis called SPIDER which use the correct constraint set. (It is called a spider connection for historical reasons).

Compare the results of all four analyses.

**Review**

So what should you have learnt?

- How to create various types of constraints.
- How to define volume regions.
- How to define rigid connections.
- How to compare results of an analysis.

Any problems with these? Then you should go back through the tutorial – perhaps several times – until you can complete it without any help.

---

Figure 16 : Comparison 4